aboutsummaryrefslogtreecommitdiffstats
path: root/recipes/libgles/libgles-omap3_5.01.00.01.bbappend
diff options
context:
space:
mode:
Diffstat (limited to 'recipes/libgles/libgles-omap3_5.01.00.01.bbappend')
-rw-r--r--recipes/libgles/libgles-omap3_5.01.00.01.bbappend42
1 files changed, 42 insertions, 0 deletions
diff --git a/recipes/libgles/libgles-omap3_5.01.00.01.bbappend b/recipes/libgles/libgles-omap3_5.01.00.01.bbappend
new file mode 100644
index 00000000..82bfdb23
--- /dev/null
+++ b/recipes/libgles/libgles-omap3_5.01.00.01.bbappend
@@ -0,0 +1,42 @@
+#############################################################################
+##
+## Copyright (C) 2014 Digia Plc and/or its subsidiary(-ies).
+##
+## This file is part of the Qt Enterprise Embedded Scripts of the Qt
+## framework.
+##
+## $QT_BEGIN_LICENSE$
+## Commercial License Usage Only
+## Licensees holding valid commercial Qt license agreements with Digia
+## with an appropriate addendum covering the Qt Enterprise Embedded Scripts,
+## may use this file in accordance with the terms contained in said license
+## agreement.
+##
+## For further information use the contact form at
+## http://qt.digia.com/contact-us.
+##
+##
+## $QT_END_LICENSE$
+##
+#############################################################################
+
+FILESEXTRAPATHS_prepend := "${THISDIR}/${PN}:"
+
+BINLOCATION_omap3 = "${S}/gfx_rel_es5.x"
+BINLOCATION_beaglebone = "${S}/gfx_rel_es8.x"
+
+LIBGLESWINDOWSYSTEM = "libpvrPVR2D_FLIPWSEGL.so.1"
+
+# Inhibit warnings about files being stripped.
+INHIBIT_PACKAGE_DEBUG_SPLIT = "1"
+
+pkg_postinst_${PN}_append() {
+ESREV=$(echo ${BINLOCATION} | grep -Po '(\d+)(?!.*\d)' )
+echo ${ESREV} > $D${sysconfdir}/powervr-esrev
+}
+
+RRECOMMENDS_${PN} = "omap3-sgx-modules"
+RRECOMMENDS_${PN}-blitwsegl = ""
+RRECOMMENDS_${PN}-flipwsegl = ""
+RRECOMMENDS_${PN}-frontwsegl = ""
+RRECOMMENDS_${PN}-linuxfbwsegl = ""