summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorRichard Purdie <richard.purdie@linuxfoundation.org>2018-12-20 10:53:30 +0000
committerRichard Purdie <richard.purdie@linuxfoundation.org>2018-12-20 11:00:20 +0000
commit423433e3d31a32dbb80203c628e808442d440ad1 (patch)
tree1edbad91e321e3c40f3d09a6f797513feba426b8
parentfa4ea76d93c87a2ad3ce88b052c282106b2761e4 (diff)
mingw-w64/gcc: Adapt to removal of gcc-initial from OE-Core2.7_M2
OE-Core dropped gcc-initial, we can do the same for mingw. Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
-rw-r--r--recipes-devtools/gcc/gcc-crosssdk-initial_%.bbappend3
-rw-r--r--recipes-devtools/mingw-w64/nativesdk-mingw-w64-runtime_6.0.0.bb7
-rw-r--r--recipes-devtools/mingw-w64/nativesdk-mingw-w64-winpthreads_6.0.0.bb5
3 files changed, 2 insertions, 13 deletions
diff --git a/recipes-devtools/gcc/gcc-crosssdk-initial_%.bbappend b/recipes-devtools/gcc/gcc-crosssdk-initial_%.bbappend
deleted file mode 100644
index 135a776..0000000
--- a/recipes-devtools/gcc/gcc-crosssdk-initial_%.bbappend
+++ /dev/null
@@ -1,3 +0,0 @@
-DEPENDS_append_mingw32 = " nativesdk-mingw-w64-headers"
-EXTRA_OECONF_remove_mingw32 = "--enable-initfini-array"
-EXTRA_OECONF_append_mingw32 = " --disable-initfini-array"
diff --git a/recipes-devtools/mingw-w64/nativesdk-mingw-w64-runtime_6.0.0.bb b/recipes-devtools/mingw-w64/nativesdk-mingw-w64-runtime_6.0.0.bb
index fc83ca8..cf39c6a 100644
--- a/recipes-devtools/mingw-w64/nativesdk-mingw-w64-runtime_6.0.0.bb
+++ b/recipes-devtools/mingw-w64/nativesdk-mingw-w64-runtime_6.0.0.bb
@@ -10,19 +10,14 @@ inherit autotools nativesdk
BUILDSDK_CPPFLAGS_append = " -isystem${STAGING_INCDIR}"
INHIBIT_DEFAULT_DEPS = "1"
-DEPENDS = "nativesdk-mingw-w64-headers virtual/${TARGET_PREFIX}gcc-initial "
+DEPENDS = "nativesdk-mingw-w64-headers virtual/${TARGET_PREFIX}gcc "
PROVIDES += "virtual/nativesdk-libc"
-PROVIDES += "virtual/nativesdk-${SDK_PREFIX}libc-initial"
-PROVIDES += "virtual/nativesdk-${SDK_PREFIX}libc-for-gcc"
# Work around pulling in eglibc for now...
PROVIDES += "virtual/nativesdk-libintl"
-STAGINGCC = "gcc-cross-initial-${TARGET_ARCH}"
-STAGINGCC_class-nativesdk = "gcc-crosssdk-initial-${SDK_SYS}"
TOOLCHAIN_OPTIONS = " --sysroot=${STAGING_DIR_TARGET}"
-PATH_prepend = "${STAGING_BINDIR_TOOLCHAIN}.${STAGINGCC}:"
do_configure() {
oe_runconf
diff --git a/recipes-devtools/mingw-w64/nativesdk-mingw-w64-winpthreads_6.0.0.bb b/recipes-devtools/mingw-w64/nativesdk-mingw-w64-winpthreads_6.0.0.bb
index b278ad7..e694e5b 100644
--- a/recipes-devtools/mingw-w64/nativesdk-mingw-w64-winpthreads_6.0.0.bb
+++ b/recipes-devtools/mingw-w64/nativesdk-mingw-w64-winpthreads_6.0.0.bb
@@ -8,16 +8,13 @@ B = "${WORKDIR}/build-${TARGET_SYS}"
inherit autotools nativesdk
INHIBIT_DEFAULT_DEPS = "1"
-DEPENDS = "nativesdk-mingw-w64-runtime virtual/${TARGET_PREFIX}gcc-initial"
+DEPENDS = "nativesdk-mingw-w64-runtime virtual/${TARGET_PREFIX}gcc"
do_configure() {
oe_runconf
}
-STAGINGCC = "gcc-cross-initial-${TARGET_ARCH}"
-STAGINGCC_class-nativesdk = "gcc-crosssdk-initial-${SDK_SYS}"
TOOLCHAIN_OPTIONS = " --sysroot=${STAGING_DIR_TARGET}"
-PATH_prepend = "${STAGING_BINDIR_TOOLCHAIN}.${STAGINGCC}:"
do_install_append() {
# headers are already installed by mingw-w64-headers