summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorSamuli Piippo <samuli.piippo@qt.io>2017-02-10 09:13:34 +0200
committerMikko Gronoff <mikko.gronoff@qt.io>2017-02-13 12:34:53 +0000
commitbfda0f040958b3c533123071ff031037389eed62 (patch)
tree24eba5f0f37f6adf7802d6682841ac30adf0e4e0
parent090fe6ff2ee59964bdf3b77bc47b4224b7a8f9fd (diff)
mingw64: update to 5.0.0
QtBase depends on new API (SHGetKnownFolderPath) that was not available in previous version. BUILDSDK_CPPFLAGS were emptied from poky.conf, but are needed for mingw build to include correct float.h. (error: '_MCW_DN' undeclared here) Change-Id: Ieca1431e4c827456b40e2151a16760bd7f66235a Reviewed-by: Mikko Gronoff <mikko.gronoff@qt.io> Reviewed-by: Samuli Piippo <samuli.piippo@qt.io>
-rw-r--r--recipes-devtools/mingw-w64/nativesdk-mingw-w64-headers_5.0.0.bb (renamed from recipes-devtools/mingw-w64/nativesdk-mingw-w64-headers_3.1.0.bb)4
-rw-r--r--recipes-devtools/mingw-w64/nativesdk-mingw-w64-runtime_5.0.0.bb (renamed from recipes-devtools/mingw-w64/nativesdk-mingw-w64-runtime_3.1.0.bb)6
2 files changed, 6 insertions, 4 deletions
diff --git a/recipes-devtools/mingw-w64/nativesdk-mingw-w64-headers_3.1.0.bb b/recipes-devtools/mingw-w64/nativesdk-mingw-w64-headers_5.0.0.bb
index 06312d6..5126a35 100644
--- a/recipes-devtools/mingw-w64/nativesdk-mingw-w64-headers_3.1.0.bb
+++ b/recipes-devtools/mingw-w64/nativesdk-mingw-w64-headers_5.0.0.bb
@@ -7,8 +7,8 @@ COMPATIBLE_HOST = ".*-mingw.*"
SRC_URI = "${SOURCEFORGE_MIRROR}/project/mingw-w64/mingw-w64/mingw-w64-release/mingw-w64-v${PV}.tar.bz2 \
file://epsilon.patch"
-SRC_URI[md5sum] = "df0e7657f46cbd59ed9cbe2a50c66e15"
-SRC_URI[sha256sum] = "ece7a7e7e1ab5e25d5ce469f8e4de7223696146fffa71c16e2a9b017d0e017d2"
+SRC_URI[md5sum] = "c9f4bb72a87d9be2cc98e0d7e1868c88"
+SRC_URI[sha256sum] = "e41d8ca739e22b4215c8ebe99ed2fc398c734cae73877f3143c394661b096d08"
S = "${WORKDIR}/mingw-w64-v${PV}/mingw-w64-headers"
B = "${WORKDIR}/build-${TARGET_SYS}"
diff --git a/recipes-devtools/mingw-w64/nativesdk-mingw-w64-runtime_3.1.0.bb b/recipes-devtools/mingw-w64/nativesdk-mingw-w64-runtime_5.0.0.bb
index c4292ad..d8945e3 100644
--- a/recipes-devtools/mingw-w64/nativesdk-mingw-w64-runtime_3.1.0.bb
+++ b/recipes-devtools/mingw-w64/nativesdk-mingw-w64-runtime_5.0.0.bb
@@ -5,14 +5,16 @@ LIC_FILES_CHKSUM = "file://../COPYING;md5=bb936f0e04d8f1e19ad545100cee9654"
COMPATIBLE_HOST = ".*-mingw.*"
SRC_URI = "${SOURCEFORGE_MIRROR}/project/mingw-w64/mingw-w64/mingw-w64-release/mingw-w64-v${PV}.tar.bz2"
-SRC_URI[md5sum] = "df0e7657f46cbd59ed9cbe2a50c66e15"
-SRC_URI[sha256sum] = "ece7a7e7e1ab5e25d5ce469f8e4de7223696146fffa71c16e2a9b017d0e017d2"
+SRC_URI[md5sum] = "c9f4bb72a87d9be2cc98e0d7e1868c88"
+SRC_URI[sha256sum] = "e41d8ca739e22b4215c8ebe99ed2fc398c734cae73877f3143c394661b096d08"
S = "${WORKDIR}/mingw-w64-v${PV}/mingw-w64-crt"
B = "${WORKDIR}/build-${TARGET_SYS}"
inherit autotools nativesdk
+BUILDSDK_CPPFLAGS = "-isystem${STAGING_INCDIR}"
+
INHIBIT_DEFAULT_DEPS = "1"
DEPENDS = "nativesdk-mingw-w64-headers virtual/${TARGET_PREFIX}gcc-initial "