summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorJuro Bystricky <juro.bystricky@intel.com>2016-10-05 15:49:19 -0700
committerJuro Bystricky <juro.bystricky@intel.com>2017-01-13 12:51:36 -0800
commitd21e286028f93feaf33de78e4e1141a6539f9567 (patch)
treec18a9753eb9d8bb8a1eb1dd60594a7551d3fc09c
parent7c358b5e5aa9481e847ad2e20c595753b3923f88 (diff)
gcc-crosssdk_%.bbappend: Do not configure with initfini-array enabled.
Default configuration for gcc-crosssddk is now to enable initfini-array. However, this works only for Linux so we disable it for mingw32. Otherwise we will eventually encounter build error such as: multiple definition of `__do_global_dtors' Signed-off-by: Juro Bystricky <juro.bystricky@intel.com> Signed-off-by: Mark Hatle <mark.hatle@windriver.com>
-rw-r--r--recipes-devtools/gcc/gcc-crosssdk_%.bbappend3
1 files changed, 3 insertions, 0 deletions
diff --git a/recipes-devtools/gcc/gcc-crosssdk_%.bbappend b/recipes-devtools/gcc/gcc-crosssdk_%.bbappend
index 77ba57f..b3b843a 100644
--- a/recipes-devtools/gcc/gcc-crosssdk_%.bbappend
+++ b/recipes-devtools/gcc/gcc-crosssdk_%.bbappend
@@ -1 +1,4 @@
EXTRA_OECONF_mingw32 := "${@oe_filter_out('--with-linker-hash-style=${LINKER_HASH_STYLE}', '${EXTRA_OECONF}', d)}"
+PACKAGECONFIG_CONFARGS ?= ""
+EXTRA_OECONF_remove_mingw32 = "--enable-initfini-array"
+EXTRA_OECONF_append_mingw32 = " --disable-initfini-array"