summaryrefslogtreecommitdiffstats
path: root/recipes-devtools
diff options
context:
space:
mode:
authorRichard Purdie <richard.purdie@linuxfoundation.org>2014-05-27 14:39:52 +0000
committerRichard Purdie <richard.purdie@linuxfoundation.org>2014-05-27 15:59:44 +0000
commitaa04ad46bbad56f7a385147bd393b399119187ac (patch)
tree04a048fc072cc4b414dfa7a49667f6c4ab955416 /recipes-devtools
parentbda37a98bccb69e71e11524f4b6364020136133c (diff)
gcc/nativesdk-mingw-w84-headers: Move symlinking to headers recipe
The symlinking is really an artefact of the way the headers are provided. Move all the code into one place. Also have the initial compiler depend on the headers else the build can fail. High parallelism prevented the issue from being seen in most cases. Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Diffstat (limited to 'recipes-devtools')
-rw-r--r--recipes-devtools/gcc/gcc-crosssdk-initial_4.8.bbappend9
-rw-r--r--recipes-devtools/mingw-w64/nativesdk-mingw-w64-headers_2.0.8.bb8
2 files changed, 9 insertions, 8 deletions
diff --git a/recipes-devtools/gcc/gcc-crosssdk-initial_4.8.bbappend b/recipes-devtools/gcc/gcc-crosssdk-initial_4.8.bbappend
index 7a7ca37..1c09342 100644
--- a/recipes-devtools/gcc/gcc-crosssdk-initial_4.8.bbappend
+++ b/recipes-devtools/gcc/gcc-crosssdk-initial_4.8.bbappend
@@ -1,8 +1 @@
-
-do_install_append_mingw32 () {
- ln -s ${STAGING_DIR_TARGET}/${target_exec_prefix}/ ${D}/${exec_prefix}/${TARGET_SYS}
-}
-
-sysroot_stage_all_append_mingw32 () {
- sysroot_stage_dir ${D}${exec_prefix}/${TARGET_SYS} ${SYSROOT_DESTDIR}${exec_prefix}/${TARGET_SYS}
-} \ No newline at end of file
+DEPENDS_append_mingw32 = " nativesdk-mingw-w64-headers"
diff --git a/recipes-devtools/mingw-w64/nativesdk-mingw-w64-headers_2.0.8.bb b/recipes-devtools/mingw-w64/nativesdk-mingw-w64-headers_2.0.8.bb
index b12a04e..a3d0e46 100644
--- a/recipes-devtools/mingw-w64/nativesdk-mingw-w64-headers_2.0.8.bb
+++ b/recipes-devtools/mingw-w64/nativesdk-mingw-w64-headers_2.0.8.bb
@@ -26,8 +26,16 @@ do_compile() {
:
}
+FILES_${PN} += "${exec_prefix}/${TARGET_SYS}"
+
do_install_append() {
# Move files to include folder where gcc-crosssdk-initial is looking
mv ${D}${exec_prefix}/${HOST_SYS}/include ${D}${exec_prefix}
rmdir ${D}${exec_prefix}/${HOST_SYS}
+
+ ln -s ./ ${D}/${exec_prefix}/${HOST_SYS}
+}
+
+sysroot_stage_all_append_mingw32 () {
+ ln -s ./ ${SYSROOT_DESTDIR}${exec_prefix}/${HOST_SYS}
}