aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorMartin Jansa <Martin.Jansa@gmail.com>2021-09-21 16:27:57 +0200
committerMartin Jansa <Martin.Jansa@gmail.com>2021-09-21 17:33:56 +0200
commit0ae3cbd677b6a8b9f7571a3f3287d9ebe144fbb4 (patch)
tree59fea55d79b61ff970661301b9c92ff668dc6cbd
parent2a38fca150f065f869ed530fffe1a07beec80692 (diff)
qtbase: inherit pkgconfig
* some features enabled with PACKAGECONFIG need pkgconfig to be detected correctly * fixes: Checking for pkg-config... test config.qtbase.tests.pkg-config FAILED ... Trying source 0 (type pkgConfig) of library dbus ... pkg-config use disabled globally. ... ERROR: Feature 'pkg-config' was enabled, but the pre-condition 'tests.pkg-config' failed. ERROR: Feature 'glib' was enabled, but the pre-condition 'libs.glib' failed. ERROR: Feature 'kms' was enabled, but the pre-condition 'libs.drm' failed. ERROR: Feature 'gbm' was enabled, but the pre-condition 'libs.gbm' failed. ERROR: Feature 'mtdev' was enabled, but the pre-condition 'libs.mtdev' failed. Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com>
-rw-r--r--recipes-qt/qt5/qtbase_git.bb2
1 files changed, 2 insertions, 0 deletions
diff --git a/recipes-qt/qt5/qtbase_git.bb b/recipes-qt/qt5/qtbase_git.bb
index 310aa761..be6c98c1 100644
--- a/recipes-qt/qt5/qtbase_git.bb
+++ b/recipes-qt/qt5/qtbase_git.bb
@@ -44,6 +44,8 @@ LTO = ""
# for syncqt
RDEPENDS:${PN}-tools += "perl"
+inherit pkgconfig
+
# separate some parts of PACKAGECONFIG which are often changed
PACKAGECONFIG_GL ?= "${@bb.utils.contains('DISTRO_FEATURES', 'opengl', 'gl', 'no-opengl', d)}"
PACKAGECONFIG_FB ?= "${@bb.utils.contains('DISTRO_FEATURES', 'directfb', 'directfb', '', d)}"