aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorSamuli Piippo <samuli.piippo@qt.io>2019-08-14 16:49:35 +0300
committerSamuli Piippo <samuli.piippo@qt.io>2019-08-15 08:47:32 +0000
commit295e826792d8ea1aa05b0ab7b1b72111cffd30b6 (patch)
tree1892d2a495e777be8765658f9420f428094366f5
parent646bc5107511496a944f31269e1dc7a66103e30b (diff)
qtbase: use offscreen platform plugin for tools
Use offscreen platform plugin when running tools in native and nativesdk. It provides font support without additional settings. Change-Id: I47baf480d1db35f7695795babdc909c6360ae049 Reviewed-by: Mikko Gronoff <mikko.gronoff@qt.io>
-rw-r--r--recipes-qt/qt5/nativesdk-qtbase_git.bb2
-rw-r--r--recipes-qt/qt5/qtbase-native_git.bb2
2 files changed, 2 insertions, 2 deletions
diff --git a/recipes-qt/qt5/nativesdk-qtbase_git.bb b/recipes-qt/qt5/nativesdk-qtbase_git.bb
index 1dde360f..4039c97a 100644
--- a/recipes-qt/qt5/nativesdk-qtbase_git.bb
+++ b/recipes-qt/qt5/nativesdk-qtbase_git.bb
@@ -75,7 +75,7 @@ FILES_${PN} += " \
DEBIAN_NOAUTONAME_${PN} = "1"
PACKAGECONFIG ?= ""
-PACKAGECONFIG[gui] = "-gui -qpa minimal,-no-gui,"
+PACKAGECONFIG[gui] = "-gui -qpa offscreen,-no-gui,"
PACKAGECONFIG[imageformats] = "-qt-libpng -qt-libjpeg -gif -ico, -no-libpng -no-libjpeg -no-ico -no-gif,"
QT_CONFIG_FLAGS += " \
diff --git a/recipes-qt/qt5/qtbase-native_git.bb b/recipes-qt/qt5/qtbase-native_git.bb
index 9efae9f8..8565aa35 100644
--- a/recipes-qt/qt5/qtbase-native_git.bb
+++ b/recipes-qt/qt5/qtbase-native_git.bb
@@ -57,7 +57,7 @@ XPLATFORM_toolchain-clang = "linux-oe-clang"
XPLATFORM ?= "linux-oe-g++"
PACKAGECONFIG ?= ""
-PACKAGECONFIG[gui] = "-gui -qpa minimal,-no-gui,"
+PACKAGECONFIG[gui] = "-gui -qpa offscreen,-no-gui,"
PACKAGECONFIG[imageformats] = "-qt-libpng -qt-libjpeg -gif -ico, -no-libpng -no-libjpeg -no-ico -no-gif,"
QT_CONFIG_FLAGS = " \