aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorMikko Levonmaa <mikko.levonmaa@palm.com>2013-03-13 15:11:30 -0700
committerMartin Jansa <Martin.Jansa@gmail.com>2013-05-06 12:21:30 +0200
commit37d0412e343cac16c06eb51bf47b5e72d14f852e (patch)
tree976962d82f0df72f498a1640ded31cfe0c31cffb
parentfc0b7ec73ce6aa470b6666ad115f3d0e8b83a340 (diff)
qtgraphicaleffects: Add recipe
* MJ: Add license information * MJ: Fix PV Signed-off-by: Martin Jansa <martin.jansa@lge.com> Signed-off-by: Mikko Levonmaa <mikko.levonmaa@palm.com>
-rw-r--r--recipes-qt/qt5/qtgraphicaleffects.inc12
-rw-r--r--recipes-qt/qt5/qtgraphicaleffects_5.0.0.bb14
-rw-r--r--recipes-qt/qt5/qtgraphicaleffects_git.bb19
3 files changed, 45 insertions, 0 deletions
diff --git a/recipes-qt/qt5/qtgraphicaleffects.inc b/recipes-qt/qt5/qtgraphicaleffects.inc
new file mode 100644
index 00000000..874c6064
--- /dev/null
+++ b/recipes-qt/qt5/qtgraphicaleffects.inc
@@ -0,0 +1,12 @@
+require qt5module.inc
+
+INC_PR = "r0"
+
+DEPENDS += "qtdeclarative"
+
+FILES_${PN} += " \
+ ${libdir}/${QT_DIR_NAME}/qml/QtGraphicalEffects/qmldir \
+ ${libdir}/${QT_DIR_NAME}/qml/QtGraphicalEffects/*.qml \
+ ${libdir}/${QT_DIR_NAME}/qml/QtGraphicalEffects/private/*.qml \
+"
+
diff --git a/recipes-qt/qt5/qtgraphicaleffects_5.0.0.bb b/recipes-qt/qt5/qtgraphicaleffects_5.0.0.bb
new file mode 100644
index 00000000..7f5d1827
--- /dev/null
+++ b/recipes-qt/qt5/qtgraphicaleffects_5.0.0.bb
@@ -0,0 +1,14 @@
+require ${PN}.inc
+require qt5-${PV}.inc
+
+# LICENSE files are missing in 5.0.0
+LIC_FILES_CHKSUM = "file://${COMMON_LICENSE_DIR}/LGPL-2.1;md5=1a6d268fd218675ffea8be556788b780 \
+ file://${COMMON_LICENSE_DIR}/GPL-3.0;md5=c79ff39f19dfec6d293b95dea7b07891 \
+ file://${COMMON_LICENSE_DIR}/GFDL-1.3;md5=1083add59b39991c748ea70a92166959 \
+"
+
+PR = "${INC_PR}.0"
+
+SRC_URI[md5sum] = "1031f8021a2b2e3a2387d94103e8868e"
+SRC_URI[sha256sum] = "e9cf71b4da1a1e879845f1fb1a532408ff6a0875e407a65d6bb3ce3dff0fe942"
+
diff --git a/recipes-qt/qt5/qtgraphicaleffects_git.bb b/recipes-qt/qt5/qtgraphicaleffects_git.bb
new file mode 100644
index 00000000..783ffa33
--- /dev/null
+++ b/recipes-qt/qt5/qtgraphicaleffects_git.bb
@@ -0,0 +1,19 @@
+require ${PN}.inc
+require qt5-git.inc
+
+# LICENSE files are missing in this old SRCREV, remove when upgraded
+# commit bd434a6ea358e96c373e3ad65bfb6d939904abf5
+# Author: Timo Jyrinki <timo.jyrinki@canonical.com>
+# Date: Fri Feb 8 09:09:55 2013 +0200
+# Subject: Add license files mandated by (L)GPL.
+LIC_FILES_CHKSUM = "file://${COMMON_LICENSE_DIR}/LGPL-2.1;md5=1a6d268fd218675ffea8be556788b780 \
+ file://${COMMON_LICENSE_DIR}/GPL-3.0;md5=c79ff39f19dfec6d293b95dea7b07891 \
+ file://${COMMON_LICENSE_DIR}/GFDL-1.3;md5=1083add59b39991c748ea70a92166959 \
+"
+
+# last tag before this SRCREV is 5.0.0
+PV = "5.0.0+git${SRCPV}"
+
+PR = "${INC_PR}.0"
+
+SRCREV = "9fb5dad66555c197ba19da6be80edf67e92888ba"