aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorJustin Bronder <jsbronder@cold-front.org>2023-05-04 17:48:34 -0400
committerMartin Jansa <Martin.Jansa@gmail.com>2023-06-12 18:08:29 +0200
commit3b2823b60d74bb8763fa576e8f2891cbf89ec54e (patch)
tree2238ee5cbd7b6e1605ccfe2d08ff2892d6bf1fd1
parentfe4ed26489fe8953b052977139b0d4202704261b (diff)
python3-pyqt-builder: add 1.15.0
This is required to build PyQt5 now. Signed-off-by: Justin Bronder <jsbronder@cold-front.org> Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com>
-rw-r--r--licenses/SIP49
-rw-r--r--recipes-python/pyqt5/python3-pyqt-builder-native_1.15.0.bb10
2 files changed, 59 insertions, 0 deletions
diff --git a/licenses/SIP b/licenses/SIP
new file mode 100644
index 00000000..9406c308
--- /dev/null
+++ b/licenses/SIP
@@ -0,0 +1,49 @@
+RIVERBANK COMPUTING LIMITED LICENSE AGREEMENT FOR SIP
+
+1. This LICENSE AGREEMENT ("the SIP License") is between Riverbank Computing
+Limited ("Riverbank"), and the Individual or Organization ("Licensee")
+accessing and otherwise using SIP software in source or binary form and its
+associated documentation. SIP comprises a software tool for generating Python
+bindings for software C and C++ libraries, and a Python extension module used
+at runtime by those generated bindings. This License Agreement may also be
+applied to other software packages written by Riverbank.
+
+2. Subject to the terms and conditions of this License Agreement, Riverbank
+hereby grants Licensee a nonexclusive, royalty-free, world-wide license to
+reproduce, analyze, test, perform and/or display publicly, prepare derivative
+works, distribute, and otherwise use SIP alone or in any derivative version,
+provided, however, that Riverbank's License Agreement and Riverbank's notice of
+copyright, e.g., "Copyright (c) 2015 Riverbank Computing Limited; All Rights
+Reserved" are retained in SIP alone or in any derivative version prepared by
+Licensee.
+
+3. In the event Licensee prepares a derivative work that is based on or
+incorporates SIP or any part thereof, and wants to make the derivative work
+available to others as provided herein, then Licensee hereby agrees to include
+in any such work a brief summary of the changes made to SIP.
+
+4. Licensee may not use SIP to generate Python bindings for any C or C++
+library for which bindings are already provided by Riverbank.
+
+5. Riverbank is making SIP available to Licensee on an "AS IS" basis.
+RIVERBANK MAKES NO REPRESENTATIONS OR WARRANTIES, EXPRESS OR IMPLIED. BY WAY
+OF EXAMPLE, BUT NOT LIMITATION, RIVERBANK MAKES NO AND DISCLAIMS ANY
+REPRESENTATION OR WARRANTY OF MERCHANTABILITY OR FITNESS FOR ANY PARTICULAR
+PURPOSE OR THAT THE USE OF SIP WILL NOT INFRINGE ANY THIRD PARTY RIGHTS.
+
+6. RIVERBANK SHALL NOT BE LIABLE TO LICENSEE OR ANY OTHER USERS OF SIP FOR ANY
+INCIDENTAL, SPECIAL, OR CONSEQUENTIAL DAMAGES OR LOSS AS A RESULT OF MODIFYING,
+DISTRIBUTING, OR OTHERWISE USING SIP, OR ANY DERIVATIVE THEREOF, EVEN IF
+ADVISED OF THE POSSIBILITY THEREOF.
+
+7. This License Agreement will automatically terminate upon a material breach
+of its terms and conditions.
+
+8. Nothing in this License Agreement shall be deemed to create any relationship
+of agency, partnership, or joint venture between Riverbank and Licensee. This
+License Agreement does not grant permission to use Riverbank trademarks or
+trade name in a trademark sense to endorse or promote products or services of
+Licensee, or any third party.
+
+9. By copying, installing or otherwise using SIP, Licensee agrees to be bound
+by the terms and conditions of this License Agreement.
diff --git a/recipes-python/pyqt5/python3-pyqt-builder-native_1.15.0.bb b/recipes-python/pyqt5/python3-pyqt-builder-native_1.15.0.bb
new file mode 100644
index 00000000..7f16eb7b
--- /dev/null
+++ b/recipes-python/pyqt5/python3-pyqt-builder-native_1.15.0.bb
@@ -0,0 +1,10 @@
+SUMMARY = "The PEP 517 compliant PyQt build system"
+HOMEPAGE = "https://pypi.org/project/PyQt-builder/"
+LICENSE = "SIP | GPL-2.0-or-later"
+LIC_FILES_CHKSUM = "file://LICENSE;md5=9cd437778ebd1c056a76b4ded73b3a6d"
+
+SRC_URI[sha256sum] = "a90553703897eb41e27c2f1abd31fb9ed304c32ec3271b380015b54ea9762ddd"
+
+inherit pypi setuptools3 native
+
+PYPI_PACKAGE = "PyQt-builder"