aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorMikko Gronoff <mikko.gronoff@qt.io>2023-04-19 10:00:04 +0300
committerMikko Gronoff <mikko.gronoff@qt.io>2023-04-19 10:06:18 +0300
commit3cb2ca61d468a4d4b8ac79543cc7708a5775c045 (patch)
tree1e3f7007b4fd4993727657444be0a26b67e3326f
parent0d8e7e52025aeae4f5fd622867017dc56ddbf188 (diff)
parent41fefb7cf44a89022a381e672c44a48dd9fb533c (diff)
Merge remote-tracking branch 'qt/upstream/master' into lts-5.15
changelog: 41fefb7c gdb: remove bbappend 480716e4 qt5-git: do not override CVE products ee5f9fc0 qtpdf: Enable on rv64 and do not force shared c++ runtime with libc++ Change-Id: I596227e66d52c566e1ad0a84d445ac4db0ed2070
-rw-r--r--recipes-devtools/gdb/gdb_%.bbappend2
-rw-r--r--recipes-qt/qt5/qt5-git.inc2
-rw-r--r--recipes-qt/qt5/qtpdf/0003-Fix-build-with-clang.patch9
-rw-r--r--recipes-qt/qt5/qtpdf_git.bb2
-rw-r--r--recipes-qt/qt5/qtwebengine/0001-Force-host-toolchain-configuration.patch22
5 files changed, 21 insertions, 16 deletions
diff --git a/recipes-devtools/gdb/gdb_%.bbappend b/recipes-devtools/gdb/gdb_%.bbappend
deleted file mode 100644
index fa2b06ab..00000000
--- a/recipes-devtools/gdb/gdb_%.bbappend
+++ /dev/null
@@ -1,2 +0,0 @@
-# Just a comment line to avoid PAK archive (application/x-pak)
-PACKAGECONFIG ??= "readline python"
diff --git a/recipes-qt/qt5/qt5-git.inc b/recipes-qt/qt5/qt5-git.inc
index 0feb09d8..0c5d2fe0 100644
--- a/recipes-qt/qt5/qt5-git.inc
+++ b/recipes-qt/qt5/qt5-git.inc
@@ -11,7 +11,7 @@ SRC_URI = " \
${QT_GIT}/${QT_MODULE_REPO};name=${QT_MODULE};${QT_MODULE_BRANCH_PARAM};protocol=${QT_GIT_PROTOCOL} \
"
-CVE_PRODUCT = "qt"
+CVE_PRODUCT:append = " qt"
S = "${WORKDIR}/git"
diff --git a/recipes-qt/qt5/qtpdf/0003-Fix-build-with-clang.patch b/recipes-qt/qt5/qtpdf/0003-Fix-build-with-clang.patch
index f5efddd4..a5a8955f 100644
--- a/recipes-qt/qt5/qtpdf/0003-Fix-build-with-clang.patch
+++ b/recipes-qt/qt5/qtpdf/0003-Fix-build-with-clang.patch
@@ -24,16 +24,15 @@ Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com>
src/buildtools/gn.pro | 2 +-
1 file changed, 1 insertion(+), 1 deletion(-)
-diff --git a/src/buildtools/gn.pro b/src/buildtools/gn.pro
-index 9632f0ef7..da85f8a26 100644
--- a/src/buildtools/gn.pro
+++ b/src/buildtools/gn.pro
-@@ -20,7 +20,7 @@ build_pass|!debug_and_release {
+@@ -20,8 +20,7 @@ build_pass|!debug_and_release {
gn_gen_args = --no-last-commit-position --out-path $$out_path \
--cc \"$$which($$CC_host)\" --cxx \"$$which($$CXX_host)\" \
- --ld \"$$which($$CXX_host)\" --ar \"$$which(ar)\" \
-+ --ld \"$$which($$CXX_host) -rtlib=libgcc -unwindlib=libgcc\" --ar \"$$which(ar)\" \
- --no-static-libstdc++
+- --no-static-libstdc++
++ --ld \"$$which($$CXX_host) -stdlib=libc++ -rtlib=libgcc -unwindlib=libgcc $$(GN_HOST_TOOLCHAIN_EXTRA_LDFLAGS)\" --ar \"$$which(ar)\"
msvc:!clang_cl: gn_gen_args += --use-lto
+
diff --git a/recipes-qt/qt5/qtpdf_git.bb b/recipes-qt/qt5/qtpdf_git.bb
index 972668c8..6098be44 100644
--- a/recipes-qt/qt5/qtpdf_git.bb
+++ b/recipes-qt/qt5/qtpdf_git.bb
@@ -71,6 +71,7 @@ COMPATIBLE_MACHINE:armv6 = "(.*)"
COMPATIBLE_MACHINE:armv7a = "(.*)"
COMPATIBLE_MACHINE:armv7ve = "(.*)"
COMPATIBLE_MACHINE:aarch64 = "(.*)"
+COMPATIBLE_MACHINE:riscv64 = "(.*)"
inherit qmake5
inherit gettext
@@ -90,6 +91,7 @@ require qt5-git.inc
export GN_PKG_CONFIG_HOST = "${STAGING_BINDIR_NATIVE}/pkg-config-native"
export GN_HOST_TOOLCHAIN_EXTRA_CPPFLAGS = "-I${STAGING_DIR_NATIVE}/usr/include"
+export GN_HOST_TOOLCHAIN_EXTRA_LDFLAGS = "-L${STAGING_LIBDIR_NATIVE}"
export NINJAFLAGS="${PARALLEL_MAKE}"
do_configure() {
diff --git a/recipes-qt/qt5/qtwebengine/0001-Force-host-toolchain-configuration.patch b/recipes-qt/qt5/qtwebengine/0001-Force-host-toolchain-configuration.patch
index cec6c56a..8f44b31c 100644
--- a/recipes-qt/qt5/qtwebengine/0001-Force-host-toolchain-configuration.patch
+++ b/recipes-qt/qt5/qtwebengine/0001-Force-host-toolchain-configuration.patch
@@ -18,8 +18,6 @@ Signed-off-by: Samuli Piippo <samuli.piippo@qt.io>
src/buildtools/gn.pro | 5 ++---
3 files changed, 10 insertions(+), 11 deletions(-)
-diff --git a/src/buildtools/config/linux.pri b/src/buildtools/config/linux.pri
-index 7507d51ef..1e078cbfe 100644
--- a/src/buildtools/config/linux.pri
+++ b/src/buildtools/config/linux.pri
@@ -118,7 +118,7 @@ contains(QT_ARCH, "mips") {
@@ -31,8 +29,6 @@ index 7507d51ef..1e078cbfe 100644
gn_args += host_cpu=\"$$GN_HOST_CPU\"
# Don't bother trying to use system libraries in this case
gn_args += use_glib=false
-diff --git a/src/buildtools/configure_host.pro b/src/buildtools/configure_host.pro
-index dd0d3e327..6312c8678 100644
--- a/src/buildtools/configure_host.pro
+++ b/src/buildtools/configure_host.pro
@@ -4,7 +4,7 @@ TEMPLATE = aux
@@ -44,7 +40,15 @@ index dd0d3e327..6312c8678 100644
!isEmpty(QT_TARGET_ARCH): GN_TARGET_CPU = $$gnArch($$QT_TARGET_ARCH)
else: GN_TARGET_CPU = $$GN_HOST_CPU
GN_OS = $$gnOS()
-@@ -31,9 +31,9 @@ GN_CONTENTS = \
+@@ -24,6 +24,7 @@ contains(GN_TARGET_CPU, "arm")|contains(
+ }
+
+ GN_HOST_EXTRA_CPPFLAGS = $$(GN_HOST_TOOLCHAIN_EXTRA_CPPFLAGS)
++GN_HOST_EXTRA_LDFLAGS = $$(GN_HOST_TOOLCHAIN_EXTRA_LDFLAGS)
+
+ # We always use the gcc_toolchain, because clang_toolchain is just
+ # a broken wrapper around it for Google's custom clang binaries.
+@@ -31,12 +32,13 @@ GN_CONTENTS = \
"import(\"//build/config/sysroot.gni\")" \
"import(\"//build/toolchain/gcc_toolchain.gni\")" \
"gcc_toolchain(\"host\") {" \
@@ -57,7 +61,11 @@ index dd0d3e327..6312c8678 100644
" ar = \"$$which(ar)\" " \
" nm = \"$$which(nm)\" " \
" extra_cppflags = \"$$GN_HOST_EXTRA_CPPFLAGS\" " \
-@@ -45,9 +45,9 @@ GN_CONTENTS = \
++" extra_ldflags = \"$$GN_HOST_EXTRA_LDFLAGS\" " \
+ " toolchain_args = { " \
+ " current_os = \"$$GN_OS\" " \
+ " current_cpu = \"$$GN_HOST_CPU\" " \
+@@ -45,9 +47,9 @@ GN_CONTENTS = \
" } " \
"}" \
"gcc_toolchain(\"v8_snapshot\") {" \
@@ -70,8 +78,6 @@ index dd0d3e327..6312c8678 100644
" ar = \"$$which(ar)\" " \
" nm = \"$$which(nm)\" " \
" toolchain_args = { " \
-diff --git a/src/buildtools/gn.pro b/src/buildtools/gn.pro
-index f94694da0..a8ca6567b 100644
--- a/src/buildtools/gn.pro
+++ b/src/buildtools/gn.pro
@@ -19,9 +19,8 @@ build_pass|!debug_and_release {