aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorMikko Gronoff <mikko.gronoff@qt.io>2022-12-08 11:24:19 +0200
committerMikko Gronoff <mikko.gronoff@qt.io>2022-12-12 18:48:36 +0200
commit60318db961aec98816d102e9bda12b5e2cc7e15c (patch)
tree9ca590fdc286aa07e0052a41e8278e2eef970ea9
parent1f12f6dbbe846bb049e36f2c5b674d5b597ea05b (diff)
qt5: update submodules
Update to latest content in lts-5.15.12 branch. Task-number: QTBUG-107229 Change-Id: I94fe826f16df6eabcb6a90943f24a852497fcf3f Reviewed-by: Tarja Sundqvist <tarja.sundqvist@qt.io> Reviewed-by: Qt CI Bot <qt_ci_bot@qt-project.org>
-rw-r--r--recipes-qt/qt5/nativesdk-qtbase_git.bb2
-rw-r--r--recipes-qt/qt5/qt3d_git.bb2
-rw-r--r--recipes-qt/qt5/qt5-git.inc2
-rw-r--r--recipes-qt/qt5/qt5-lts.inc2
-rw-r--r--recipes-qt/qt5/qtbase-native_git.bb2
-rw-r--r--recipes-qt/qt5/qtbase_git.bb2
-rw-r--r--recipes-qt/qt5/qtdeclarative_git.bb2
-rw-r--r--recipes-qt/qt5/qtmultimedia_git.bb2
-rw-r--r--recipes-qt/qt5/qtopcua_git.bb2
-rw-r--r--recipes-qt/qt5/qtpdf_git.bb4
-rw-r--r--recipes-qt/qt5/qtwayland_git.bb2
-rw-r--r--recipes-qt/qt5/qtwebengine/chromium/0003-chromium-Exclude-CRC32-for-32bit-arm.patch8
-rw-r--r--recipes-qt/qt5/qtwebengine_git.bb4
13 files changed, 18 insertions, 18 deletions
diff --git a/recipes-qt/qt5/nativesdk-qtbase_git.bb b/recipes-qt/qt5/nativesdk-qtbase_git.bb
index 42dd1be7..5b42a0d4 100644
--- a/recipes-qt/qt5/nativesdk-qtbase_git.bb
+++ b/recipes-qt/qt5/nativesdk-qtbase_git.bb
@@ -200,4 +200,4 @@ fakeroot do_generate_qt_environment_file() {
do_generate_qt_environment_file[umask] = "022"
addtask generate_qt_environment_file after do_install before do_package
-SRCREV = "e3e8267db4c3f7e4f82e88fe73b62fea7b714f16"
+SRCREV = "1bf394a4c98c529844c896f8666412e5fcac8a7a"
diff --git a/recipes-qt/qt5/qt3d_git.bb b/recipes-qt/qt5/qt3d_git.bb
index f9a9b175..6ae8f3d2 100644
--- a/recipes-qt/qt5/qt3d_git.bb
+++ b/recipes-qt/qt5/qt3d_git.bb
@@ -44,7 +44,7 @@ do_configure:prepend() {
${S}/src/quick3d/imports/input/importsinput.pro
}
-SRCREV_qt3d = "d67a1934416cfd65e930a95506d20076ffd28b30"
+SRCREV_qt3d = "b59fdcefdbce6a1870e49b0da14d30b51293dea6"
SRCREV_assimp = "8f0c6b04b2257a520aaab38421b2e090204b69df"
SRCREV_FORMAT = "qt3d_assimp"
diff --git a/recipes-qt/qt5/qt5-git.inc b/recipes-qt/qt5/qt5-git.inc
index 701d91cf..1a32304c 100644
--- a/recipes-qt/qt5/qt5-git.inc
+++ b/recipes-qt/qt5/qt5-git.inc
@@ -2,7 +2,7 @@
# Copyright (C) 2013-2022 Martin Jansa <martin.jansa@gmail.com>
QT_MODULE ?= "${BPN}"
-QT_MODULE_BRANCH ?= "5.15"
+QT_MODULE_BRANCH ?= "5.15.12"
QT_MODULE_BRANCH_PARAM ?= "branch=${QT_MODULE_BRANCH}"
QT_MODULE_REPO ?= "${QT_MODULE}.git"
diff --git a/recipes-qt/qt5/qt5-lts.inc b/recipes-qt/qt5/qt5-lts.inc
index af611ce4..39682882 100644
--- a/recipes-qt/qt5/qt5-lts.inc
+++ b/recipes-qt/qt5/qt5-lts.inc
@@ -4,6 +4,6 @@ QT_LTS_GIT ?= "git://codereview.qt-project.org/${QT_GIT_PROJECT}"
QT_GIT = "${QT_LTS_GIT}"
QT_LTS_GIT_PROTOCOL ?= "ssh"
QT_GIT_PROTOCOL = "${QT_LTS_GIT_PROTOCOL}"
-QT_MODULE_BRANCH = "tqtc/lts-5.15"
+QT_MODULE_BRANCH = "tqtc/lts-5.15.12"
QT_LTS_MODULE_REPO ?= "tqtc-${QT_MODULE}.git"
QT_MODULE_REPO = "${QT_LTS_MODULE_REPO}"
diff --git a/recipes-qt/qt5/qtbase-native_git.bb b/recipes-qt/qt5/qtbase-native_git.bb
index 90e9810d..d638e44b 100644
--- a/recipes-qt/qt5/qtbase-native_git.bb
+++ b/recipes-qt/qt5/qtbase-native_git.bb
@@ -143,4 +143,4 @@ do_install() {
echo 'set(_qt5_corelib_extra_includes "${_qt5Core_install_prefix}/lib${QT_DIR_NAME}/mkspecs/linux-oe-g++")' > ${D}${libdir}/cmake/Qt5Core/Qt5CoreConfigExtrasMkspecDir.cmake
}
-SRCREV = "e3e8267db4c3f7e4f82e88fe73b62fea7b714f16"
+SRCREV = "1bf394a4c98c529844c896f8666412e5fcac8a7a"
diff --git a/recipes-qt/qt5/qtbase_git.bb b/recipes-qt/qt5/qtbase_git.bb
index 7ca6ceeb..d741f1fd 100644
--- a/recipes-qt/qt5/qtbase_git.bb
+++ b/recipes-qt/qt5/qtbase_git.bb
@@ -307,4 +307,4 @@ sed -i \
$D${OE_QMAKE_PATH_ARCHDATA}/mkspecs/qmodule.pri
}
-SRCREV = "e3e8267db4c3f7e4f82e88fe73b62fea7b714f16"
+SRCREV = "1bf394a4c98c529844c896f8666412e5fcac8a7a"
diff --git a/recipes-qt/qt5/qtdeclarative_git.bb b/recipes-qt/qt5/qtdeclarative_git.bb
index d194a2b7..1ea1ef7a 100644
--- a/recipes-qt/qt5/qtdeclarative_git.bb
+++ b/recipes-qt/qt5/qtdeclarative_git.bb
@@ -53,6 +53,6 @@ do_install:append:class-nativesdk() {
rm -rf ${D}${OE_QMAKE_PATH_QML}
}
-SRCREV = "760a37d60a79c8b4fcf91009d92e8fdfb7bdba6f"
+SRCREV = "94fd52dbb83a4982e4a70e621f431b0bd0945b5d"
BBCLASSEXTEND =+ "native nativesdk"
diff --git a/recipes-qt/qt5/qtmultimedia_git.bb b/recipes-qt/qt5/qtmultimedia_git.bb
index a0e16421..56de482d 100644
--- a/recipes-qt/qt5/qtmultimedia_git.bb
+++ b/recipes-qt/qt5/qtmultimedia_git.bb
@@ -40,7 +40,7 @@ SRC_URI += "\
# http://errors.yoctoproject.org/Errors/Build/44914/
LDFLAGS:append:x86 = "${@bb.utils.contains('DISTRO_FEATURES', 'ld-is-gold', ' -fuse-ld=bfd ', '', d)}"
-SRCREV = "0f3c93716e246dd98d320a4e37ac08b7e152bb09"
+SRCREV = "569d91d8560620d697dd8cc7c49581c7ff70b8ce"
# Temporary work around for Qt5MultimediaConfig.cmake referencing non-existent videoeglvideonode directory
do_install:append() {
diff --git a/recipes-qt/qt5/qtopcua_git.bb b/recipes-qt/qt5/qtopcua_git.bb
index 352065d2..13162a24 100644
--- a/recipes-qt/qt5/qtopcua_git.bb
+++ b/recipes-qt/qt5/qtopcua_git.bb
@@ -18,4 +18,4 @@ SECURITY_STRINGFORMAT = ""
DEPENDS += "qtbase"
-SRCREV = "c54698525ee73d450f451bf204b685c7c941d900"
+SRCREV = "ec9768f4daf0a799dd02921155ea7b3e58d1fd49"
diff --git a/recipes-qt/qt5/qtpdf_git.bb b/recipes-qt/qt5/qtpdf_git.bb
index c742c24e..4b35c0a1 100644
--- a/recipes-qt/qt5/qtpdf_git.bb
+++ b/recipes-qt/qt5/qtpdf_git.bb
@@ -180,8 +180,8 @@ SRC_URI:append:libc-musl = "\
file://chromium/0023-chromium-musl-initialize-msghdr-in-a-compatible-mann.patch;patchdir=src/3rdparty \
"
-SRCREV_qtwebengine = "c107eb20a25157836fcf3be91566d8ea38490f40"
-SRCREV_chromium = "7e11d69b957595a172a3eb60db17141daed29d63"
+SRCREV_qtwebengine = "4ea03a0affbfd6ff36a7defd391b7ca139d18c8e"
+SRCREV_chromium = "e0fd3a5d3ce79d43dee6e0bad16a71123d9a14b3"
SRCREV = "${SRCREV_qtwebengine}"
SRCREV_FORMAT = "qtwebengine_chromium"
diff --git a/recipes-qt/qt5/qtwayland_git.bb b/recipes-qt/qt5/qtwayland_git.bb
index 509f6289..a8ddacda 100644
--- a/recipes-qt/qt5/qtwayland_git.bb
+++ b/recipes-qt/qt5/qtwayland_git.bb
@@ -48,7 +48,7 @@ PACKAGECONFIG[wayland-vulkan-server-buffer] = "-feature-wayland-vulkan-server-bu
EXTRA_QMAKEVARS_CONFIGURE += "${PACKAGECONFIG_CONFARGS}"
-SRCREV = "4cc3ce4a20fb46ed70094bd1c9a4c735eb37cc60"
+SRCREV = "df401d596364fd6a90dc1527a85d97ff863deae1"
BBCLASSEXTEND =+ "native nativesdk"
diff --git a/recipes-qt/qt5/qtwebengine/chromium/0003-chromium-Exclude-CRC32-for-32bit-arm.patch b/recipes-qt/qt5/qtwebengine/chromium/0003-chromium-Exclude-CRC32-for-32bit-arm.patch
index 8e14d145..2b3da378 100644
--- a/recipes-qt/qt5/qtwebengine/chromium/0003-chromium-Exclude-CRC32-for-32bit-arm.patch
+++ b/recipes-qt/qt5/qtwebengine/chromium/0003-chromium-Exclude-CRC32-for-32bit-arm.patch
@@ -1,4 +1,4 @@
-From b2e7a10448d984eb62810ad5c41720d61599cecc Mon Sep 17 00:00:00 2001
+From a8b4eca96598011ee01458782e473aae4d6dd840 Mon Sep 17 00:00:00 2001
From: Khem Raj <raj.khem@gmail.com>
Date: Tue, 5 Feb 2019 14:32:20 -0800
Subject: [PATCH] chromium: Exclude CRC32 for 32bit arm
@@ -15,15 +15,15 @@ Signed-off-by: Khem Raj <raj.khem@gmail.com>
1 file changed, 4 insertions(+), 1 deletion(-)
diff --git a/chromium/third_party/zlib/BUILD.gn b/chromium/third_party/zlib/BUILD.gn
-index 891c2c34bfb..5ab519bd133 100644
+index 44b827155b2..0f73a2f5ccc 100644
--- a/chromium/third_party/zlib/BUILD.gn
+++ b/chromium/third_party/zlib/BUILD.gn
-@@ -115,8 +115,11 @@ if (use_arm_neon_optimizations) {
+@@ -129,8 +129,11 @@ if (use_arm_neon_optimizations) {
# Disabled for iPhone, as described in DDI0487C_a_armv8_arm:
# "All implementations of the ARMv8.1 architecture are required to
# implement the CRC32* instructions. These are optional in ARMv8.0."
+ defines = []
- if (!is_ios) {
+ if (!is_ios && !use_qt) {
- defines = [ "CRC32_ARMV8_CRC32" ]
+ if (current_cpu == "arm64") {
+ defines += [ "CRC32_ARMV8_CRC32" ]
diff --git a/recipes-qt/qt5/qtwebengine_git.bb b/recipes-qt/qt5/qtwebengine_git.bb
index f83fab69..af082714 100644
--- a/recipes-qt/qt5/qtwebengine_git.bb
+++ b/recipes-qt/qt5/qtwebengine_git.bb
@@ -198,8 +198,8 @@ SRC_URI:append:libc-musl = "\
file://chromium/0023-chromium-musl-initialize-msghdr-in-a-compatible-mann.patch;patchdir=src/3rdparty \
"
-SRCREV_qtwebengine = "5d89f26414471689a9626515d098104e38bacbda"
-SRCREV_chromium = "be349eaf62e77955791d7bf29f893f1e8a37daf4"
+SRCREV_qtwebengine = "4ea03a0affbfd6ff36a7defd391b7ca139d18c8e"
+SRCREV_chromium = "e0fd3a5d3ce79d43dee6e0bad16a71123d9a14b3"
SRCREV = "${SRCREV_qtwebengine}"
SRCREV_FORMAT = "qtwebengine_chromium"