aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorJames Minor <james.minor@ni.com>2024-04-05 15:30:22 -0500
committerMartin Jansa <martin.jansa@gmail.com>2024-04-18 10:13:18 +0200
commit6813e66a1087d453870f003b6e22b087a1bef433 (patch)
tree6f5910f7c8ef29516dfd2cf17562c39883cd3de1
parent585d28d0da0f9fa1251a6abb5056317e471eb747 (diff)
qtbase: Remove ptests that use SRCDIR
Some of the auto tests use SRCDIR which will fail on a target when compiled and run as a ptest. Since those tests don't pass completely anyway and so that host paths won't leak into these binaries, remove them. Signed-off-by: James Minor <james.minor@ni.com> Signed-off-by: Martin Jansa <martin.jansa@gmail.com>
-rw-r--r--recipes-qt/qt5/qtbase/0029-Remove-ptests-with-SRCDIR.patch57
-rw-r--r--recipes-qt/qt5/qtbase_git.bb1
2 files changed, 58 insertions, 0 deletions
diff --git a/recipes-qt/qt5/qtbase/0029-Remove-ptests-with-SRCDIR.patch b/recipes-qt/qt5/qtbase/0029-Remove-ptests-with-SRCDIR.patch
new file mode 100644
index 00000000..690d491c
--- /dev/null
+++ b/recipes-qt/qt5/qtbase/0029-Remove-ptests-with-SRCDIR.patch
@@ -0,0 +1,57 @@
+Remove ptests that leak host paths via SRCDIR
+The host paths are not useful on the target and may cause security concerns.
+Some auto tests run as ptests include references to external resources via
+SRCDIR and fail today.
+
+Remove the problematic tests since they won't pass completely anyway.
+
+Upstream-Status: Inappropriate [embedded specific]
+Signed-off-by: James Minor <james.minor@ni.com>
+Index: git/tests/auto/corelib/tools/tools.pro
+===================================================================
+--- git.orig/tests/auto/corelib/tools/tools.pro
++++ git/tests/auto/corelib/tools/tools.pro
+@@ -36,7 +36,6 @@ SUBDIRS=\
+ qscopedvaluerollback \
+ qscopeguard \
+ qset \
+- qsharedpointer \
+ qsize \
+ qsizef \
+ qstl \
+Index: git/tests/auto/other/other.pro
+===================================================================
+--- git.orig/tests/auto/other/other.pro
++++ git/tests/auto/other/other.pro
+@@ -4,7 +4,6 @@ QT_FOR_CONFIG += gui-private
+ SUBDIRS=\
+ compiler \
+ gestures \
+- lancelot \
+ languagechange \
+ macgui \
+ #macnativeevents \
+Index: git/tests/auto/widgets/dialogs/dialogs.pro
+===================================================================
+--- git.orig/tests/auto/widgets/dialogs/dialogs.pro
++++ git/tests/auto/widgets/dialogs/dialogs.pro
+@@ -3,7 +3,6 @@ SUBDIRS=\
+ qcolordialog \
+ qdialog \
+ qerrormessage \
+- qfiledialog \
+ qfiledialog2 \
+ qfilesystemmodel \
+ qfontdialog \
+Index: git/tests/auto/widgets/itemviews/itemviews.pro
+===================================================================
+--- git.orig/tests/auto/widgets/itemviews/itemviews.pro
++++ git/tests/auto/widgets/itemviews/itemviews.pro
+@@ -3,7 +3,6 @@ SUBDIRS=\
+ qabstractitemview \
+ qcolumnview \
+ qdatawidgetmapper \
+- qdirmodel \
+ qfileiconprovider \
+ qheaderview \
+ qitemdelegate \
diff --git a/recipes-qt/qt5/qtbase_git.bb b/recipes-qt/qt5/qtbase_git.bb
index 00d55e34..0585e285 100644
--- a/recipes-qt/qt5/qtbase_git.bb
+++ b/recipes-qt/qt5/qtbase_git.bb
@@ -48,6 +48,7 @@ SRC_URI += "\
file://0001-CVE-2023-51714-qtbase-5.15.diff \
file://0002-CVE-2023-51714-qtbase-5.15.diff \
file://0028-Remove-host-paths-from-qmake.patch \
+ file://0029-Remove-ptests-with-SRCDIR.patch \
"
# Disable LTO for now, QT5 patches are being worked upstream, perhaps revisit with