aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorKhem Raj <raj.khem@gmail.com>2023-04-20 11:08:35 -0700
committerMartin Jansa <Martin.Jansa@gmail.com>2023-04-25 16:12:09 +0200
commit7b83cadb771f31ba54427e23143736b3706d0cc4 (patch)
tree8997767c43c13812b4a2081feac69f5e45f60506
parent77b6060cef9337b184100083746c2e35f531be74 (diff)
qtbase: Fix build on 32bit arches with 64bit time_t
Signed-off-by: Khem Raj <raj.khem@gmail.com>
-rw-r--r--recipes-qt/qt5/qtbase/0023-Remove-unsetting-_FILE_OFFSET_BITS.patch26
-rw-r--r--recipes-qt/qt5/qtbase_git.bb1
2 files changed, 27 insertions, 0 deletions
diff --git a/recipes-qt/qt5/qtbase/0023-Remove-unsetting-_FILE_OFFSET_BITS.patch b/recipes-qt/qt5/qtbase/0023-Remove-unsetting-_FILE_OFFSET_BITS.patch
new file mode 100644
index 00000000..423db6e4
--- /dev/null
+++ b/recipes-qt/qt5/qtbase/0023-Remove-unsetting-_FILE_OFFSET_BITS.patch
@@ -0,0 +1,26 @@
+Remove unsetting _FILE_OFFSET_BITS
+This does not work when enabling 64bit time_t with glibc which is
+enabled with -D_TIME_BITS=64, since it also needs
+_FILE_OFFSET_BITS=64 and this does not work when its undefined
+explicitly
+
+Upstream-Status: Submitted [https://github.com/madler/zlib/pull/764]
+Signed-off-by: Khem Raj <raj.khem@gmail.com>
+--- a/src/3rdparty/zlib/src/gzguts.h
++++ b/src/3rdparty/zlib/src/gzguts.h
+@@ -22,15 +22,6 @@
+ #define HAVE_HIDDEN
+ #endif
+
+-#ifdef _LARGEFILE64_SOURCE
+-# ifndef _LARGEFILE_SOURCE
+-# define _LARGEFILE_SOURCE 1
+-# endif
+-# ifdef _FILE_OFFSET_BITS
+-# undef _FILE_OFFSET_BITS
+-# endif
+-#endif
+-
+ #ifdef HAVE_HIDDEN
+ # define ZLIB_INTERNAL __attribute__((visibility ("hidden")))
+ #else
diff --git a/recipes-qt/qt5/qtbase_git.bb b/recipes-qt/qt5/qtbase_git.bb
index be4a96e6..90ee8522 100644
--- a/recipes-qt/qt5/qtbase_git.bb
+++ b/recipes-qt/qt5/qtbase_git.bb
@@ -37,6 +37,7 @@ SRC_URI += "\
file://0019-tst_QPluginLoader-Simplify-creating-a-fake-pointer-i.patch \
file://0021-rcc-Just-dcument-file-name-without-full-path-to-redu.patch \
file://0022-testlib-don-t-track-the-build-or-source-directories.patch \
+ file://0023-Remove-unsetting-_FILE_OFFSET_BITS.patch \
"
# Disable LTO for now, QT5 patches are being worked upstream, perhaps revisit with