aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorSamuli Piippo <samuli.piippo@qt.io>2017-06-07 16:16:59 +0300
committerSamuli Piippo <samuli.piippo@qt.io>2017-06-08 10:34:03 +0000
commit8116cc0e8acf90f8651fcb39eafcf006419e6e06 (patch)
tree24a602750dff09173c280e323eb1291e7e4df488
parent15a2e1643239b40ee1bc2ee32dd3b91ec6960dbf (diff)
qtremoteobjects: build repc tool for native and nativesdk
Tools is required for actually using QtRemoteObjects Change-Id: I455f5e693261da2290f742cd1f0131240cc4afe5 Reviewed-by: Teemu Holappa <teemu.holappa@qt.io>
-rw-r--r--recipes-qt/qt5/qtremoteobjects/0001-Allow-a-tools-only-build.patch37
-rw-r--r--recipes-qt/qt5/qtremoteobjects_git.bb15
2 files changed, 51 insertions, 1 deletions
diff --git a/recipes-qt/qt5/qtremoteobjects/0001-Allow-a-tools-only-build.patch b/recipes-qt/qt5/qtremoteobjects/0001-Allow-a-tools-only-build.patch
new file mode 100644
index 00000000..dfebc184
--- /dev/null
+++ b/recipes-qt/qt5/qtremoteobjects/0001-Allow-a-tools-only-build.patch
@@ -0,0 +1,37 @@
+From dd9d1e5ecdcd8267215523ad08ea893656a7f42d Mon Sep 17 00:00:00 2001
+From: Samuli Piippo <samuli.piippo@qt.io>
+Date: Wed, 7 Jun 2017 15:17:12 +0300
+Subject: [PATCH] Allow a tools-only build
+
+Change-Id: I3b33fc1c8877fc82568bd386b063e7a0aa57b706
+---
+ mkspecs/features/repccommon.pri | 2 +-
+ qtremoteobjects.pro | 5 +++++
+ 2 files changed, 6 insertions(+), 1 deletion(-)
+
+diff --git a/mkspecs/features/repccommon.pri b/mkspecs/features/repccommon.pri
+index 5e88bf8..6efd19e 100644
+--- a/mkspecs/features/repccommon.pri
++++ b/mkspecs/features/repccommon.pri
+@@ -3,7 +3,7 @@ cmd = $${QT.remoteobjects.bins}/repc
+ contains(QMAKE_HOST.os, Windows) {
+ cmd = $$system_path($${cmd}.exe)
+ }
+-exists($$cmd): QT_TOOL.repc.binary = $$cmd
++false:exists($$cmd): QT_TOOL.repc.binary = $$cmd
+
+ # qtPrepareTool honors QT_TOOL.repc.binary if set
+ qtPrepareTool(QMAKE_REPC, repc)
+diff --git a/qtremoteobjects.pro b/qtremoteobjects.pro
+index c2e2b6b..93c2bb5 100644
+--- a/qtremoteobjects.pro
++++ b/qtremoteobjects.pro
+@@ -2,3 +2,8 @@ CONFIG += examples_need_tools tests_need_tools
+ load(qt_parts)
+
+ SUBDIRS += mkspecs
++
++tools-only {
++ sub_tools.depends -= sub_src
++ SUBDIRS = sub_tools
++}
diff --git a/recipes-qt/qt5/qtremoteobjects_git.bb b/recipes-qt/qt5/qtremoteobjects_git.bb
index 550e0305..f563818d 100644
--- a/recipes-qt/qt5/qtremoteobjects_git.bb
+++ b/recipes-qt/qt5/qtremoteobjects_git.bb
@@ -9,6 +9,19 @@ LIC_FILES_CHKSUM = " \
require qt5.inc
require qt5-git.inc
-DEPENDS += "qtbase qtdeclarative"
+DEPENDS += "qtbase qtdeclarative qtremoteobjects-native"
+
+SRC_URI += " \
+ file://0001-Allow-a-tools-only-build.patch \
+"
+
+PACKAGECONFIG ??= ""
+PACKAGECONFIG_class-native ??= "tools-only"
+PACKAGECONFIG_class-nativesdk ??= "tools-only"
+PACKAGECONFIG[tools-only] = "CONFIG+=tools-only"
+
+EXTRA_QMAKEVARS_PRE += "${PACKAGECONFIG_CONFARGS}"
SRCREV = "ae0b101884b05355e3a7bc06dbca722ad3d08d0f"
+
+BBCLASSEXTEND += "native nativesdk"