aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorMikko Gronoff <mikko.gronoff@qt.io>2019-09-02 20:25:37 +0300
committerMikko Gronoff <mikko.gronoff@qt.io>2019-09-19 07:44:27 +0300
commita16976979e929618c8fc873b798d78fc82393cab (patch)
treef6881ce7c9119c3b1b3bce75577e2eddd0fa1c45
parentab2d92123df243c5668904bb693309a0ecbb2a3c (diff)
qt5: update submodules
Update to latest content in Qt 5.14.0 branch. Task-number: QTBUG-77876 Change-Id: I3ab35758a7e84bd15d50bcf794a9a3fd1fdaea3e Reviewed-by: Samuli Piippo <samuli.piippo@qt.io>
-rw-r--r--recipes-qt/qt5/nativesdk-qtbase_git.bb2
-rw-r--r--recipes-qt/qt5/qt3d_git.bb2
-rw-r--r--recipes-qt/qt5/qtbase-native_git.bb2
-rw-r--r--recipes-qt/qt5/qtbase/0004-configure-bump-path-length-from-256-to-512-character.patch10
-rw-r--r--recipes-qt/qt5/qtbase_git.bb2
-rw-r--r--recipes-qt/qt5/qtconnectivity_git.bb2
-rw-r--r--recipes-qt/qt5/qtdatavis3d_git.bb2
-rw-r--r--recipes-qt/qt5/qtdeclarative/0001-Revert-Yield-error-if-qtquickcompiler-is-used-in-non.patch36
-rw-r--r--recipes-qt/qt5/qtdeclarative/0002-scenegraph-fix-error-QOffscreenSurface-does-not-name.patch23
-rw-r--r--recipes-qt/qt5/qtdeclarative_git.bb4
-rw-r--r--recipes-qt/qt5/qtgraphicaleffects_git.bb2
-rw-r--r--recipes-qt/qt5/qtimageformats_git.bb2
-rw-r--r--recipes-qt/qt5/qtknx_git.bb2
-rw-r--r--recipes-qt/qt5/qtlocation_git.bb4
-rw-r--r--recipes-qt/qt5/qtmqtt_git.bb2
-rw-r--r--recipes-qt/qt5/qtmultimedia_git.bb2
-rw-r--r--recipes-qt/qt5/qtopcua_git.bb2
-rw-r--r--recipes-qt/qt5/qtquick3d_git.bb14
-rw-r--r--recipes-qt/qt5/qtquickcontrols2_git.bb2
-rw-r--r--recipes-qt/qt5/qtremoteobjects_git.bb2
-rw-r--r--recipes-qt/qt5/qtscript_git.bb2
-rw-r--r--recipes-qt/qt5/qtscxml/0001-Fix-shadow-build.patch37
-rw-r--r--recipes-qt/qt5/qtscxml_git.bb3
-rw-r--r--recipes-qt/qt5/qtsensors_git.bb2
-rw-r--r--recipes-qt/qt5/qtserialbus_git.bb2
-rw-r--r--recipes-qt/qt5/qtserialport_git.bb2
-rw-r--r--recipes-qt/qt5/qtsvg_git.bb2
-rw-r--r--recipes-qt/qt5/qttools_git.bb2
-rw-r--r--recipes-qt/qt5/qttranslations_git.bb2
-rw-r--r--recipes-qt/qt5/qtvirtualkeyboard_git.bb2
-rw-r--r--recipes-qt/qt5/qtwayland_git.bb2
-rw-r--r--recipes-qt/qt5/qtwebchannel_git.bb2
-rw-r--r--recipes-qt/qt5/qtwebengine/0001-Force-host-toolchain-configuration.patch34
-rw-r--r--recipes-qt/qt5/qtwebengine/0004-musl-allow-build-without-glibc.patch14
-rw-r--r--recipes-qt/qt5/qtwebengine_git.bb4
-rw-r--r--recipes-qt/qt5/qtwebsockets_git.bb2
-rw-r--r--recipes-qt/qt5/qtx11extras_git.bb2
-rw-r--r--recipes-qt/qt5/qtxmlpatterns_git.bb2
38 files changed, 75 insertions, 162 deletions
diff --git a/recipes-qt/qt5/nativesdk-qtbase_git.bb b/recipes-qt/qt5/nativesdk-qtbase_git.bb
index dab74157..aece580c 100644
--- a/recipes-qt/qt5/nativesdk-qtbase_git.bb
+++ b/recipes-qt/qt5/nativesdk-qtbase_git.bb
@@ -193,4 +193,4 @@ fakeroot do_generate_qt_environment_file() {
do_generate_qt_environment_file[umask] = "022"
addtask generate_qt_environment_file after do_install before do_package
-SRCREV = "50e496bd3ac71ccebc99c0a429b41fb0e7864ac2"
+SRCREV = "9864d2c6f3b628ca9f07a56b197e77bd43931cca"
diff --git a/recipes-qt/qt5/qt3d_git.bb b/recipes-qt/qt5/qt3d_git.bb
index 2ad121dd..9686768a 100644
--- a/recipes-qt/qt5/qt3d_git.bb
+++ b/recipes-qt/qt5/qt3d_git.bb
@@ -36,6 +36,6 @@ do_configure_prepend() {
${S}/src/quick3d/imports/input/importsinput.pro
}
-SRCREV = "87abbae2f16bae53aff6b2e41658bafbef642a95"
+SRCREV = "7814da64942c4566e2fa9c9e2bd2a1e169e7fab9"
BBCLASSEXTEND += "native nativesdk"
diff --git a/recipes-qt/qt5/qtbase-native_git.bb b/recipes-qt/qt5/qtbase-native_git.bb
index 33a9e464..186e2cff 100644
--- a/recipes-qt/qt5/qtbase-native_git.bb
+++ b/recipes-qt/qt5/qtbase-native_git.bb
@@ -140,4 +140,4 @@ do_install() {
echo 'set(_qt5_corelib_extra_includes "${_qt5Core_install_prefix}/lib${QT_DIR_NAME}/mkspecs/linux-oe-g++")' > ${D}${libdir}/cmake/Qt5Core/Qt5CoreConfigExtrasMkspecDir.cmake
}
-SRCREV = "50e496bd3ac71ccebc99c0a429b41fb0e7864ac2"
+SRCREV = "9864d2c6f3b628ca9f07a56b197e77bd43931cca"
diff --git a/recipes-qt/qt5/qtbase/0004-configure-bump-path-length-from-256-to-512-character.patch b/recipes-qt/qt5/qtbase/0004-configure-bump-path-length-from-256-to-512-character.patch
index 420a1e3c..02796515 100644
--- a/recipes-qt/qt5/qtbase/0004-configure-bump-path-length-from-256-to-512-character.patch
+++ b/recipes-qt/qt5/qtbase/0004-configure-bump-path-length-from-256-to-512-character.patch
@@ -1,4 +1,4 @@
-From 7f912753d733d218eb87fd3b3d1d3d39e336f566 Mon Sep 17 00:00:00 2001
+From 51353f7fa6a7c1480e52e7f630d7bf1f129fbd9e Mon Sep 17 00:00:00 2001
From: Denys Dmytriyenko <denys@ti.com>
Date: Tue, 25 Aug 2015 10:05:15 -0400
Subject: [PATCH] configure: bump path length from 256 to 512 characters
@@ -15,12 +15,12 @@ Signed-off-by: Denys Dmytriyenko <denys@ti.com>
1 file changed, 3 insertions(+), 3 deletions(-)
diff --git a/configure.pri b/configure.pri
-index 131aa868c2..294dfd6fd2 100644
+index e26b557..1b470a8 100644
--- a/configure.pri
+++ b/configure.pri
-@@ -843,10 +843,10 @@ defineTest(qtConfOutput_preparePaths) {
- "static const char qt_configure_installation [12+11] = \"qt_instdate=2012-12-20\";" \
- "" \
+@@ -844,10 +844,10 @@ defineTest(qtConfOutput_preparePaths) {
+
+ $${currentConfig}.output.qconfigSource = \
"/* Installation Info */" \
- "static const char qt_configure_prefix_path_str [12+256] = \"qt_prfxpath=$$config.input.prefix\";" \
+ "static const char qt_configure_prefix_path_str [12+512] = \"qt_prfxpath=$$config.input.prefix\";" \
diff --git a/recipes-qt/qt5/qtbase_git.bb b/recipes-qt/qt5/qtbase_git.bb
index cf22d141..6e32af6c 100644
--- a/recipes-qt/qt5/qtbase_git.bb
+++ b/recipes-qt/qt5/qtbase_git.bb
@@ -275,4 +275,4 @@ INSANE_SKIP_${PN}-mkspecs += "file-rdeps"
RRECOMMENDS_${PN}-plugins += "${@bb.utils.contains('DISTRO_FEATURES', 'x11', 'libx11-locale', '', d)}"
-SRCREV = "50e496bd3ac71ccebc99c0a429b41fb0e7864ac2"
+SRCREV = "9864d2c6f3b628ca9f07a56b197e77bd43931cca"
diff --git a/recipes-qt/qt5/qtconnectivity_git.bb b/recipes-qt/qt5/qtconnectivity_git.bb
index 6ebf985c..502364f3 100644
--- a/recipes-qt/qt5/qtconnectivity_git.bb
+++ b/recipes-qt/qt5/qtconnectivity_git.bb
@@ -19,4 +19,4 @@ PACKAGECONFIG[bluez] = "-feature-bluez,-no-feature-bluez,bluez5"
EXTRA_QMAKEVARS_CONFIGURE += "${PACKAGECONFIG_CONFARGS}"
-SRCREV = "ccc1544f5ff929f466df8c790a4e7595e177a720"
+SRCREV = "2c6dcc643f29c212fca0ead123a377e96b9a17c9"
diff --git a/recipes-qt/qt5/qtdatavis3d_git.bb b/recipes-qt/qt5/qtdatavis3d_git.bb
index c06e2f63..461165aa 100644
--- a/recipes-qt/qt5/qtdatavis3d_git.bb
+++ b/recipes-qt/qt5/qtdatavis3d_git.bb
@@ -8,4 +8,4 @@ LIC_FILES_CHKSUM = " \
DEPENDS += "qtbase qtdeclarative qtmultimedia qtxmlpatterns"
-SRCREV = "422856bb470e1380309c66a8ba4b40e06d1df830"
+SRCREV = "548b93d6e5e70afeb220502170a51cc2e2510139"
diff --git a/recipes-qt/qt5/qtdeclarative/0001-Revert-Yield-error-if-qtquickcompiler-is-used-in-non.patch b/recipes-qt/qt5/qtdeclarative/0001-Revert-Yield-error-if-qtquickcompiler-is-used-in-non.patch
deleted file mode 100644
index d2bac1f7..00000000
--- a/recipes-qt/qt5/qtdeclarative/0001-Revert-Yield-error-if-qtquickcompiler-is-used-in-non.patch
+++ /dev/null
@@ -1,36 +0,0 @@
-From 5ae643e2ab69892e0dbe296cf14e020c7938ebee Mon Sep 17 00:00:00 2001
-From: =?UTF-8?q?J=C3=B6rg=20Bornemann?= <joerg.bornemann@qt.io>
-Date: Fri, 2 Aug 2019 11:03:06 +0000
-Subject: [PATCH] Revert "Yield error if qtquickcompiler is used in non-QML
- projects"
-
-This reverts commit c5578b16d6454e708c8ce12661a85d41eeaaa758, because
-it prevents enabling the qtquickcompiler feature globally.
-
-Fixes: QTBUG-77277
-Change-Id: Ic80835c462570a67ae3105bb3d1b6452800d2c94
-Reviewed-by: Kai Koehne <kai.koehne@qt.io>
----
- tools/qmlcachegen/qtquickcompiler.prf | 10 ----------
- 1 file changed, 10 deletions(-)
-
-diff --git a/tools/qmlcachegen/qtquickcompiler.prf b/tools/qmlcachegen/qtquickcompiler.prf
-index 967d55a5b..b98d8a019 100644
---- a/tools/qmlcachegen/qtquickcompiler.prf
-+++ b/tools/qmlcachegen/qtquickcompiler.prf
-@@ -1,15 +1,5 @@
- if(qtc_run|lupdate_run): return()
-
--!contains(QT, qml) {
-- qt_modules = \
-- $$replace(QT, -private$, _private) \
-- $$replace(QT_PRIVATE, -private$, _private)
-- qt_modules = $$resolve_depends(qt_modules, "QT.", ".depends" ".run_depends")
-- !contains(qt_modules, qml): \
-- error("The qtquickcompiler feature cannot be used without the QML module.")
-- unset(qt_modules)
--}
--
- qtPrepareTool(QML_CACHEGEN, qmlcachegen, _FILTER)
- qtPrepareTool(QMAKE_RCC, rcc, _DEP)
-
diff --git a/recipes-qt/qt5/qtdeclarative/0002-scenegraph-fix-error-QOffscreenSurface-does-not-name.patch b/recipes-qt/qt5/qtdeclarative/0002-scenegraph-fix-error-QOffscreenSurface-does-not-name.patch
deleted file mode 100644
index 3de99517..00000000
--- a/recipes-qt/qt5/qtdeclarative/0002-scenegraph-fix-error-QOffscreenSurface-does-not-name.patch
+++ /dev/null
@@ -1,23 +0,0 @@
-From 258a0c6a231f2f853858229e9e069aae71290bba Mon Sep 17 00:00:00 2001
-From: Mikko Gronoff <mikko.gronoff@qt.io>
-Date: Mon, 12 Aug 2019 08:27:19 +0300
-Subject: [PATCH] scenegraph: fix error: 'QOffscreenSurface' does not name a
- type
-
-Change-Id: I41a8b30b316b038ed1e3910adb0254931f385a2a
----
- src/quick/scenegraph/qsgrhisupport_p.h | 1 +
- 1 file changed, 1 insertion(+)
-
-diff --git a/src/quick/scenegraph/qsgrhisupport_p.h b/src/quick/scenegraph/qsgrhisupport_p.h
-index 48ad2f0..0e1881a 100644
---- a/src/quick/scenegraph/qsgrhisupport_p.h
-+++ b/src/quick/scenegraph/qsgrhisupport_p.h
-@@ -86,6 +86,7 @@ QT_BEGIN_NAMESPACE
-
- class QSGDefaultRenderContext;
- class QVulkanInstance;
-+class QOffscreenSurface;
-
- // Opting in/out of QRhi and choosing the default/requested backend is managed
- // by this singleton. This is because this information may be needed before
diff --git a/recipes-qt/qt5/qtdeclarative_git.bb b/recipes-qt/qt5/qtdeclarative_git.bb
index df06f813..0f8d1fbc 100644
--- a/recipes-qt/qt5/qtdeclarative_git.bb
+++ b/recipes-qt/qt5/qtdeclarative_git.bb
@@ -16,8 +16,6 @@ DEPENDS += "qtbase"
SRC_URI += "\
file://0001-Use-OE_QMAKE_PATH_EXTERNAL_HOST_BINS-to-locate-qmlca.patch \
- file://0001-Revert-Yield-error-if-qtquickcompiler-is-used-in-non.patch \
- file://0002-scenegraph-fix-error-QOffscreenSurface-does-not-name.patch \
"
PACKAGECONFIG ??= "qml-debug qml-network ${@bb.utils.contains('DISTRO_FEATURES', 'qt5-static', 'static', '', d)}"
@@ -30,6 +28,6 @@ do_install_append_class-nativesdk() {
rm -rf ${D}${OE_QMAKE_PATH_QML}
}
-SRCREV = "d4e1f5395c896dc5bda9a2e122e2ed0f45be6c18"
+SRCREV = "90a706dffb944e7d18b8b199b1cea68633e2b172"
BBCLASSEXTEND =+ "native nativesdk"
diff --git a/recipes-qt/qt5/qtgraphicaleffects_git.bb b/recipes-qt/qt5/qtgraphicaleffects_git.bb
index 09569195..b2af445f 100644
--- a/recipes-qt/qt5/qtgraphicaleffects_git.bb
+++ b/recipes-qt/qt5/qtgraphicaleffects_git.bb
@@ -18,4 +18,4 @@ RDEPENDS_${PN}-dev = ""
# http://errors.yoctoproject.org/Errors/Build/44912/
LDFLAGS_append_x86 = "${@bb.utils.contains('DISTRO_FEATURES', 'ld-is-gold', ' -fuse-ld=bfd ', '', d)}"
-SRCREV = "c76eb211ff12fc3a1588c3092dd76a41eb5551c7"
+SRCREV = "cb8c28031c60c708721ef8a875076f12a630e6b9"
diff --git a/recipes-qt/qt5/qtimageformats_git.bb b/recipes-qt/qt5/qtimageformats_git.bb
index b089fc74..37683ad2 100644
--- a/recipes-qt/qt5/qtimageformats_git.bb
+++ b/recipes-qt/qt5/qtimageformats_git.bb
@@ -25,4 +25,4 @@ PACKAGECONFIG[libwebp] = ",CONFIG+=done_config_libwebp,libwebp"
EXTRA_QMAKEVARS_PRE += "${PACKAGECONFIG_CONFARGS}"
-SRCREV = "82a6d3426215253e013dd3ddd6712488388bc926"
+SRCREV = "44000c87d352e4f88b7eea3d441a807b755698d3"
diff --git a/recipes-qt/qt5/qtknx_git.bb b/recipes-qt/qt5/qtknx_git.bb
index cd525271..1474c64b 100644
--- a/recipes-qt/qt5/qtknx_git.bb
+++ b/recipes-qt/qt5/qtknx_git.bb
@@ -9,4 +9,4 @@ LIC_FILES_CHKSUM = " \
DEPENDS += "qtbase"
-SRCREV = "99dd0e8203d789caf2edfd2105c398654f5b5748"
+SRCREV = "df0ba9b97c26901f52769381df3c4cbf1fae9ca6"
diff --git a/recipes-qt/qt5/qtlocation_git.bb b/recipes-qt/qt5/qtlocation_git.bb
index 1ba9cb6a..a7d4670d 100644
--- a/recipes-qt/qt5/qtlocation_git.bb
+++ b/recipes-qt/qt5/qtlocation_git.bb
@@ -36,7 +36,7 @@ SRC_URI += " \
${QT_GIT}/qtlocation-mapboxgl.git;name=qtlocation-mapboxgl;branch=${QT_MODULE_BRANCH_MAPBOXGL};protocol=${QT_GIT_PROTOCOL};destsuffix=git/src/3rdparty/mapbox-gl-native \
"
-SRCREV_qtlocation = "3334c6f6d00255f6fd5690e4b9cb05416950fd4d"
-SRCREV_qtlocation-mapboxgl = "4b85252fbe811a786c6ee9eabedb7639b031dc53"
+SRCREV_qtlocation = "08972f5e65c8d7286fe1435cb85be4574ac3772f"
+SRCREV_qtlocation-mapboxgl = "5233c75b3f6c73623c5473b2d6573f31f3ddb4b7"
SRCREV_FORMAT = "qtlocation_qtlocation-mapboxgl"
diff --git a/recipes-qt/qt5/qtmqtt_git.bb b/recipes-qt/qt5/qtmqtt_git.bb
index e986dc91..0c87063d 100644
--- a/recipes-qt/qt5/qtmqtt_git.bb
+++ b/recipes-qt/qt5/qtmqtt_git.bb
@@ -9,4 +9,4 @@ LIC_FILES_CHKSUM = " \
DEPENDS += "qtbase"
-SRCREV = "9e7eba636ebb5ca42822f682be2b442be50cde6e"
+SRCREV = "954534fb5542dda1ab1a1730f7ef57c250d9f10c"
diff --git a/recipes-qt/qt5/qtmultimedia_git.bb b/recipes-qt/qt5/qtmultimedia_git.bb
index 2e9afa20..89ef41bb 100644
--- a/recipes-qt/qt5/qtmultimedia_git.bb
+++ b/recipes-qt/qt5/qtmultimedia_git.bb
@@ -37,4 +37,4 @@ SRC_URI += "\
# http://errors.yoctoproject.org/Errors/Build/44914/
LDFLAGS_append_x86 = "${@bb.utils.contains('DISTRO_FEATURES', 'ld-is-gold', ' -fuse-ld=bfd ', '', d)}"
-SRCREV = "9178132f75563cd0e907525f08736c1b4cec73b4"
+SRCREV = "38e49d060d13ef592f457a5d6640d68a2d9c6b06"
diff --git a/recipes-qt/qt5/qtopcua_git.bb b/recipes-qt/qt5/qtopcua_git.bb
index 599711e9..b53e014d 100644
--- a/recipes-qt/qt5/qtopcua_git.bb
+++ b/recipes-qt/qt5/qtopcua_git.bb
@@ -18,4 +18,4 @@ SECURITY_STRINGFORMAT = ""
DEPENDS += "qtbase"
-SRCREV = "0654a03da7884c7a222a8662622810e59996a124"
+SRCREV = "2e5ffcf29ac1867ab07e93684e4243e71d7ae8f7"
diff --git a/recipes-qt/qt5/qtquick3d_git.bb b/recipes-qt/qt5/qtquick3d_git.bb
index b63c889f..6c0065ac 100644
--- a/recipes-qt/qt5/qtquick3d_git.bb
+++ b/recipes-qt/qt5/qtquick3d_git.bb
@@ -8,8 +8,20 @@ LIC_FILES_CHKSUM = " \
DEPENDS += "qtbase qtdeclarative qtquickcontrols2"
+SRC_URI += " \
+ git://github.com/assimp/assimp.git;name=assimp;branch=master;protocol=https;destsuffix=git/src/3rdparty/assimp/src \
+"
+
+PACKAGECONFIG ??= ""
+PACKAGECONFIG[system-assimp] = "-system-assimp,-qt-assimp,assimp"
+
+EXTRA_QMAKEVARS_CONFIGURE += "${PACKAGECONFIG_CONFARGS}"
+
FILES_${PN}-qmlplugins += " \
${OE_QMAKE_PATH_QML}/QtQuick3D/Helpers/meshes/*.mesh \
"
-SRCREV = "03dbcc5eb3364886ee8ffc07b4438eaee3c188fe"
+SRCREV_qtquick3d = "fa5d0b457c5e31cea5a1bddad574d4505c93174f"
+SRCREV_assimp = "5c900d689a5db5637b98f665fc1e9e9c9ed416b9"
+
+SRCREV_FORMAT = "qtquick3d_assimp"
diff --git a/recipes-qt/qt5/qtquickcontrols2_git.bb b/recipes-qt/qt5/qtquickcontrols2_git.bb
index a0dea147..95322e1e 100644
--- a/recipes-qt/qt5/qtquickcontrols2_git.bb
+++ b/recipes-qt/qt5/qtquickcontrols2_git.bb
@@ -10,4 +10,4 @@ LIC_FILES_CHKSUM = " \
DEPENDS += "qtdeclarative qtdeclarative-native"
-SRCREV = "92c827a2a4b7e56dcb6865fa35fba25b5d2eb87f"
+SRCREV = "e0b2a30357a6fbb2d52fcba69f0a5059d3b065b8"
diff --git a/recipes-qt/qt5/qtremoteobjects_git.bb b/recipes-qt/qt5/qtremoteobjects_git.bb
index 9c2306e1..511f9207 100644
--- a/recipes-qt/qt5/qtremoteobjects_git.bb
+++ b/recipes-qt/qt5/qtremoteobjects_git.bb
@@ -25,6 +25,6 @@ PACKAGECONFIG[tools-only] = "CONFIG+=tools-only"
EXTRA_QMAKEVARS_PRE += "${PACKAGECONFIG_CONFARGS}"
-SRCREV = "d88c6a1690d1d725e4436537546b3d5681ee4a9f"
+SRCREV = "acb75637a429d1a540b0b86b35554f75bd13b44b"
BBCLASSEXTEND += "native nativesdk"
diff --git a/recipes-qt/qt5/qtscript_git.bb b/recipes-qt/qt5/qtscript_git.bb
index e2c035bb..31f57180 100644
--- a/recipes-qt/qt5/qtscript_git.bb
+++ b/recipes-qt/qt5/qtscript_git.bb
@@ -36,4 +36,4 @@ DEPENDS += "qtbase"
# http://errors.yoctoproject.org/Errors/Build/44915/
LDFLAGS_append_x86 = "${@bb.utils.contains('DISTRO_FEATURES', 'ld-is-gold', ' -fuse-ld=bfd ', '', d)}"
-SRCREV = "40b5d325b6105d4e520c76a079f530168b58efec"
+SRCREV = "1de1f080ef4b37576843bd59a8aa3e484c918820"
diff --git a/recipes-qt/qt5/qtscxml/0001-Fix-shadow-build.patch b/recipes-qt/qt5/qtscxml/0001-Fix-shadow-build.patch
deleted file mode 100644
index 96d87b82..00000000
--- a/recipes-qt/qt5/qtscxml/0001-Fix-shadow-build.patch
+++ /dev/null
@@ -1,37 +0,0 @@
-From 91547b21cbbdc608a800ad53f47f296798b370ab Mon Sep 17 00:00:00 2001
-From: Samuli Piippo <samuli.piippo@qt.io>
-Date: Mon, 19 Aug 2019 15:17:13 +0300
-Subject: [PATCH] Fix shadow build
-
-Don't write to source directory when using shadow build.
-This stops working with Qt 5.14.0.
-
-Change-Id: Ica83b9c810e2a937aab75af131484f5f91570453
----
- tests/auto/scion/scion.pro | 8 ++++----
- 1 file changed, 4 insertions(+), 4 deletions(-)
-
-diff --git a/tests/auto/scion/scion.pro b/tests/auto/scion/scion.pro
-index 6e1f7f4..1ebc624 100644
---- a/tests/auto/scion/scion.pro
-+++ b/tests/auto/scion/scion.pro
-@@ -89,15 +89,15 @@ for (f,ALLSCXMLS) {
- ALLFILES = $$files($$SCXMLS_DIR/*.*, true)
- for (f,ALLFILES) {
- base = $$relative_path($$f,$$absolute_path($$SCXMLS_DIR))
-- file = $$relative_path($$f, $$absolute_path($$PWD))
-+ file = $$relative_path($$f, $$absolute_path($$OUT_PWD))
- qrc += '<file alias="$$base">$$file</file>'
- }
-
- contents = $$inc_list "std::function<QScxmlStateMachine *()> creators[] = {" $$func_list "};"
--write_file("scxml/compiled_tests.h", contents)|error("Aborting.")
-+write_file("$$OUT_PWD/scxml/compiled_tests.h", contents)|error("Aborting.")
-
- contents = "const char *testBases[] = {" $$testBases "};"
--write_file("scxml/scion.h", contents)|error("Aborting.")
-+write_file("$$OUT_PWD/scxml/scion.h", contents)|error("Aborting.")
-
- contents = '<!DOCTYPE RCC><RCC version=\"1.0\">' '<qresource>' $$qrc '</qresource></RCC>'
--write_file("scion.qrc", contents)|error("Aborting.")
-+write_file("$$OUT_PWD/scion.qrc", contents)|error("Aborting.")
diff --git a/recipes-qt/qt5/qtscxml_git.bb b/recipes-qt/qt5/qtscxml_git.bb
index 2e8b42d8..d02d0a8f 100644
--- a/recipes-qt/qt5/qtscxml_git.bb
+++ b/recipes-qt/qt5/qtscxml_git.bb
@@ -10,13 +10,12 @@ require qt5-git.inc
DEPENDS += "qtbase qtdeclarative qtxmlpatterns qtscxml-native"
-SRCREV = "279d63c4f6632237e6a0d9c4be91b466876c260a"
+SRCREV = "07c62001b55b515629062ccc51e8c12aaa7d4eec"
# Patches from https://github.com/meta-qt5/qtscxml/commits/b5.12
# 5.12.meta-qt5.2
SRC_URI += "\
file://0001-Use-external-host-bin-path-for-cmake-file.patch \
- file://0001-Fix-shadow-build.patch \
"
do_install_append_class-nativesdk() {
diff --git a/recipes-qt/qt5/qtsensors_git.bb b/recipes-qt/qt5/qtsensors_git.bb
index d01efbee..b8c43d8a 100644
--- a/recipes-qt/qt5/qtsensors_git.bb
+++ b/recipes-qt/qt5/qtsensors_git.bb
@@ -12,4 +12,4 @@ LIC_FILES_CHKSUM = " \
DEPENDS += "qtbase qtdeclarative"
-SRCREV = "4dfa95538ff15f59880c93675676ce609b365d89"
+SRCREV = "c4519ffcfc009d4ffbfa77bfa1b7c9749b9fe7dc"
diff --git a/recipes-qt/qt5/qtserialbus_git.bb b/recipes-qt/qt5/qtserialbus_git.bb
index 6096475f..113328f0 100644
--- a/recipes-qt/qt5/qtserialbus_git.bb
+++ b/recipes-qt/qt5/qtserialbus_git.bb
@@ -11,4 +11,4 @@ LIC_FILES_CHKSUM = " \
DEPENDS += "qtbase qtserialport"
-SRCREV = "556c6b67315c25f7e4359ab19314f3485f10ecc6"
+SRCREV = "47eaa2b1a58db67643f32cb1d8779c5b199ccb10"
diff --git a/recipes-qt/qt5/qtserialport_git.bb b/recipes-qt/qt5/qtserialport_git.bb
index cd1d984a..2598df97 100644
--- a/recipes-qt/qt5/qtserialport_git.bb
+++ b/recipes-qt/qt5/qtserialport_git.bb
@@ -12,4 +12,4 @@ LIC_FILES_CHKSUM = " \
DEPENDS += "qtbase"
-SRCREV = "bc4196f908a96522ecaab078141364b3e10d1788"
+SRCREV = "78bfc0a93077dafb217f854782e14b65a5746949"
diff --git a/recipes-qt/qt5/qtsvg_git.bb b/recipes-qt/qt5/qtsvg_git.bb
index 8a05ea2d..e8c85a33 100644
--- a/recipes-qt/qt5/qtsvg_git.bb
+++ b/recipes-qt/qt5/qtsvg_git.bb
@@ -12,4 +12,4 @@ LIC_FILES_CHKSUM = " \
DEPENDS += "qtbase"
-SRCREV = "b80a1676c9f5cc0b428f15ac09f6648a80aacb26"
+SRCREV = "d8ccc52c038a033b20c96041b998322a907521c4"
diff --git a/recipes-qt/qt5/qttools_git.bb b/recipes-qt/qt5/qttools_git.bb
index 91ce0a2c..1f70e686 100644
--- a/recipes-qt/qt5/qttools_git.bb
+++ b/recipes-qt/qt5/qttools_git.bb
@@ -39,7 +39,7 @@ EXTRA_QMAKEVARS_PRE_append_class-target = "\
${@bb.utils.contains('PACKAGECONFIG', 'clang', 'CONFIG+=config_clang', 'CONFIG-=config_clang', d)} \
"
-SRCREV = "eba0529d488536e83b1e32b1c1c6c1000790e329"
+SRCREV = "01d70a3150191445b043873db2a19474983a411e"
BBCLASSEXTEND = "native nativesdk"
diff --git a/recipes-qt/qt5/qttranslations_git.bb b/recipes-qt/qt5/qttranslations_git.bb
index de74f4fb..ff8d498f 100644
--- a/recipes-qt/qt5/qttranslations_git.bb
+++ b/recipes-qt/qt5/qttranslations_git.bb
@@ -98,4 +98,4 @@ FILES_${PN}-qthelp = " \
${OE_QMAKE_PATH_TRANSLATIONS}/qt_help_*.qm \
"
-SRCREV = "66952c79bc648e1074936dddb7fa2cffc17b1777"
+SRCREV = "c3f688fbdfaf633d7e6dd198865d4dc6cdef04b8"
diff --git a/recipes-qt/qt5/qtvirtualkeyboard_git.bb b/recipes-qt/qt5/qtvirtualkeyboard_git.bb
index 70303f38..f5940f90 100644
--- a/recipes-qt/qt5/qtvirtualkeyboard_git.bb
+++ b/recipes-qt/qt5/qtvirtualkeyboard_git.bb
@@ -71,4 +71,4 @@ FILES_${PN} += "${OE_QMAKE_PATH_DATA}/qtvirtualkeyboard/lipi_toolkit"
DEPENDS += "qtbase qtdeclarative qtmultimedia qtquickcontrols qtsvg qtxmlpatterns qtdeclarative-native"
-SRCREV = "e342f1366eff06f3cf01991b377c880b2d246177"
+SRCREV = "997a4c23d5c062644eda3b0db74252654289bdc5"
diff --git a/recipes-qt/qt5/qtwayland_git.bb b/recipes-qt/qt5/qtwayland_git.bb
index 2cd4c0e0..cd1c0d53 100644
--- a/recipes-qt/qt5/qtwayland_git.bb
+++ b/recipes-qt/qt5/qtwayland_git.bb
@@ -37,7 +37,7 @@ PACKAGECONFIG[wayland-libhybris-egl-server-buffer] = "-feature-wayland-libhybris
EXTRA_QMAKEVARS_CONFIGURE += "${PACKAGECONFIG_CONFARGS}"
-SRCREV = "52b6560708ebcfeeaebdf2b43f368c610aa905a4"
+SRCREV = "559f4fa005b140105e29e09c96084f59148565c5"
BBCLASSEXTEND =+ "native nativesdk"
diff --git a/recipes-qt/qt5/qtwebchannel_git.bb b/recipes-qt/qt5/qtwebchannel_git.bb
index fd66bfed..9d9fd12a 100644
--- a/recipes-qt/qt5/qtwebchannel_git.bb
+++ b/recipes-qt/qt5/qtwebchannel_git.bb
@@ -12,4 +12,4 @@ LIC_FILES_CHKSUM = " \
DEPENDS += "qtdeclarative qtwebsockets"
-SRCREV = "29496e3f08e20398e253e6d32bb95879a1a68978"
+SRCREV = "744a7330f786259bd48e442da391d11ab12d62c7"
diff --git a/recipes-qt/qt5/qtwebengine/0001-Force-host-toolchain-configuration.patch b/recipes-qt/qt5/qtwebengine/0001-Force-host-toolchain-configuration.patch
index 610b703f..e5e11036 100644
--- a/recipes-qt/qt5/qtwebengine/0001-Force-host-toolchain-configuration.patch
+++ b/recipes-qt/qt5/qtwebengine/0001-Force-host-toolchain-configuration.patch
@@ -1,4 +1,4 @@
-From 468ed461a955cc1ab3d890178546b79b9d001de9 Mon Sep 17 00:00:00 2001
+From f1db5849e2af526f1ec9297b42b4b1684f542a29 Mon Sep 17 00:00:00 2001
From: Samuli Piippo <samuli.piippo@qt.io>
Date: Wed, 15 Mar 2017 13:53:28 +0200
Subject: [PATCH] Force host toolchain configuration
@@ -13,13 +13,26 @@ for the qmakes's host architecture.
Upstream-Status: Inappropriate [OE specific]
Signed-off-by: Samuli Piippo <samuli.piippo@qt.io>
---
+ src/buildtools/config/linux.pri | 2 +-
src/buildtools/configure_host.pro | 14 +++++++-------
src/buildtools/gn.pro | 4 ++--
- src/core/config/linux.pri | 2 +-
3 files changed, 10 insertions(+), 10 deletions(-)
+diff --git a/src/buildtools/config/linux.pri b/src/buildtools/config/linux.pri
+index 998aedc..b04db36 100644
+--- a/src/buildtools/config/linux.pri
++++ b/src/buildtools/config/linux.pri
+@@ -124,7 +124,7 @@ contains(QT_ARCH, "mips") {
+
+ host_build {
+ gn_args += custom_toolchain=\"$$QTWEBENGINE_OUT_ROOT/src/toolchain:host\"
+- GN_HOST_CPU = $$gnArch($$QT_ARCH)
++ GN_HOST_CPU = $$gnArch($$QMAKE_HOST.arch)
+ gn_args += host_cpu=\"$$GN_HOST_CPU\"
+ # Don't bother trying to use system libraries in this case
+ gn_args += use_glib=false
diff --git a/src/buildtools/configure_host.pro b/src/buildtools/configure_host.pro
-index dd0d3e32..6312c867 100644
+index dd0d3e3..6312c86 100644
--- a/src/buildtools/configure_host.pro
+++ b/src/buildtools/configure_host.pro
@@ -4,7 +4,7 @@ TEMPLATE = aux
@@ -58,7 +71,7 @@ index dd0d3e32..6312c867 100644
" nm = \"$$which(nm)\" " \
" toolchain_args = { " \
diff --git a/src/buildtools/gn.pro b/src/buildtools/gn.pro
-index b6bf9cfc..ae419b1a 100644
+index 033202e..a8ca656 100644
--- a/src/buildtools/gn.pro
+++ b/src/buildtools/gn.pro
@@ -19,8 +19,8 @@ build_pass|!debug_and_release {
@@ -72,16 +85,3 @@ index b6bf9cfc..ae419b1a 100644
msvc:!clang_cl: gn_gen_args += --use-lto
-diff --git a/src/core/config/linux.pri b/src/core/config/linux.pri
-index fcce4c31..e3384e58 100644
---- a/src/core/config/linux.pri
-+++ b/src/core/config/linux.pri
-@@ -117,7 +117,7 @@ contains(QT_ARCH, "mips") {
-
- host_build {
- gn_args += custom_toolchain=\"$$QTWEBENGINE_OUT_ROOT/src/toolchain:host\"
-- GN_HOST_CPU = $$gnArch($$QT_ARCH)
-+ GN_HOST_CPU = $$gnArch($$QMAKE_HOST.arch)
- gn_args += host_cpu=\"$$GN_HOST_CPU\"
- # Don't bother trying to use system libraries in this case
- gn_args += use_glib=false
diff --git a/recipes-qt/qt5/qtwebengine/0004-musl-allow-build-without-glibc.patch b/recipes-qt/qt5/qtwebengine/0004-musl-allow-build-without-glibc.patch
index 3047230c..f464f4a6 100644
--- a/recipes-qt/qt5/qtwebengine/0004-musl-allow-build-without-glibc.patch
+++ b/recipes-qt/qt5/qtwebengine/0004-musl-allow-build-without-glibc.patch
@@ -1,18 +1,18 @@
-From a1c248259f3d8561d6e2c75a56edf4a72c393843 Mon Sep 17 00:00:00 2001
+From 5a1d55ce93a51b35b7c409bcf778a6439ab34906 Mon Sep 17 00:00:00 2001
From: Samuli Piippo <samuli.piippo@qt.io>
Date: Thu, 15 Aug 2019 07:52:53 +0300
Subject: [PATCH] musl: allow build without glibc
Signed-off-by: Samuli Piippo <samuli.piippo@qt.io>
---
- mkspecs/features/configure.prf | 2 +-
+ mkspecs/features/functions.prf | 2 +-
1 file changed, 1 insertion(+), 1 deletion(-)
-diff --git a/mkspecs/features/configure.prf b/mkspecs/features/configure.prf
-index cc84182b..f1310f75 100644
---- a/mkspecs/features/configure.prf
-+++ b/mkspecs/features/configure.prf
-@@ -75,7 +75,7 @@ defineTest(runConfigure) {
+diff --git a/mkspecs/features/functions.prf b/mkspecs/features/functions.prf
+index a301929..15e7110 100644
+--- a/mkspecs/features/functions.prf
++++ b/mkspecs/features/functions.prf
+@@ -167,7 +167,7 @@ defineTest(isWebEngineCoreBuild) {
return(false)
}
diff --git a/recipes-qt/qt5/qtwebengine_git.bb b/recipes-qt/qt5/qtwebengine_git.bb
index 28f1d3a8..fd4faecd 100644
--- a/recipes-qt/qt5/qtwebengine_git.bb
+++ b/recipes-qt/qt5/qtwebengine_git.bb
@@ -172,8 +172,8 @@ SRC_URI_append_libc-musl = "\
file://chromium/0019-chromium-musl-pread-pwrite.patch;patchdir=src/3rdparty \
"
-SRCREV_qtwebengine = "23b24fb49a9115151ea086afd271fdf9bb36fda0"
-SRCREV_chromium = "f5613a4bc321972b8f72654d4c4bc9ba0c36ffbe"
+SRCREV_qtwebengine = "8daefcfd8e1bf41ae4d06c7a79a526b81a78dc58"
+SRCREV_chromium = "feccbb4ea7fa685dcd013f5a3f6c14ea768636c9"
SRCREV = "${SRCREV_qtwebengine}"
SRCREV_FORMAT = "qtwebengine_chromium"
diff --git a/recipes-qt/qt5/qtwebsockets_git.bb b/recipes-qt/qt5/qtwebsockets_git.bb
index 3e71e542..034ac5ca 100644
--- a/recipes-qt/qt5/qtwebsockets_git.bb
+++ b/recipes-qt/qt5/qtwebsockets_git.bb
@@ -11,4 +11,4 @@ LIC_FILES_CHKSUM = " \
DEPENDS += "qtbase qtdeclarative"
-SRCREV = "e108b1f06d18003d7a758b07bc3bea9922b2e116"
+SRCREV = "87a5151adfc9947f2ab2e560fea7da0088eb59c6"
diff --git a/recipes-qt/qt5/qtx11extras_git.bb b/recipes-qt/qt5/qtx11extras_git.bb
index b8da0d29..32855887 100644
--- a/recipes-qt/qt5/qtx11extras_git.bb
+++ b/recipes-qt/qt5/qtx11extras_git.bb
@@ -12,4 +12,4 @@ LIC_FILES_CHKSUM = " \
DEPENDS += "qtbase"
-SRCREV = "15ffa33a162325d2d16437a057e79cd3b0e3d61c"
+SRCREV = "a0443bd723601205c8cc4666dd89be5a32decf98"
diff --git a/recipes-qt/qt5/qtxmlpatterns_git.bb b/recipes-qt/qt5/qtxmlpatterns_git.bb
index dc8fca6b..80c000fc 100644
--- a/recipes-qt/qt5/qtxmlpatterns_git.bb
+++ b/recipes-qt/qt5/qtxmlpatterns_git.bb
@@ -25,7 +25,7 @@ do_configure_prepend() {
EXTRA_QMAKEVARS_PRE += "${@bb.utils.contains('PACKAGECONFIG', 'qtdeclarative', 'CONFIG+=OE_QTDECLARATIVE_ENABLED', '', d)}"
-SRCREV = "9da08816e1072fc1391377a38d6afd9e73d756e0"
+SRCREV = "85bec28aafc05c9b1fe3428832ee18af82747123"
BBCLASSEXTEND =+ "native nativesdk"