aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorJustin Bronder <jsbronder@cold-front.org>2024-04-11 15:24:51 -0400
committerMartin Jansa <martin.jansa@gmail.com>2024-04-18 10:15:40 +0200
commitaea3fc9b5d5cc4fb2eee427a7722cd891e4f04a7 (patch)
tree44e153726bf41aba4639afdf1b44c9d891249c3b
parentd1d8e0848a3cde1f41e6d645d77ded1a36d07fc9 (diff)
python3-pyqt5: bump 5.15.9 -> 5.15.10
PyQt v5.15.10 has been released. This is a bug-fix release and also adds support for Python v3.12. Signed-off-by: Justin Bronder <jsbronder@cold-front.org> Signed-off-by: Martin Jansa <martin.jansa@gmail.com>
-rw-r--r--recipes-python/pyqt5/python3-pyqt5_5.15.10.bb (renamed from recipes-python/pyqt5/python3-pyqt5_5.15.9.bb)6
1 files changed, 3 insertions, 3 deletions
diff --git a/recipes-python/pyqt5/python3-pyqt5_5.15.9.bb b/recipes-python/pyqt5/python3-pyqt5_5.15.10.bb
index 3361cd50..524acbfa 100644
--- a/recipes-python/pyqt5/python3-pyqt5_5.15.9.bb
+++ b/recipes-python/pyqt5/python3-pyqt5_5.15.10.bb
@@ -6,7 +6,7 @@ LIC_FILES_CHKSUM = "file://LICENSE;md5=d32239bcb673463ab874e80d47fae504"
inherit pypi python3-dir python3native qmake5 qmake5_paths
-SRC_URI[sha256sum] = "dc41e8401a90dc3e2b692b411bd5492ab559ae27a27424eed4bd3915564ec4c0"
+SRC_URI[sha256sum] = "d46b7804b1b10a4ff91753f8113e5b5580d2b4462f3226288e2d84497334898a"
PYPI_PACKAGE = "PyQt5"
S = "${WORKDIR}/PyQt5-${PV}"
@@ -81,9 +81,9 @@ do_install:append() {
}
pyqt_fix_sources() {
- find ${PKGD}/usr/src/debug/${PN} -type f -exec sed -i "s,\(${B}\|${S}\),/usr/src/debug/${PN}/${PV},g" {} \;
+ find ${PKGD}${TARGET_DBGSRC_DIR} -type f -exec sed -i "s,\(${B}\|${S}\),${TARGET_DBGSRC_DIR},g" {} \;
}
-PACKAGESPLITFUNCS += "pyqt_fix_sources"
+PACKAGESPLITFUNCS =+ "pyqt_fix_sources"
FILES:${PN} += "${PYTHON_SITEPACKAGES_DIR} ${OE_QMAKE_PATH_PLUGINS}"
RDEPENDS:${PN} = " \