aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorMartin Jansa <Martin.Jansa@gmail.com>2021-09-21 17:50:13 +0200
committerMartin Jansa <Martin.Jansa@gmail.com>2021-09-21 17:50:14 +0200
commitbf2daefeb57ac4c3e4bc39af3ddbfa6719978931 (patch)
treec16f63b7332ca014a050af9cf9da0c3c89c1b9d2
parentf200be9d671ced4d2f8054c238527a7c6ed5b4b8 (diff)
qtwebengine: inherit pkgconfig
* Newer oe-core doesn't pull many default dependencies anymore: https://lists.openembedded.org/g/openembedded-core/message/156185 add explicit dependency on pkgconfig through pkgconfig.bbclass as we're using it here. * fixes: | sed: can't read /OE/build/luneos-honister/webos-ports/tmp-glibc/work/core2-64-webos-linux/qtwebengine/5.15.4+gitAUTOINC+dd7f7a9166_7aad021f2e-r0/image/usr/lib/pkgconfig/Qt5WebEngineCore.pc: No such file or directory because without pkgconfig detected this file isn't created during the build Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com>
-rw-r--r--recipes-qt/qt5/qtwebengine_git.bb2
1 files changed, 2 insertions, 0 deletions
diff --git a/recipes-qt/qt5/qtwebengine_git.bb b/recipes-qt/qt5/qtwebengine_git.bb
index 7a69159b..58653073 100644
--- a/recipes-qt/qt5/qtwebengine_git.bb
+++ b/recipes-qt/qt5/qtwebengine_git.bb
@@ -34,6 +34,8 @@ DEPENDS += " \
DEPENDS:append:libc-musl = " libexecinfo"
+inherit pkgconfig
+
EXTRA_QMAKEVARS_CONFIGURE += "-feature-webengine-system-ninja -no-feature-webengine-system-gn"
EXTRA_QMAKEVARS_PRE += "CONFIG+=force_debug_info"