aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorMartin Jansa <martin.jansa@gmail.com>2024-04-18 12:40:45 +0200
committerMartin Jansa <martin.jansa@gmail.com>2024-04-18 13:51:25 +0200
commitc0f3c1f99d512e2f95aaaed7022b66d3acff9102 (patch)
tree876d4a9de17aecad972c8d8e8a14bee4f7d291f9
parent02cac01b4f754da3386331be0aae31f1f65fb67d (diff)
qtlocation: backport mapboxgl patch to fix build with gcc-14
Signed-off-by: Martin Jansa <martin.jansa@gmail.com>
-rw-r--r--recipes-qt/qt5/qtlocation/gcc14-const.patch22
-rw-r--r--recipes-qt/qt5/qtlocation_git.bb1
2 files changed, 23 insertions, 0 deletions
diff --git a/recipes-qt/qt5/qtlocation/gcc14-const.patch b/recipes-qt/qt5/qtlocation/gcc14-const.patch
new file mode 100644
index 00000000..2e2e82e5
--- /dev/null
+++ b/recipes-qt/qt5/qtlocation/gcc14-const.patch
@@ -0,0 +1,22 @@
+https://bugs.gentoo.org/914583
+https://github.com/Tencent/rapidjson/commit/3b2441b87f99ab65f37b141a7b548ebadb607b96
+https://github.com/Tencent/rapidjson/issues/718
+
+Upstream-Status: Backport [https://github.com/Tencent/rapidjson/commit/3b2441b87f99ab65f37b141a7b548ebadb607b96]
+
+From 3b2441b87f99ab65f37b141a7b548ebadb607b96 Mon Sep 17 00:00:00 2001
+From: Janusz Chorko <janusz.chorko@apdu.pl>
+Date: Fri, 26 Aug 2016 21:17:38 +0200
+Subject: [PATCH] Removed non-compiling assignment operator. Fixed #718
+
+--- a/include/rapidjson/document.h
++++ b/include/rapidjson/document.h
+@@ -316,8 +316,6 @@ struct GenericStringRef {
+
+ GenericStringRef(const GenericStringRef& rhs) : s(rhs.s), length(rhs.length) {}
+
+- GenericStringRef& operator=(const GenericStringRef& rhs) { s = rhs.s; length = rhs.length; }
+-
+ //! implicit conversion to plain CharType pointer
+ operator const Ch *() const { return s; }
+
diff --git a/recipes-qt/qt5/qtlocation_git.bb b/recipes-qt/qt5/qtlocation_git.bb
index f23b6420..2863e484 100644
--- a/recipes-qt/qt5/qtlocation_git.bb
+++ b/recipes-qt/qt5/qtlocation_git.bb
@@ -34,6 +34,7 @@ QT_MODULE_BRANCH_MAPBOXGL = "upstream/qt-staging"
SRC_URI += " \
${QT_GIT}/qtlocation-mapboxgl.git;name=qtlocation-mapboxgl;branch=${QT_MODULE_BRANCH_MAPBOXGL};protocol=${QT_GIT_PROTOCOL};destsuffix=git/src/3rdparty/mapbox-gl-native \
file://0001-mapbox-gl-explicitly-include-cstdint-header.patch;patchdir=src/3rdparty/mapbox-gl-native \
+ file://gcc14-const.patch;patchdir=src/3rdparty/mapbox-gl-native/deps/rapidjson/1.1.0 \
"
SRCREV_qtlocation = "f6953a8d604b906b170fb4610e124e7c31260a18"