aboutsummaryrefslogtreecommitdiffstats
path: root/recipes-python/pyqtchart/python-pyqtchart.inc
diff options
context:
space:
mode:
authorMikko Gronoff <mikko.gronoff@qt.io>2020-03-06 12:32:13 +0200
committerMikko Gronoff <mikko.gronoff@qt.io>2020-03-10 09:03:25 +0200
commit5114e3057ceb4afc7f2ae9f71bb351f9e5c7f553 (patch)
tree970f133c757794bcdc024acff5e053ca621ad47d /recipes-python/pyqtchart/python-pyqtchart.inc
parentc29bdf41c4494e278a17a233048205bf212e040f (diff)
parentde2ecaa13fde8f30b1a6558bbbbdfecfd3cd4bd8 (diff)
Merge remote-tracking branch 'qt/5.14' into 5.15
* qt/5.14: de2ecaa1 coin: update module_config.yaml with meta-python2 support f9a58d62 Merge remote-tracking branch 'qt/upstream/master' into 5.14 2da972e5 qt5: update submodules 9be6548e qt5: update submodules b5e4f925 qtquicktimeline: add recipe abb42351 (qt/upstream/master) qtwebview: Skip if meta-python is not present caf09cd5 Add PyQtChart. f18d5948 qtbase: fix build with platform where FE macro are not defined c8cd55b0 qtwebkit: build with python3 0bbd0ebe qtwebengine: Link libatomic on x86/32bit 23914740 Revert "qtwebkit: remove" 8cadcbcb qt5: upgrade to 5.14.1 f13a3cec packagegroup-qt5-toolchain-target: Use TUNE_PKGARCH instead of MACHINE_ARCH a35403dc qtwebkit: remove a797f85c python-pyqt5, qtwebengine, qtwebkit, qt-kiosk-browser: skip without meta-python2 b1f4f1fd Revert "recipes: Use python3 during build" 47fb26de recipes: Use python3 during build 4060f68d qt-kiosk-browser: Only support arm/x86 fd376e15 qtwebengine: Fix missing headers found in build with clang 7f324f11 gstreamer1.0-plugins-good: Adjust bbappend for meson migration in core 1365691f qttools: remove ptest installation 254576f9 qt-kiosk-browser: Add recipe 47399df9 nativesdk-packagegroup: fix cmake builds using sdk Conflicts: recipes-qt/packagegroups/packagegroup-qt5-toolchain-target.bb recipes-qt/qt5/nativesdk-qtbase_git.bb recipes-qt/qt5/qt3d/0001-Allow-a-tools-only-build.patch recipes-qt/qt5/qt3d_git.bb recipes-qt/qt5/qtbase-native_git.bb recipes-qt/qt5/qtbase_git.bb recipes-qt/qt5/qtcharts_git.bb recipes-qt/qt5/qtcoap_git.bb recipes-qt/qt5/qtconnectivity_git.bb recipes-qt/qt5/qtdeclarative_git.bb recipes-qt/qt5/qtimageformats_git.bb recipes-qt/qt5/qtknx_git.bb recipes-qt/qt5/qtlocation_git.bb recipes-qt/qt5/qtmultimedia_git.bb recipes-qt/qt5/qtquick3d_git.bb recipes-qt/qt5/qtquickcontrols2_git.bb recipes-qt/qt5/qtremoteobjects_git.bb recipes-qt/qt5/qtscript_git.bb recipes-qt/qt5/qtserialbus_git.bb recipes-qt/qt5/qtsvg_git.bb recipes-qt/qt5/qttools_git.bb recipes-qt/qt5/qtwebengine_git.bb recipes-qt/qt5/qtwebsockets_git.bb recipes-qt/qt5/qtwebview_git.bb Change-Id: I41b3b999dc1278342e33dda3b66af1990e8da090
Diffstat (limited to 'recipes-python/pyqtchart/python-pyqtchart.inc')
-rw-r--r--recipes-python/pyqtchart/python-pyqtchart.inc66
1 files changed, 66 insertions, 0 deletions
diff --git a/recipes-python/pyqtchart/python-pyqtchart.inc b/recipes-python/pyqtchart/python-pyqtchart.inc
new file mode 100644
index 00000000..e8dba18a
--- /dev/null
+++ b/recipes-python/pyqtchart/python-pyqtchart.inc
@@ -0,0 +1,66 @@
+SUMMARY = "Python Qt Chart Bindings"
+AUTHOR = "Adrian.Fiergolski@fastree3d.com"
+SECTION = "devel/python"
+LICENSE = "GPLv3"
+LIC_FILES_CHKSUM = "\
+ file://LICENSE;md5=d32239bcb673463ab874e80d47fae504 \
+"
+SRC_URI = "\
+ https://www.riverbankcomputing.com/static/Downloads/PyQtChart/${PV}/PyQtChart-${PV}.tar.gz \
+"
+SRC_URI[md5sum] = "d5d37bff46b690d6318e5e5f25dd5213"
+SRC_URI[sha256sum] = "49960a1483527857b38c1527f9b6328d30bdcc84521f579c0a561a892f54130e"
+
+S = "${WORKDIR}/PyQtChart-${PV}"
+
+inherit qmake5
+DEPENDS = "qtbase qtdeclarative qtquickcontrols2"
+
+export BUILD_SYS
+export HOST_SYS
+export STAGING_INCDIR
+export STAGING_LIBDIR
+
+PARALLEL_MAKEINST = ""
+
+DISABLED_FEATURES = "PyQt_Desktop_OpenGL PyQt_Accessibility PyQt_SessionManager"
+
+DISABLED_FEATURES_append_arm = " PyQt_qreal_double"
+
+do_configure_prepend() {
+ cd ${S}
+ echo "[PyQt 5]" > pyqt.cfg
+ echo "py_platform = linux" >> pyqt.cfg
+ echo "py_inc_dir = %(sysroot)/$includedir/python%(py_major).%(py_minor)${PYTHON_ABI}" >> pyqt.cfg
+ echo "py_pylib_dir = %(sysroot)/${libdir}/python%(py_major).%(py_minor)" >> pyqt.cfg
+ echo "pyqt_module_dir = ${D}/${libdir}/python%(py_major).%(py_minor)/site-packages" >> pyqt.cfg
+ echo "py_sip_dir = ${STAGING_EXECPREFIXDIR}/share/sip" >> pyqt.cfg
+ echo "sip_module = PyQt5.sip" >> pyqt.cfg
+ echo "pyqt_disabled_features = ${DISABLED_FEATURES}" >> pyqt.cfg
+ echo yes | ${PYTHON} configure.py --verbose --qmake ${STAGING_BINDIR_NATIVE}/${QT_DIR_NAME}/qmake --configuration pyqt.cfg --sysroot ${STAGING_DIR_HOST}
+}
+
+do_configure_append() {
+ #Fix installation paths
+ sed -i -e s:'$(INSTALL_ROOT)'${STAGING_EXECPREFIXDIR}:'$(INSTALL_ROOT)'${D}${exec_prefix}:g ${S}/Makefile
+ sed -i -e s:'$(INSTALL_ROOT)'${STAGING_EXECPREFIXDIR}:'$(INSTALL_ROOT)'${D}${exec_prefix}:g ${S}/QtChart/Makefile
+ #Skip installed.txt creation
+ sed -i -e s:" install_distinfo ":" ": ${S}/Makefile
+}
+
+do_compile() {
+ cd ${S}
+ oe_runmake
+}
+
+do_install() {
+ cd ${S}
+ oe_runmake MAKEFLAGS='-j 1' install
+}
+
+
+FILES_${PN} += "${libdir}/${PYTHON_DIR}/site-packages ${datadir}/"
+
+DEPENDS = "qtcharts"
+
+RDEPENDS_${PN} = "qtbase qtdeclarative qtquickcontrols2 qtquickcontrols2-mkspecs qtcharts"