aboutsummaryrefslogtreecommitdiffstats
path: root/recipes-qt/maliit
diff options
context:
space:
mode:
authorMartin Jansa <Martin.Jansa@gmail.com>2021-07-29 17:05:32 +0200
committerMartin Jansa <Martin.Jansa@gmail.com>2021-08-03 13:38:16 +0200
commita6bee8ea4cb91d0e07d8be272ddc0e56c86e4acf (patch)
tree127f88ca5f4c1f1a0fb80dca719ef817b700ed5b /recipes-qt/maliit
parent10f3673fd4b6c6e1e61c23478802f83652475a5f (diff)
Convert to new override syntax
This is the result of automated script (0.9.0) conversion: oe-core/scripts/contrib/convert-overrides.py . converting the metadata to use ":" as the override character instead of "_". Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com>
Diffstat (limited to 'recipes-qt/maliit')
-rw-r--r--recipes-qt/maliit/maliit-framework-qt5_git.bb16
-rw-r--r--recipes-qt/maliit/maliit-plugins-qt5_git.bb6
2 files changed, 11 insertions, 11 deletions
diff --git a/recipes-qt/maliit/maliit-framework-qt5_git.bb b/recipes-qt/maliit/maliit-framework-qt5_git.bb
index 72e6be5f..67fd1295 100644
--- a/recipes-qt/maliit/maliit-framework-qt5_git.bb
+++ b/recipes-qt/maliit/maliit-framework-qt5_git.bb
@@ -24,9 +24,9 @@ GTKIMMODULES_PACKAGES = "${PN}-gtk"
DEPENDS = "qtdeclarative"
-RRECOMMENDS_${PN} = "maliit-plugins-qt5"
+RRECOMMENDS:${PN} = "maliit-plugins-qt5"
-FILES_${PN} += "\
+FILES:${PN} += "\
${libdir}/*.so* \
${bindir} \
${datadir}/applications/maliit-server.desktop \
@@ -34,11 +34,11 @@ FILES_${PN} += "\
${OE_QMAKE_PATH_PLUGINS}/platforminputcontexts \
"
-FILES_${PN}-dbg += "\
+FILES:${PN}-dbg += "\
${libdir}/maliit-framework-tests \
"
-FILES_${PN}-dev += "\
+FILES:${PN}-dev += "\
${includedir}/maliit \
${libdir}/pkgconfig \
${OE_QMAKE_PATH_QT_ARCHDATA}/mkspecs \
@@ -62,11 +62,11 @@ EXTRA_QMAKEVARS_PRE = "\
"
# tests fail to build with clang
-EXTRA_QMAKEVARS_PRE_append_toolchain-clang = " CONFIG+=notests"
+EXTRA_QMAKEVARS_PRE:append:toolchain-clang = " CONFIG+=notests"
EXTRA_OEMAKE += "INSTALL_ROOT=${D}"
-do_install_append() {
+do_install:append() {
#Fix absolute paths
sed -i -e "s|/usr|${STAGING_DIR_TARGET}${prefix}|" ${D}/${OE_QMAKE_PATH_QT_ARCHDATA}/mkspecs/features/maliit-framework.prf
sed -i -e "s|/usr|${STAGING_DIR_TARGET}${prefix}|" ${D}/${OE_QMAKE_PATH_QT_ARCHDATA}/mkspecs/features/maliit-plugins.prf
@@ -75,14 +75,14 @@ do_install_append() {
install -m 644 ${WORKDIR}/maliit-server.desktop ${D}${datadir}/applications
}
-pkg_postinst_ontarget_${PN} () {
+pkg_postinst_ontarget:${PN} () {
#!/bin/sh
# should run online
echo "export QT_IM_MODULE=Maliit" >> /etc/xprofile
ln -s /usr/share/applications/maliit-server.desktop /etc/xdg/autostart/maliit-server.desktop
}
-pkg_postrm_${PN} () {
+pkg_postrm:${PN} () {
#!/bin/sh
# should run online
if [ "x$D" = "x" ]; then
diff --git a/recipes-qt/maliit/maliit-plugins-qt5_git.bb b/recipes-qt/maliit/maliit-plugins-qt5_git.bb
index 8464e1f0..d60d4fd7 100644
--- a/recipes-qt/maliit/maliit-plugins-qt5_git.bb
+++ b/recipes-qt/maliit/maliit-plugins-qt5_git.bb
@@ -8,7 +8,7 @@ inherit qmake5
DEPENDS = "maliit-framework-qt5"
-RDEPENDS_${PN} += "qtsvg-plugins"
+RDEPENDS:${PN} += "qtsvg-plugins"
SRC_URI = "git://github.com/maliit/plugins.git;branch=master \
file://0001-Do-not-use-tr1-namespace.patch \
@@ -26,9 +26,9 @@ EXTRA_QMAKEVARS_PRE = "\
"
# tests fail to build with clang
-EXTRA_QMAKEVARS_PRE_append_toolchain-clang = " CONFIG+=notests"
+EXTRA_QMAKEVARS_PRE:append:toolchain-clang = " CONFIG+=notests"
-FILES_${PN} += "\
+FILES:${PN} += "\
${libdir}/maliit \
${datadir} \
"