aboutsummaryrefslogtreecommitdiffstats
path: root/recipes-qt/packagegroups/nativesdk-packagegroup-qt5-toolchain-host.bb
diff options
context:
space:
mode:
authorOtavio Salvador <otavio@ossystems.com.br>2014-02-05 23:05:21 -0200
committerOtavio Salvador <otavio@ossystems.com.br>2014-02-07 11:39:50 -0200
commitd768d975282b8a230314880ab6acd334440a6214 (patch)
treec3aabcf75a58b6c4eeb68cecccab8366510372ed /recipes-qt/packagegroups/nativesdk-packagegroup-qt5-toolchain-host.bb
parent91ac66d5e4867d7e400bbffe5b31caa8ed660fbb (diff)
nativesdk-packagegroup-qt5-toolchain-host: Add packagegroup
Allow easy inclusion of host packages for the Qt5 standalone SDK or external toolchain. Signed-off-by: Otavio Salvador <otavio@ossystems.com.br>
Diffstat (limited to 'recipes-qt/packagegroups/nativesdk-packagegroup-qt5-toolchain-host.bb')
-rw-r--r--recipes-qt/packagegroups/nativesdk-packagegroup-qt5-toolchain-host.bb14
1 files changed, 14 insertions, 0 deletions
diff --git a/recipes-qt/packagegroups/nativesdk-packagegroup-qt5-toolchain-host.bb b/recipes-qt/packagegroups/nativesdk-packagegroup-qt5-toolchain-host.bb
new file mode 100644
index 00000000..4cc0b930
--- /dev/null
+++ b/recipes-qt/packagegroups/nativesdk-packagegroup-qt5-toolchain-host.bb
@@ -0,0 +1,14 @@
+# Copyright (C) 2014 O.S. Systems Software LTDA.
+
+SUMMARY = "Host packages for the Qt5 standalone SDK or external toolchain"
+LICENSE = "MIT"
+
+inherit nativesdk packagegroup
+
+PACKAGEGROUP_DISABLE_COMPLEMENTARY = "1"
+
+RDEPENDS_${PN} += " \
+ nativesdk-packagegroup-sdk-host \
+ nativesdk-qttools \
+ nativesdk-qtbase-tools \
+"