aboutsummaryrefslogtreecommitdiffstats
path: root/recipes-qt/qt5
diff options
context:
space:
mode:
authorMikko Gronoff <mikko.gronoff@qt.io>2024-05-06 10:49:45 +0300
committerMikko Gronoff <mikko.gronoff@qt.io>2024-05-08 13:21:13 +0300
commit8c501b4d098fcb1912b20ffe656d8b38da00d551 (patch)
tree9a0e7a7f9e0c58dc4e38adbbf7f2f012fae31295 /recipes-qt/qt5
parent00e719c75dde4020ca0870f53e543610e4313c71 (diff)
qt5: update submodulesHEADlts-5.15
Update to latest content in lts-5.15.17 branch. Webengine dependency patch added to fix build with ninja 12. Task-number: QTBUG-119819 Change-Id: I68c31a1a855b107a8a24a2be73549faa89cbff94 Reviewed-by: Samuli Piippo <samuli.piippo@qt.io>
Diffstat (limited to 'recipes-qt/qt5')
-rw-r--r--recipes-qt/qt5/nativesdk-qtbase_git.bb2
-rw-r--r--recipes-qt/qt5/qtbase-native_git.bb2
-rw-r--r--recipes-qt/qt5/qtbase_git.bb2
-rw-r--r--recipes-qt/qt5/qtimageformats_git.bb2
-rw-r--r--recipes-qt/qt5/qtpdf/0001-configure.json-remove-python2-dependency.patch8
-rw-r--r--recipes-qt/qt5/qtpdf_git.bb7
-rw-r--r--recipes-qt/qt5/qtwebengine/chromium/0024-Fix-dependecy-when-compiling-content-browser.patch28
-rw-r--r--recipes-qt/qt5/qtwebengine_git.bb1
8 files changed, 41 insertions, 11 deletions
diff --git a/recipes-qt/qt5/nativesdk-qtbase_git.bb b/recipes-qt/qt5/nativesdk-qtbase_git.bb
index 71833770..56e0a0a8 100644
--- a/recipes-qt/qt5/nativesdk-qtbase_git.bb
+++ b/recipes-qt/qt5/nativesdk-qtbase_git.bb
@@ -202,4 +202,4 @@ fakeroot do_generate_qt_environment_file() {
do_generate_qt_environment_file[umask] = "022"
addtask generate_qt_environment_file after do_install before do_package
-SRCREV = "abc097a32e13fe8b0a5b2f08430cc580a24f3b06"
+SRCREV = "8a25db3204f39a228d14148d9cdf414393d239a5"
diff --git a/recipes-qt/qt5/qtbase-native_git.bb b/recipes-qt/qt5/qtbase-native_git.bb
index 3b02d2a1..2ed8aa50 100644
--- a/recipes-qt/qt5/qtbase-native_git.bb
+++ b/recipes-qt/qt5/qtbase-native_git.bb
@@ -145,4 +145,4 @@ do_install() {
echo 'set(_qt5_corelib_extra_includes "${_qt5Core_install_prefix}/lib${QT_DIR_NAME}/mkspecs/linux-oe-g++")' > ${D}${libdir}/cmake/Qt5Core/Qt5CoreConfigExtrasMkspecDir.cmake
}
-SRCREV = "abc097a32e13fe8b0a5b2f08430cc580a24f3b06"
+SRCREV = "8a25db3204f39a228d14148d9cdf414393d239a5"
diff --git a/recipes-qt/qt5/qtbase_git.bb b/recipes-qt/qt5/qtbase_git.bb
index 5450ce44..4009afc5 100644
--- a/recipes-qt/qt5/qtbase_git.bb
+++ b/recipes-qt/qt5/qtbase_git.bb
@@ -308,4 +308,4 @@ sed -i \
$D${OE_QMAKE_PATH_ARCHDATA}/mkspecs/qmodule.pri
}
-SRCREV = "abc097a32e13fe8b0a5b2f08430cc580a24f3b06"
+SRCREV = "8a25db3204f39a228d14148d9cdf414393d239a5"
diff --git a/recipes-qt/qt5/qtimageformats_git.bb b/recipes-qt/qt5/qtimageformats_git.bb
index dbee6c06..4986276c 100644
--- a/recipes-qt/qt5/qtimageformats_git.bb
+++ b/recipes-qt/qt5/qtimageformats_git.bb
@@ -25,4 +25,4 @@ PACKAGECONFIG[libwebp] = ",CONFIG+=done_config_libwebp,libwebp"
EXTRA_QMAKEVARS_PRE += "${PACKAGECONFIG_CONFARGS}"
-SRCREV = "5374766d3520fdebe3c9b10ba6cc4de58fc3dacf"
+SRCREV = "348a2b3860519a00f8b8f4cb690497b3f2ac5e7b"
diff --git a/recipes-qt/qt5/qtpdf/0001-configure.json-remove-python2-dependency.patch b/recipes-qt/qt5/qtpdf/0001-configure.json-remove-python2-dependency.patch
index e12d8fc1..013832e5 100644
--- a/recipes-qt/qt5/qtpdf/0001-configure.json-remove-python2-dependency.patch
+++ b/recipes-qt/qt5/qtpdf/0001-configure.json-remove-python2-dependency.patch
@@ -1,4 +1,4 @@
-From b87860c14637458c5a7f5c1ca6f66f21bb87652e Mon Sep 17 00:00:00 2001
+From be54e6e336001ed3ed342f65f379c2e355d847f0 Mon Sep 17 00:00:00 2001
From: Leif Middelschulte <Leif.Middelschulte@klsmartin.com>
Date: Tue, 8 Feb 2022 14:14:02 +0100
Subject: [PATCH] configure.json: remove python2 dependency
@@ -10,14 +10,14 @@ Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com>
1 file changed, 1 deletion(-)
diff --git a/src/buildtools/configure.json b/src/buildtools/configure.json
-index 9eb5e8e33..ebe31c216 100644
+index 5e5d9d725..541b7b740 100644
--- a/src/buildtools/configure.json
+++ b/src/buildtools/configure.json
-@@ -399,7 +399,6 @@
+@@ -422,7 +422,6 @@
&& features.webengine-gperf
&& features.webengine-bison
&& features.webengine-flex
-- && features.webengine-python2
+- && features.webengine-python
&& (!config.sanitizer || features.webengine-sanitizer)
&& (!config.linux || features.pkg-config)
&& (!config.linux || features.webengine-host-pkg-config)
diff --git a/recipes-qt/qt5/qtpdf_git.bb b/recipes-qt/qt5/qtpdf_git.bb
index fc232b98..ad17f36e 100644
--- a/recipes-qt/qt5/qtpdf_git.bb
+++ b/recipes-qt/qt5/qtpdf_git.bb
@@ -164,6 +164,7 @@ SRC_URI += " \
file://chromium/0010-chromium-icu-use-system-library-only-targets.patch;patchdir=src/3rdparty \
file://chromium/0011-chromium-skia-Fix-build-with-gcc-12.patch;patchdir=src/3rdparty \
file://chromium/0012-Remove-unsetting-_FILE_OFFSET_BITS.patch;patchdir=src/3rdparty \
+ file://chromium/0024-Fix-dependecy-when-compiling-content-browser.patch;patchdir=src/3rdparty \
"
# Patches from https://github.com/meta-qt5/qtwebengine-chromium/commits/87-based
@@ -182,8 +183,8 @@ SRC_URI:append:libc-musl = "\
file://chromium/0023-chromium-musl-initialize-msghdr-in-a-compatible-mann.patch;patchdir=src/3rdparty \
"
-SRCREV_qtwebengine = "3a11b38575e6aa929d1e7d5d11d0acf61eae6420"
-SRCREV_chromium = "ce00f9b5aa761866b24d6460e10aacb671c92cf0"
+SRCREV_qtwebengine = "17fd3176988586168bee8654008a097a5f23ec1d"
+SRCREV_chromium = "fdfef5b37af3bed8402d7c7e20a5487f2602b0a6"
SRCREV = "${SRCREV_qtwebengine}"
SRCREV_FORMAT = "qtwebengine_chromium"
@@ -210,7 +211,7 @@ SRC_URI:append:toolchain-clang:runtime-llvm = " file://0003-Fix-build-with-clang
# These flags below go more into detail than qtwebengine's documentation
PACKAGECONFIG[no-core] = "-no-build-qtwebengine-core,,"
PACKAGECONFIG[qtpdf] = "-feature-build-qtpdf,-no-feature-build-qtpdf,python3-native"
-PACKAGECONFIG[webengine-pdf] = "-feature-webengine-python2,-no-feature-webengine-python2,python3-native"
+PACKAGECONFIG[webengine-pdf] = "-feature-webengine-python,-no-feature-webengine-python,python3-native"
# The flags below enable just the PDF widget
PACKAGECONFIG = "no-core qtpdf"
diff --git a/recipes-qt/qt5/qtwebengine/chromium/0024-Fix-dependecy-when-compiling-content-browser.patch b/recipes-qt/qt5/qtwebengine/chromium/0024-Fix-dependecy-when-compiling-content-browser.patch
new file mode 100644
index 00000000..2ca2e313
--- /dev/null
+++ b/recipes-qt/qt5/qtwebengine/chromium/0024-Fix-dependecy-when-compiling-content-browser.patch
@@ -0,0 +1,28 @@
+From a4783ee130e638f51438340b9f8f4de415f9ad76 Mon Sep 17 00:00:00 2001
+From: Michal Klocek <michal.klocek@qt.io>
+Date: Wed, 8 May 2024 09:07:49 +0200
+Subject: [PATCH] Fix dependecy when compiling content/browser
+
+Deals with:
+
+"fatal error: components/spellcheck/spellcheck_buildflags.h:
+No such file or directory"
+
+Change-Id: If633fdf9d3d793158ab0dd994c011c17e66c13b5
+Upstream-Status: Pending
+---
+ chromium/content/browser/BUILD.gn | 1 +
+ 1 file changed, 1 insertion(+)
+
+diff --git a/chromium/content/browser/BUILD.gn b/chromium/content/browser/BUILD.gn
+index 1466f33d462..ae459c24d4f 100644
+--- a/chromium/content/browser/BUILD.gn
++++ b/chromium/content/browser/BUILD.gn
+@@ -334,6 +334,7 @@ jumbo_static_library("browser") {
+
+ public_deps = [
+ ":accessibility_buildflags",
++ "//components/spellcheck:buildflags",
+ "//base/util/memory_pressure",
+ "//base/util/type_safety",
+ "//ipc",
diff --git a/recipes-qt/qt5/qtwebengine_git.bb b/recipes-qt/qt5/qtwebengine_git.bb
index acccc998..efdd57b9 100644
--- a/recipes-qt/qt5/qtwebengine_git.bb
+++ b/recipes-qt/qt5/qtwebengine_git.bb
@@ -180,6 +180,7 @@ SRC_URI += " \
file://chromium/0011-chromium-Add-missing-include-for-C-strncpy.patch;patchdir=src/3rdparty \
file://chromium/0011-chromium-skia-Fix-build-with-gcc-12.patch;patchdir=src/3rdparty \
file://chromium/0012-Remove-unsetting-_FILE_OFFSET_BITS.patch;patchdir=src/3rdparty \
+ file://chromium/0024-Fix-dependecy-when-compiling-content-browser.patch;patchdir=src/3rdparty \
"
# Patches from https://github.com/meta-qt5/qtwebengine-chromium/commits/87-based