aboutsummaryrefslogtreecommitdiffstats
path: root/recipes-qt/qt5/qtbase/0008-Replace-pthread_yield-with-sched_yield.patch
diff options
context:
space:
mode:
authorMikko Gronoff <mikko.gronoff@qt.io>2019-11-18 15:44:26 +0200
committerMikko Gronoff <mikko.gronoff@qt.io>2019-11-18 15:45:10 +0200
commit12cc756c7948a90367473f0a52dd2fe2b519dd24 (patch)
tree5db143dfa7dbee5459cf4079d2e72cdf50c68d79 /recipes-qt/qt5/qtbase/0008-Replace-pthread_yield-with-sched_yield.patch
parent3e502778ee161bef4177e7e7f45c0c9b78d047da (diff)
parent432ad2aa6c3a13253fefc909faba368851d21fb1 (diff)
Merge remote-tracking branch 'qtyocto/upstream/zeus' into 5.135.13
* qtyocto/upstream/zeus: 432ad2a qttools: don't install tst_qtattributionsscanner 8115617 qt5: Upgrade to Qt 5.13.2 267e646 python(3)-pyqt5: add qml support 653e12f libqofono: bump SRCREV and add a fix for voicecall cefb48e qtbase: Add PACKAGECONFIG for lttng 911b346 layer: Mark zeus as compatible release c373272 ogl-runtime: Fix build on x86_64 9172ba1 README.md: Document need for 32bit host compiler db2fd6c qtwayland: Fix build with clang/libc++ 6b5122e qtbase: Fix build when fp16 is used Conflicts: recipes-qt/qt5/ogl-runtime_git.bb recipes-qt/qt5/qtbase/0004-configure-bump-path-length-from-256-to-512-character.patch recipes-qt/qt5/qtbase/0013-Disable-ltcg-for-host_build.patch recipes-qt/qt5/qtbase_git.bb recipes-qt/qt5/qtwayland_git.bb Change-Id: I6f325e5d4fc0f2e774962f1b5fd54e5e0e9c96d7
Diffstat (limited to 'recipes-qt/qt5/qtbase/0008-Replace-pthread_yield-with-sched_yield.patch')
-rw-r--r--recipes-qt/qt5/qtbase/0008-Replace-pthread_yield-with-sched_yield.patch10
1 files changed, 5 insertions, 5 deletions
diff --git a/recipes-qt/qt5/qtbase/0008-Replace-pthread_yield-with-sched_yield.patch b/recipes-qt/qt5/qtbase/0008-Replace-pthread_yield-with-sched_yield.patch
index 84e59e7c..1c33a51f 100644
--- a/recipes-qt/qt5/qtbase/0008-Replace-pthread_yield-with-sched_yield.patch
+++ b/recipes-qt/qt5/qtbase/0008-Replace-pthread_yield-with-sched_yield.patch
@@ -1,4 +1,4 @@
-From aebff1455c764e9ecc73e6b52a4bac8233c93966 Mon Sep 17 00:00:00 2001
+From a12d09f70178952f5be68110714386a0be00b017 Mon Sep 17 00:00:00 2001
From: Khem Raj <raj.khem@gmail.com>
Date: Thu, 27 Jul 2017 08:02:51 -0700
Subject: [PATCH] Replace pthread_yield with sched_yield
@@ -14,7 +14,7 @@ Signed-off-by: Khem Raj <raj.khem@gmail.com>
2 files changed, 5 insertions(+), 4 deletions(-)
diff --git a/tests/auto/corelib/kernel/qmetatype/tst_qmetatype.cpp b/tests/auto/corelib/kernel/qmetatype/tst_qmetatype.cpp
-index e6fac74ccc..28c7e9cfb3 100644
+index e2bb7dab2a..683c7bafcd 100644
--- a/tests/auto/corelib/kernel/qmetatype/tst_qmetatype.cpp
+++ b/tests/auto/corelib/kernel/qmetatype/tst_qmetatype.cpp
@@ -35,7 +35,7 @@
@@ -26,7 +26,7 @@ index e6fac74ccc..28c7e9cfb3 100644
#endif
#include <algorithm>
-@@ -366,7 +366,7 @@ protected:
+@@ -368,7 +368,7 @@ protected:
const char *nm = name.constData();
int tp = qRegisterMetaType<Bar>(nm);
#if defined(Q_OS_LINUX) && !defined(Q_OS_ANDROID)
@@ -36,7 +36,7 @@ index e6fac74ccc..28c7e9cfb3 100644
QMetaType info(tp);
if (!info.isValid()) {
diff --git a/tests/auto/network/socket/qtcpsocket/tst_qtcpsocket.cpp b/tests/auto/network/socket/qtcpsocket/tst_qtcpsocket.cpp
-index c473230246..1db8d6f225 100644
+index 10b09629bc..858fc5fc99 100644
--- a/tests/auto/network/socket/qtcpsocket/tst_qtcpsocket.cpp
+++ b/tests/auto/network/socket/qtcpsocket/tst_qtcpsocket.cpp
@@ -78,6 +78,7 @@
@@ -47,7 +47,7 @@ index c473230246..1db8d6f225 100644
#endif
#include "private/qhostinfo_p.h"
-@@ -2132,8 +2133,8 @@ public slots:
+@@ -2151,8 +2152,8 @@ public slots:
#if defined(Q_OS_MAC)
pthread_yield_np();