aboutsummaryrefslogtreecommitdiffstats
path: root/recipes-qt/qt5/qtwayland_git.bb
diff options
context:
space:
mode:
authorMikko Gronoff <mikko.gronoff@qt.io>2019-10-10 09:53:46 +0300
committerMikko Gronoff <mikko.gronoff@qt.io>2019-10-11 10:48:26 +0300
commitbf923061ee01f9fd93bed5550861d4f2ca8b06f1 (patch)
tree47e31095a6ebc4e834c3858e097048f88c8d985d /recipes-qt/qt5/qtwayland_git.bb
parent79a0e938922f85638b578a9ae0f21c8856176e68 (diff)
parent6442c54d10750016083b06a8bc22b9bffc5e26a2 (diff)
Merge remote-tracking branch 'qtyocto/upstream/master' into 5.13
* upstream/master: 6442c54 qt3d-runtime: update to ogl-runtime v2.4 7bb213b qtvirtualkeyboard: update supported layouts eb63611 qt5-creator: Fix clangformat with clang 9.x 12ea469 qttools: Add CONFIG+=config_clang_done when not building with clang dc502d5 qtwebengine: Fix compile failure with 5.2+ kernel headers 8799d3b qtserialbus: Fix build with 5.2+ kernel headers e8aa2dd qtwebengine: Add pulseaudio support 4d8f350 qtwebengine: Rename jasoncpp to jsoncpp 725c87d qtwayland: do not reference private modules in cmake Qt5WaylandClient a41cd9e qtwayland: remove workaround for missing private headers (QTBUG-71340) Conflicts: recipes-qt/qt5/qtserialbus_git.bb Change-Id: I8f5248fb6f320555a231f59cddeb4c18ff810259
Diffstat (limited to 'recipes-qt/qt5/qtwayland_git.bb')
-rw-r--r--recipes-qt/qt5/qtwayland_git.bb29
1 files changed, 0 insertions, 29 deletions
diff --git a/recipes-qt/qt5/qtwayland_git.bb b/recipes-qt/qt5/qtwayland_git.bb
index 835d5929..949a28a6 100644
--- a/recipes-qt/qt5/qtwayland_git.bb
+++ b/recipes-qt/qt5/qtwayland_git.bb
@@ -44,32 +44,3 @@ BBCLASSEXTEND =+ "native nativesdk"
# The same issue as in qtbase:
# http://errors.yoctoproject.org/Errors/Details/152641/
LDFLAGS_append = "${@bb.utils.contains('DISTRO_FEATURES', 'ld-is-gold', ' -fuse-ld=bfd ', '', d)}"
-
-# Since version 5.11.2 some private headers are not installed. Work around
-# until fixed upstream. See https://bugreports.qt.io/browse/QTBUG-71340 for
-# further details
-QTWAYLAND_INSTALL_PRIVATE_HEADERS_MANUALLY ?= "1"
-# First 6 characters before first + (e.g. 5.11.3-+git) or - (e.g. 5.11.3-2)
-SHRT_VER ?= "${@d.getVar('PV').split('+')[0].split('-')[0]}"
-do_install_append() {
- if [ -d "${B}/src/client" -a "${QTWAYLAND_INSTALL_PRIVATE_HEADERS_MANUALLY}" = "1" -a -d "${D}${includedir}/QtWaylandClient/${SHRT_VER}/QtWaylandClient/private/" ]; then
- for header in `find ${B}/src/client -name '*wayland-*.h'`; do
- header_base=`basename $header`
- dest="${D}${includedir}/QtWaylandClient/${SHRT_VER}/QtWaylandClient/private/$header_base"
- if [ ! -e "$dest" ]; then
- echo "Manual install: $header_base to $dest"
- install -m 644 "$header" "$dest"
- fi
- done
- fi
- if [ -d "${B}/src/compositor" -a "${QTWAYLAND_INSTALL_PRIVATE_HEADERS_MANUALLY}" = "1" -a -d "${D}${includedir}/QtCompositor/${SHRT_VER}/QtCompositor/private/" ]; then
- for header in `find ${B}/src/compositor -name '*wayland-*.h'`; do
- header_base=`basename $header`
- dest="${D}${includedir}/QtCompositor/${SHRT_VER}/QtCompositor/private/$header_base"
- if [ ! -e "$dest" ]; then
- echo "Manual install: $header_base to $dest"
- install -m 644 "$header" "$dest"
- fi
- done
- fi
-}