aboutsummaryrefslogtreecommitdiffstats
path: root/recipes-qt/qt5/qtwayland_git.bb
diff options
context:
space:
mode:
authorMikko Gronoff <mikko.gronoff@qt.io>2019-10-28 11:58:10 +0200
committerMikko Gronoff <mikko.gronoff@qt.io>2019-10-28 12:18:28 +0200
commitec860bdcdb8c4b64f9b4d73b0e1723bd18bd1112 (patch)
tree5eba8a83dc76c6011e0b956e989d01fc45a522ae /recipes-qt/qt5/qtwayland_git.bb
parentb16599a516e0f5e73673ba101ae0a852d8a14cf0 (diff)
parent0be6a24a4623f52b8b92fa77f0f1c3faf4169d27 (diff)
Merge remote-tracking branch 'qtyocto/5.13' into 5.14
* qtyocto/5.13: 0be6a24 qt5: update submodules bf92306 Merge remote-tracking branch 'qtyocto/upstream/master' into 5.13 6442c54 qt3d-runtime: update to ogl-runtime v2.4 7bb213b qtvirtualkeyboard: update supported layouts eb63611 qt5-creator: Fix clangformat with clang 9.x 12ea469 qttools: Add CONFIG+=config_clang_done when not building with clang dc502d5 qtwebengine: Fix compile failure with 5.2+ kernel headers 8799d3b qtserialbus: Fix build with 5.2+ kernel headers e8aa2dd qtwebengine: Add pulseaudio support 4d8f350 qtwebengine: Rename jasoncpp to jsoncpp 725c87d qtwayland: do not reference private modules in cmake Qt5WaylandClient a41cd9e qtwayland: remove workaround for missing private headers (QTBUG-71340) Change-Id: Iac0ec8c35f65aa27a1bf0c6b5928d26f13bc0733
Diffstat (limited to 'recipes-qt/qt5/qtwayland_git.bb')
-rw-r--r--recipes-qt/qt5/qtwayland_git.bb29
1 files changed, 0 insertions, 29 deletions
diff --git a/recipes-qt/qt5/qtwayland_git.bb b/recipes-qt/qt5/qtwayland_git.bb
index 7f033d3b..b4d8e119 100644
--- a/recipes-qt/qt5/qtwayland_git.bb
+++ b/recipes-qt/qt5/qtwayland_git.bb
@@ -44,32 +44,3 @@ BBCLASSEXTEND =+ "native nativesdk"
# The same issue as in qtbase:
# http://errors.yoctoproject.org/Errors/Details/152641/
LDFLAGS_append = "${@bb.utils.contains('DISTRO_FEATURES', 'ld-is-gold', ' -fuse-ld=bfd ', '', d)}"
-
-# Since version 5.11.2 some private headers are not installed. Work around
-# until fixed upstream. See https://bugreports.qt.io/browse/QTBUG-71340 for
-# further details
-QTWAYLAND_INSTALL_PRIVATE_HEADERS_MANUALLY ?= "1"
-# First 6 characters before first + (e.g. 5.11.3-+git) or - (e.g. 5.11.3-2)
-SHRT_VER ?= "${@d.getVar('PV').split('+')[0].split('-')[0]}"
-do_install_append() {
- if [ -d "${B}/src/client" -a "${QTWAYLAND_INSTALL_PRIVATE_HEADERS_MANUALLY}" = "1" -a -d "${D}${includedir}/QtWaylandClient/${SHRT_VER}/QtWaylandClient/private/" ]; then
- for header in `find ${B}/src/client -name '*wayland-*.h'`; do
- header_base=`basename $header`
- dest="${D}${includedir}/QtWaylandClient/${SHRT_VER}/QtWaylandClient/private/$header_base"
- if [ ! -e "$dest" ]; then
- echo "Manual install: $header_base to $dest"
- install -m 644 "$header" "$dest"
- fi
- done
- fi
- if [ -d "${B}/src/compositor" -a "${QTWAYLAND_INSTALL_PRIVATE_HEADERS_MANUALLY}" = "1" -a -d "${D}${includedir}/QtCompositor/${SHRT_VER}/QtCompositor/private/" ]; then
- for header in `find ${B}/src/compositor -name '*wayland-*.h'`; do
- header_base=`basename $header`
- dest="${D}${includedir}/QtCompositor/${SHRT_VER}/QtCompositor/private/$header_base"
- if [ ! -e "$dest" ]; then
- echo "Manual install: $header_base to $dest"
- install -m 644 "$header" "$dest"
- fi
- done
- fi
-}