aboutsummaryrefslogtreecommitdiffstats
path: root/recipes-qt/qt5/qtwebengine/chromium/0009-chromium-Include-cstddef-for-size_t-definition.patch
diff options
context:
space:
mode:
authorMartin Jansa <Martin.Jansa@gmail.com>2020-01-11 14:55:56 +0100
committerMartin Jansa <Martin.Jansa@gmail.com>2020-01-11 14:59:12 +0100
commitb814111ed28cab46d9d896919b2b5fe308614e1d (patch)
tree09b7b2ee7a67ed0e732cc8d789499dde4b90bc8f /recipes-qt/qt5/qtwebengine/chromium/0009-chromium-Include-cstddef-for-size_t-definition.patch
parent1fde17e1a570aa5495ecbe8a8daae95b628db260 (diff)
qtwebengine: refresh the patches and upload them to meta-qt5 forks on github for maintenance
* fixes 0004-mkspecs-Allow-builds-with-libc-glibc.patch which didn't apply at all, because the modified mkspecs/features/configure.prf was dropped completely in: commit 047d61f188aae3fe3ebc689900b8a5c9fb6e901d Author: Michal Klocek michal.klocek@qt.io Date: Fri Aug 9 17:40:29 2019 +0200 Add webengine-core feature The same chunk can be found in src/buildtools/config/support.pri, so I've updated the .patch accordingly, but haven't tried the build with musl yet. * fixes 0023-chromium-Move-CharAllocator-definition-to-a-header-f.patch to apply ERROR: qtwebengine-5.14.0+gitAUTOINC+d366f1d5d3_939daf833f-r0 do_patch: Command Error: 'quilt --quiltrc /OE/build/oe-core/tmp-glibc/work/core2-64-oe-linux/qtwebengine/5.14.0+gitAUTOINC+d366f1d5d3_939daf833f-r0/recipe-sysroot-native/etc/quiltrc push' exited with 0 Output: Applying patch 0023-chromium-Move-CharAllocator-definition-to-a-header-f.patch patching file chromium/cc/base/list_container_helper.cc Hunk #1 FAILED at 13. 1 out of 1 hunk FAILED -- rejects in file chromium/cc/base/list_container_helper.cc patching file chromium/cc/base/list_container_helper.h Hunk #1 FAILED at 8. Hunk #2 succeeded at 174 with fuzz 1. 1 out of 2 hunks FAILED -- rejects in file chromium/cc/base/list_container_helper.h Patch 0023-chromium-Move-CharAllocator-definition-to-a-header-f.patch does not apply (enforce with -f) ERROR: Logfile of failure stored in: /OE/build/oe-core/tmp-glibc/work/core2-64-oe-linux/qtwebengine/5.14.0+gitAUTOINC+d366f1d5d3_939daf833f-r0/temp/log.do_patch.21067 NOTE: recipe qtwebengine-5.14.0+gitAUTOINC+d366f1d5d3_939daf833f-r0: task do_patch: Failed ERROR: Task (/OE/build/oe-core/meta-qt5/recipes-qt/qt5/qtwebengine_git.bb:do_patch) failed with exit code '1' * build is still going (it will be a while on my slow builder) Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com>
Diffstat (limited to 'recipes-qt/qt5/qtwebengine/chromium/0009-chromium-Include-cstddef-for-size_t-definition.patch')
-rw-r--r--recipes-qt/qt5/qtwebengine/chromium/0009-chromium-Include-cstddef-for-size_t-definition.patch48
1 files changed, 48 insertions, 0 deletions
diff --git a/recipes-qt/qt5/qtwebengine/chromium/0009-chromium-Include-cstddef-for-size_t-definition.patch b/recipes-qt/qt5/qtwebengine/chromium/0009-chromium-Include-cstddef-for-size_t-definition.patch
new file mode 100644
index 00000000..1f4a7c14
--- /dev/null
+++ b/recipes-qt/qt5/qtwebengine/chromium/0009-chromium-Include-cstddef-for-size_t-definition.patch
@@ -0,0 +1,48 @@
+From ef41260060293cf53c279b675c470341fd635a4e Mon Sep 17 00:00:00 2001
+From: Khem Raj <raj.khem@gmail.com>
+Date: Wed, 25 Dec 2019 15:41:16 -0800
+Subject: [PATCH] chromium: Include cstddef for size_t definition
+
+Include ctsdint for uintXX_t
+
+Fixes
+In file included from ../../../../git/src/3rdparty/chromium/third_party/webrtc/modules/audio_processing/aec3/clockdrift_detector.cc:10:
+../../../../git/src/3rdparty/chromium/third_party/webrtc/modules/audio_processing/aec3/clockdrift_detector.h:34:3: error: 'size_t' does not name a type
+ 34 | size_t stability_counter_;
+ | ^~~~~~
+
+Upstream-Status: Pending
+Signed-off-by: Khem Raj <raj.khem@gmail.com>
+
+ccc
+
+Signed-off-by: Khem Raj <raj.khem@gmail.com>
+---
+ .../webrtc/modules/audio_processing/aec3/clockdrift_detector.h | 1 +
+ .../third_party/webrtc/modules/video_coding/decoding_state.h | 1 +
+ 2 files changed, 2 insertions(+)
+
+diff --git a/chromium/third_party/webrtc/modules/audio_processing/aec3/clockdrift_detector.h b/chromium/third_party/webrtc/modules/audio_processing/aec3/clockdrift_detector.h
+index 22528c94892..69e624e8b19 100644
+--- a/chromium/third_party/webrtc/modules/audio_processing/aec3/clockdrift_detector.h
++++ b/chromium/third_party/webrtc/modules/audio_processing/aec3/clockdrift_detector.h
+@@ -12,6 +12,7 @@
+ #define MODULES_AUDIO_PROCESSING_AEC3_CLOCKDRIFT_DETECTOR_H_
+
+ #include <array>
++#include <cstddef>
+
+ namespace webrtc {
+
+diff --git a/chromium/third_party/webrtc/modules/video_coding/decoding_state.h b/chromium/third_party/webrtc/modules/video_coding/decoding_state.h
+index b87fb2d0345..b3faffcfc79 100644
+--- a/chromium/third_party/webrtc/modules/video_coding/decoding_state.h
++++ b/chromium/third_party/webrtc/modules/video_coding/decoding_state.h
+@@ -14,6 +14,7 @@
+ #include <map>
+ #include <set>
+ #include <vector>
++#include <cstdint>
+
+ namespace webrtc {
+