aboutsummaryrefslogtreecommitdiffstats
path: root/recipes-qt/qt5/qtwebengine_git.bb
diff options
context:
space:
mode:
authorMikko Gronoff <mikko.gronoff@qt.io>2020-03-02 14:39:52 +0200
committerMikko Gronoff <mikko.gronoff@qt.io>2020-03-02 15:28:57 +0200
commitf9a58d623762c5fd78bd6bc18d701a7aaa004567 (patch)
treecbb55ca0f320d53b82c69b1afe063b675a20147a /recipes-qt/qt5/qtwebengine_git.bb
parent7637ea77fa521c348da331d103ce96ed4d8b57f5 (diff)
parentabb423512d10d7554e0d62b3a593ce5e436f2756 (diff)
Merge remote-tracking branch 'qt/upstream/master' into 5.14
* qt/upstream/master: abb42351 qtwebview: Skip if meta-python is not present caf09cd5 Add PyQtChart. f18d5948 qtbase: fix build with platform where FE macro are not defined c8cd55b0 qtwebkit: build with python3 0bbd0ebe qtwebengine: Link libatomic on x86/32bit 23914740 Revert "qtwebkit: remove" 8cadcbcb qt5: upgrade to 5.14.1 f13a3cec packagegroup-qt5-toolchain-target: Use TUNE_PKGARCH instead of MACHINE_ARCH a35403dc qtwebkit: remove a797f85c python-pyqt5, qtwebengine, qtwebkit, qt-kiosk-browser: skip without meta-python2 b1f4f1fd Revert "recipes: Use python3 during build" 47fb26de recipes: Use python3 during build 4060f68d qt-kiosk-browser: Only support arm/x86 fd376e15 qtwebengine: Fix missing headers found in build with clang 7f324f11 gstreamer1.0-plugins-good: Adjust bbappend for meson migration in core 1365691f qttools: remove ptest installation 254576f9 qt-kiosk-browser: Add recipe 47399df9 nativesdk-packagegroup: fix cmake builds using sdk Conflicts: recipes-qt/qt5/nativesdk-qtbase_git.bb recipes-qt/qt5/qt3d_git.bb recipes-qt/qt5/qt5-git.inc recipes-qt/qt5/qtbase-native_git.bb recipes-qt/qt5/qtbase/0017-qfloat16-check-for-__ARM_FP-2.patch recipes-qt/qt5/qtbase_git.bb recipes-qt/qt5/qtcharts_git.bb recipes-qt/qt5/qtcoap_git.bb recipes-qt/qt5/qtconnectivity_git.bb recipes-qt/qt5/qtdatavis3d_git.bb recipes-qt/qt5/qtdeclarative_git.bb recipes-qt/qt5/qtgamepad_git.bb recipes-qt/qt5/qtgraphicaleffects_git.bb recipes-qt/qt5/qtknx_git.bb recipes-qt/qt5/qtlocation_git.bb recipes-qt/qt5/qtlottie_git.bb recipes-qt/qt5/qtmqtt_git.bb recipes-qt/qt5/qtmultimedia_git.bb recipes-qt/qt5/qtnetworkauth_git.bb recipes-qt/qt5/qtopcua_git.bb [...] (41 conflicts) Change-Id: Ib48e50eb939e7a8d0422c0beb75863b8a4b82b15
Diffstat (limited to 'recipes-qt/qt5/qtwebengine_git.bb')
-rw-r--r--recipes-qt/qt5/qtwebengine_git.bb15
1 files changed, 12 insertions, 3 deletions
diff --git a/recipes-qt/qt5/qtwebengine_git.bb b/recipes-qt/qt5/qtwebengine_git.bb
index 0262d9bd..36561214 100644
--- a/recipes-qt/qt5/qtwebengine_git.bb
+++ b/recipes-qt/qt5/qtwebengine_git.bb
@@ -79,10 +79,17 @@ COMPATIBLE_MACHINE_aarch64 = "(.*)"
inherit qmake5
inherit gettext
-inherit pythonnative
inherit perlnative
inherit features_check
+inherit ${@bb.utils.contains("BBFILE_COLLECTIONS", "meta-python2", "pythonnative", "", d)}
+
+python() {
+ if 'meta-python2' not in d.getVar('BBFILE_COLLECTIONS').split():
+ raise bb.parse.SkipRecipe('Requires meta-python2 to be present.')
+}
+
+
# Static builds of QtWebEngine aren't supported.
CONFLICT_DISTRO_FEATURES = "qt5-static"
@@ -138,7 +145,7 @@ RDEPENDS_${PN}-examples += " \
QT_MODULE_BRANCH_CHROMIUM = "77-based"
# Patches from https://github.com/meta-qt5/qtwebengine/commits/b5.14
-# 5.14.meta-qt5.1
+# 5.14.meta-qt5.2
SRC_URI += " \
${QT_GIT}/qtwebengine-chromium.git;name=chromium;branch=${QT_MODULE_BRANCH_CHROMIUM};protocol=${QT_GIT_PROTOCOL};destsuffix=git/src/3rdparty \
file://0001-Force-host-toolchain-configuration.patch \
@@ -150,7 +157,7 @@ SRC_URI_append_libc-musl = "\
"
# Patches from https://github.com/meta-qt5/qtwebengine-chromium/commits/77-based
-# 77-based.meta-qt5.1
+# 77-based.meta-qt5.2
SRC_URI += " \
file://chromium/0001-chromium-workaround-for-too-long-.rps-file-name.patch;patchdir=src/3rdparty \
file://chromium/0002-chromium-stack-pointer-clobber.patch;patchdir=src/3rdparty \
@@ -162,6 +169,8 @@ SRC_URI += " \
file://chromium/0008-chromium-Fix-build-on-32bit-arches-with-64bit-time_t.patch;patchdir=src/3rdparty \
file://chromium/0009-chromium-Include-cstddef-for-size_t-definition.patch;patchdir=src/3rdparty \
file://chromium/0010-chromium-Move-CharAllocator-definition-to-a-header-f.patch;patchdir=src/3rdparty \
+ file://chromium/0011-chromium-Include-cstddef-and-cstdint.patch;patchdir=src/3rdparty \
+ file://chromium/0012-chromium-Link-v8-with-libatomic-on-x86.patch;patchdir=src/3rdparty \
"
SRC_URI_append_libc-musl = "\