aboutsummaryrefslogtreecommitdiffstats
path: root/recipes-qt/qt5/qtwebglplugin_git.bb
diff options
context:
space:
mode:
authorSamuli Piippo <samuli.piippo@qt.io>2018-05-29 12:25:56 +0300
committerMartin Jansa <Martin.Jansa@gmail.com>2018-05-30 20:02:46 +0000
commite0a4e23c1dbeed88962694263de1776b530f3899 (patch)
tree50df74129e6ec5eb35f16213e62d0c0e1f3d137c /recipes-qt/qt5/qtwebglplugin_git.bb
parent73f99f2370a3dc5b81f42d0af7fe530431599454 (diff)
qt5: Update to Qt 5.11.0
Add recipes for Qt OPC UA and Qt WebGL platform plugin. Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com>
Diffstat (limited to 'recipes-qt/qt5/qtwebglplugin_git.bb')
-rw-r--r--recipes-qt/qt5/qtwebglplugin_git.bb21
1 files changed, 21 insertions, 0 deletions
diff --git a/recipes-qt/qt5/qtwebglplugin_git.bb b/recipes-qt/qt5/qtwebglplugin_git.bb
new file mode 100644
index 00000000..62601bb3
--- /dev/null
+++ b/recipes-qt/qt5/qtwebglplugin_git.bb
@@ -0,0 +1,21 @@
+require qt5.inc
+require qt5-git.inc
+
+LICENSE = "GPL-3.0 | The-Qt-Company-Commercial"
+LIC_FILES_CHKSUM = " \
+ file://LICENSE.GPL3;md5=d32239bcb673463ab874e80d47fae504 \
+"
+
+DEPENDS += "qtbase qtwebsockets"
+
+PACKAGECONFIG ?= "qtdeclarative"
+PACKAGECONFIG[qtdeclarative] = ",,qtdeclarative"
+
+do_configure_prepend() {
+ # disable qtdeclarative test if it isn't enabled by PACKAGECONFIG
+ sed -e 's/^\(qtHaveModule(quick)\)/OE_QTDECLARATIVE_ENABLED:\1/' -i ${S}/src/plugins/platforms/webgl/webgl.pro
+}
+
+EXTRA_QMAKEVARS_PRE += "${@bb.utils.contains('PACKAGECONFIG', 'qtdeclarative', 'CONFIG+=OE_QTDECLARATIVE_ENABLED', '', d)}"
+
+SRCREV = "62a5226c6147ee45f488a2e2c65870c1f836a5be"