aboutsummaryrefslogtreecommitdiffstats
path: root/recipes-qt/qt5/qtwebkit/0002-Do-not-skip-build-for-cross-compile.patch
diff options
context:
space:
mode:
authorMikko Gronoff <mikko.gronoff@qt.io>2020-03-06 12:32:13 +0200
committerMikko Gronoff <mikko.gronoff@qt.io>2020-03-10 09:03:25 +0200
commit5114e3057ceb4afc7f2ae9f71bb351f9e5c7f553 (patch)
tree970f133c757794bcdc024acff5e053ca621ad47d /recipes-qt/qt5/qtwebkit/0002-Do-not-skip-build-for-cross-compile.patch
parentc29bdf41c4494e278a17a233048205bf212e040f (diff)
parentde2ecaa13fde8f30b1a6558bbbbdfecfd3cd4bd8 (diff)
Merge remote-tracking branch 'qt/5.14' into 5.15
* qt/5.14: de2ecaa1 coin: update module_config.yaml with meta-python2 support f9a58d62 Merge remote-tracking branch 'qt/upstream/master' into 5.14 2da972e5 qt5: update submodules 9be6548e qt5: update submodules b5e4f925 qtquicktimeline: add recipe abb42351 (qt/upstream/master) qtwebview: Skip if meta-python is not present caf09cd5 Add PyQtChart. f18d5948 qtbase: fix build with platform where FE macro are not defined c8cd55b0 qtwebkit: build with python3 0bbd0ebe qtwebengine: Link libatomic on x86/32bit 23914740 Revert "qtwebkit: remove" 8cadcbcb qt5: upgrade to 5.14.1 f13a3cec packagegroup-qt5-toolchain-target: Use TUNE_PKGARCH instead of MACHINE_ARCH a35403dc qtwebkit: remove a797f85c python-pyqt5, qtwebengine, qtwebkit, qt-kiosk-browser: skip without meta-python2 b1f4f1fd Revert "recipes: Use python3 during build" 47fb26de recipes: Use python3 during build 4060f68d qt-kiosk-browser: Only support arm/x86 fd376e15 qtwebengine: Fix missing headers found in build with clang 7f324f11 gstreamer1.0-plugins-good: Adjust bbappend for meson migration in core 1365691f qttools: remove ptest installation 254576f9 qt-kiosk-browser: Add recipe 47399df9 nativesdk-packagegroup: fix cmake builds using sdk Conflicts: recipes-qt/packagegroups/packagegroup-qt5-toolchain-target.bb recipes-qt/qt5/nativesdk-qtbase_git.bb recipes-qt/qt5/qt3d/0001-Allow-a-tools-only-build.patch recipes-qt/qt5/qt3d_git.bb recipes-qt/qt5/qtbase-native_git.bb recipes-qt/qt5/qtbase_git.bb recipes-qt/qt5/qtcharts_git.bb recipes-qt/qt5/qtcoap_git.bb recipes-qt/qt5/qtconnectivity_git.bb recipes-qt/qt5/qtdeclarative_git.bb recipes-qt/qt5/qtimageformats_git.bb recipes-qt/qt5/qtknx_git.bb recipes-qt/qt5/qtlocation_git.bb recipes-qt/qt5/qtmultimedia_git.bb recipes-qt/qt5/qtquick3d_git.bb recipes-qt/qt5/qtquickcontrols2_git.bb recipes-qt/qt5/qtremoteobjects_git.bb recipes-qt/qt5/qtscript_git.bb recipes-qt/qt5/qtserialbus_git.bb recipes-qt/qt5/qtsvg_git.bb recipes-qt/qt5/qttools_git.bb recipes-qt/qt5/qtwebengine_git.bb recipes-qt/qt5/qtwebsockets_git.bb recipes-qt/qt5/qtwebview_git.bb Change-Id: I41b3b999dc1278342e33dda3b66af1990e8da090
Diffstat (limited to 'recipes-qt/qt5/qtwebkit/0002-Do-not-skip-build-for-cross-compile.patch')
-rw-r--r--recipes-qt/qt5/qtwebkit/0002-Do-not-skip-build-for-cross-compile.patch28
1 files changed, 28 insertions, 0 deletions
diff --git a/recipes-qt/qt5/qtwebkit/0002-Do-not-skip-build-for-cross-compile.patch b/recipes-qt/qt5/qtwebkit/0002-Do-not-skip-build-for-cross-compile.patch
new file mode 100644
index 00000000..a237d03d
--- /dev/null
+++ b/recipes-qt/qt5/qtwebkit/0002-Do-not-skip-build-for-cross-compile.patch
@@ -0,0 +1,28 @@
+From 34018c2a61045c58f88e09a12ecd62533aa2c2f1 Mon Sep 17 00:00:00 2001
+From: =?UTF-8?q?Andreas=20M=C3=BCller?= <schnitzeltony@gmail.com>
+Date: Mon, 4 Jun 2018 10:35:46 +0200
+Subject: [PATCH] Do not skip build for cross-compile
+MIME-Version: 1.0
+Content-Type: text/plain; charset=UTF-8
+Content-Transfer-Encoding: 8bit
+
+Upstream-Status: Inappropriate [OE specific]
+
+Signed-off-by: Andreas Müller <schnitzeltony@gmail.com>
+---
+ Tools/qmake/mkspecs/features/functions.prf | 2 --
+ 1 file changed, 2 deletions(-)
+
+diff --git a/Tools/qmake/mkspecs/features/functions.prf b/Tools/qmake/mkspecs/features/functions.prf
+index e3f42cec4..797b7085f 100644
+--- a/Tools/qmake/mkspecs/features/functions.prf
++++ b/Tools/qmake/mkspecs/features/functions.prf
+@@ -53,8 +53,6 @@ defineReplace(appleSdkVersion) {
+ defineTest(isPlatformSupported) {
+ !qtHaveModule(widgets): skipBuild("QtWidgets module is required to build QtWebKit.")
+
+- cross_compile: skipBuild("cross-compilation of QtWebKit with qmake is not supported yet")
+-
+ requiredPrograms = cmake gperf python perl bison ruby flex
+ for(program, requiredPrograms): \
+ !programExistsInPath($$program): \