aboutsummaryrefslogtreecommitdiffstats
path: root/recipes-qt/qt5/qtwebkit
diff options
context:
space:
mode:
authorMartin Jansa <Martin.Jansa@gmail.com>2018-09-14 10:00:14 +0000
committerMartin Jansa <Martin.Jansa@gmail.com>2018-09-19 09:55:34 +0000
commitedf1e434942d3169c459eedaf1d7736ab51ac07a (patch)
tree720a2b4d1eb09fb618ec61ac65dfe31ca37c22b2 /recipes-qt/qt5/qtwebkit
parenta307eb0ede74c0f6335fa6e016c65c8ab101dc98 (diff)
qtwebkit: add patches to meta-qt5 fork
Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com>
Diffstat (limited to 'recipes-qt/qt5/qtwebkit')
-rw-r--r--recipes-qt/qt5/qtwebkit/0002-Fix-build-with-non-glibc-libc-on-musl.patch (renamed from recipes-qt/qt5/qtwebkit/0001-Fix-build-with-non-glibc-libc-on-musl.patch)10
-rw-r--r--recipes-qt/qt5/qtwebkit/0003-WebKitMacros-Append-to-I-and-not-to-isystem.patch (renamed from recipes-qt/qt5/qtwebkit/0001-WebKitMacros-Append-to-I-and-not-to-isystem.patch)31
2 files changed, 19 insertions, 22 deletions
diff --git a/recipes-qt/qt5/qtwebkit/0001-Fix-build-with-non-glibc-libc-on-musl.patch b/recipes-qt/qt5/qtwebkit/0002-Fix-build-with-non-glibc-libc-on-musl.patch
index 5cd604e5..dead46d1 100644
--- a/recipes-qt/qt5/qtwebkit/0001-Fix-build-with-non-glibc-libc-on-musl.patch
+++ b/recipes-qt/qt5/qtwebkit/0002-Fix-build-with-non-glibc-libc-on-musl.patch
@@ -1,4 +1,4 @@
-From 356ef55b985d8d874f2358b937d396bea52ebff6 Mon Sep 17 00:00:00 2001
+From 9db9a8850602c2446b1a7ee96608fd74cf56a342 Mon Sep 17 00:00:00 2001
From: Khem Raj <raj.khem@gmail.com>
Date: Thu, 23 Aug 2018 04:06:17 +0000
Subject: [PATCH] Fix build with non-glibc libc on musl
@@ -8,12 +8,12 @@ Need to ensure glibc features are not assumed to be linux-wide
Upstream-Status: Pending
Signed-off-by: Khem Raj <raj.khem@gmail.com>
---
- Source/JavaScriptCore/heap/MachineStackMarker.cpp | 8 ++++----
- .../inspector/JSGlobalObjectInspectorController.cpp | 2 ++
+ Source/JavaScriptCore/heap/MachineStackMarker.cpp | 8 ++++----
+ .../inspector/JSGlobalObjectInspectorController.cpp | 2 ++
2 files changed, 6 insertions(+), 4 deletions(-)
diff --git a/Source/JavaScriptCore/heap/MachineStackMarker.cpp b/Source/JavaScriptCore/heap/MachineStackMarker.cpp
-index 883914f..ce4e8d3 100644
+index 883914fd3..ce4e8d331 100644
--- a/Source/JavaScriptCore/heap/MachineStackMarker.cpp
+++ b/Source/JavaScriptCore/heap/MachineStackMarker.cpp
@@ -566,7 +566,7 @@ void* MachineThreads::Thread::Registers::stackPointer() const
@@ -53,7 +53,7 @@ index 883914f..ce4e8d3 100644
// The following sequence depends on glibc's sys/ucontext.h.
#if CPU(X86)
diff --git a/Source/JavaScriptCore/inspector/JSGlobalObjectInspectorController.cpp b/Source/JavaScriptCore/inspector/JSGlobalObjectInspectorController.cpp
-index fd7f869..e95391b 100644
+index fd7f869d4..e95391b32 100644
--- a/Source/JavaScriptCore/inspector/JSGlobalObjectInspectorController.cpp
+++ b/Source/JavaScriptCore/inspector/JSGlobalObjectInspectorController.cpp
@@ -51,8 +51,10 @@
diff --git a/recipes-qt/qt5/qtwebkit/0001-WebKitMacros-Append-to-I-and-not-to-isystem.patch b/recipes-qt/qt5/qtwebkit/0003-WebKitMacros-Append-to-I-and-not-to-isystem.patch
index d96a6b65..c24eb69e 100644
--- a/recipes-qt/qt5/qtwebkit/0001-WebKitMacros-Append-to-I-and-not-to-isystem.patch
+++ b/recipes-qt/qt5/qtwebkit/0003-WebKitMacros-Append-to-I-and-not-to-isystem.patch
@@ -1,4 +1,4 @@
-From 7c2e6013caf7720530f963ca03eab2baa540c512 Mon Sep 17 00:00:00 2001
+From ef1b87e4ce8db720a4d7f5ee80fec4388dc3b086 Mon Sep 17 00:00:00 2001
From: Khem Raj <raj.khem@gmail.com>
Date: Fri, 24 Aug 2018 07:13:39 +0000
Subject: [PATCH] WebKitMacros: Append to -I and not to -isystem
@@ -34,7 +34,7 @@ Signed-off-by: Khem Raj <raj.khem@gmail.com>
13 files changed, 13 insertions(+), 13 deletions(-)
diff --git a/Source/JavaScriptCore/shell/CMakeLists.txt b/Source/JavaScriptCore/shell/CMakeLists.txt
-index 27d8133..9480f6d 100644
+index 27d81336f..9480f6d88 100644
--- a/Source/JavaScriptCore/shell/CMakeLists.txt
+++ b/Source/JavaScriptCore/shell/CMakeLists.txt
@@ -20,7 +20,7 @@ WEBKIT_INCLUDE_CONFIG_FILES_IF_EXISTS()
@@ -47,7 +47,7 @@ index 27d8133..9480f6d 100644
target_link_libraries(jsc ${JSC_LIBRARIES})
set_target_properties(jsc PROPERTIES FOLDER "JavaScriptCore")
diff --git a/Source/WebKit/qt/declarative/CMakeLists.txt b/Source/WebKit/qt/declarative/CMakeLists.txt
-index e1ba22b..84cb565 100644
+index e1ba22bc1..84cb56544 100644
--- a/Source/WebKit/qt/declarative/CMakeLists.txt
+++ b/Source/WebKit/qt/declarative/CMakeLists.txt
@@ -15,7 +15,7 @@ include_directories(
@@ -60,7 +60,7 @@ index e1ba22b..84cb565 100644
${Qt5Quick_INCLUDE_DIRS}
${Qt5Quick_PRIVATE_INCLUDE_DIRS}
diff --git a/Source/WebKit/qt/tests/CMakeLists.txt b/Source/WebKit/qt/tests/CMakeLists.txt
-index 3dc6af1..d821f02 100644
+index 3dc6af1d5..d821f0284 100644
--- a/Source/WebKit/qt/tests/CMakeLists.txt
+++ b/Source/WebKit/qt/tests/CMakeLists.txt
@@ -7,7 +7,7 @@ include_directories(
@@ -73,7 +73,7 @@ index 3dc6af1..d821f02 100644
${Qt5Gui_PRIVATE_INCLUDE_DIRS}
${Qt5Widgets_INCLUDE_DIRS}
diff --git a/Source/WebKit2/UIProcess/API/qt/tests/CMakeLists.txt b/Source/WebKit2/UIProcess/API/qt/tests/CMakeLists.txt
-index 210342e..bfc768f 100644
+index 210342ef5..bfc768fa0 100644
--- a/Source/WebKit2/UIProcess/API/qt/tests/CMakeLists.txt
+++ b/Source/WebKit2/UIProcess/API/qt/tests/CMakeLists.txt
@@ -4,7 +4,7 @@ include_directories(
@@ -86,7 +86,7 @@ index 210342e..bfc768f 100644
${Qt5Quick_PRIVATE_INCLUDE_DIRS}
${Qt5QuickTest_INCLUDE_DIRS}
diff --git a/Source/cmake/WebKitMacros.cmake b/Source/cmake/WebKitMacros.cmake
-index 07e3143..a1e5887 100644
+index 07e31432a..a1e58873f 100644
--- a/Source/cmake/WebKitMacros.cmake
+++ b/Source/cmake/WebKitMacros.cmake
@@ -260,7 +260,7 @@ endmacro()
@@ -99,7 +99,7 @@ index 07e3143..a1e5887 100644
${${_target}_HEADERS}
${${_target}_SOURCES}
diff --git a/Tools/DumpRenderTree/CMakeLists.txt b/Tools/DumpRenderTree/CMakeLists.txt
-index 4a726cc..cd0c5e3 100644
+index 4a726ccaf..cd0c5e303 100644
--- a/Tools/DumpRenderTree/CMakeLists.txt
+++ b/Tools/DumpRenderTree/CMakeLists.txt
@@ -115,7 +115,7 @@ list(APPEND TestNetscapePlugin_LIBRARIES
@@ -112,7 +112,7 @@ index 4a726cc..cd0c5e3 100644
add_executable(DumpRenderTree ${DumpRenderTree_SOURCES})
target_link_libraries(DumpRenderTree ${DumpRenderTree_LIBRARIES})
diff --git a/Tools/DumpRenderTree/TestNetscapePlugIn/CMakeLists.txt b/Tools/DumpRenderTree/TestNetscapePlugIn/CMakeLists.txt
-index c431667..6dff244 100644
+index c431667b2..6dff24475 100644
--- a/Tools/DumpRenderTree/TestNetscapePlugIn/CMakeLists.txt
+++ b/Tools/DumpRenderTree/TestNetscapePlugIn/CMakeLists.txt
@@ -42,7 +42,7 @@ set(WebKitTestNetscapePlugin_SYSTEM_INCLUDE_DIRECTORIES
@@ -125,7 +125,7 @@ index c431667..6dff244 100644
set(WebKitTestNetscapePlugin_LIBRARIES
${X11_LIBRARIES}
diff --git a/Tools/ImageDiff/CMakeLists.txt b/Tools/ImageDiff/CMakeLists.txt
-index 6ce4ed5..4dd6c4a 100644
+index 6ce4ed522..4dd6c4adf 100644
--- a/Tools/ImageDiff/CMakeLists.txt
+++ b/Tools/ImageDiff/CMakeLists.txt
@@ -14,7 +14,7 @@ set(IMAGE_DIFF_LIBRARIES
@@ -138,7 +138,7 @@ index 6ce4ed5..4dd6c4a 100644
target_link_libraries(ImageDiff ${IMAGE_DIFF_LIBRARIES})
set_target_properties(ImageDiff PROPERTIES FOLDER "Tools")
diff --git a/Tools/MiniBrowser/qt/CMakeLists.txt b/Tools/MiniBrowser/qt/CMakeLists.txt
-index 68dd13c..b491df2 100644
+index 68dd13c8b..b491df2a8 100644
--- a/Tools/MiniBrowser/qt/CMakeLists.txt
+++ b/Tools/MiniBrowser/qt/CMakeLists.txt
@@ -64,7 +64,7 @@ if (ENABLE_TEST_SUPPORT)
@@ -151,7 +151,7 @@ index 68dd13c..b491df2 100644
target_link_libraries(MiniBrowser ${MiniBrowser_LIBRARIES})
set_target_properties(MiniBrowser PROPERTIES FOLDER "Tools" AUTOMOC ON)
diff --git a/Tools/QtTestBrowser/CMakeLists.txt b/Tools/QtTestBrowser/CMakeLists.txt
-index ccd8e0f..18de9f2 100644
+index ccd8e0ff2..18de9f274 100644
--- a/Tools/QtTestBrowser/CMakeLists.txt
+++ b/Tools/QtTestBrowser/CMakeLists.txt
@@ -62,7 +62,7 @@ if (ENABLE_TEST_SUPPORT)
@@ -164,7 +164,7 @@ index ccd8e0f..18de9f2 100644
target_link_libraries(QtTestBrowser ${QtTestBrowser_LIBRARIES})
set_target_properties(QtTestBrowser PROPERTIES FOLDER "Tools" AUTOMOC ON)
diff --git a/Tools/TestWebKitAPI/PlatformQt.cmake b/Tools/TestWebKitAPI/PlatformQt.cmake
-index c054c66..046a91a 100644
+index c054c661b..046a91abc 100644
--- a/Tools/TestWebKitAPI/PlatformQt.cmake
+++ b/Tools/TestWebKitAPI/PlatformQt.cmake
@@ -7,7 +7,7 @@ include_directories(
@@ -177,7 +177,7 @@ index c054c66..046a91a 100644
${Qt5Gui_INCLUDE_DIRS}
)
diff --git a/Tools/TestWebKitAPI/Tests/WebKit2Gtk/CMakeLists.txt b/Tools/TestWebKitAPI/Tests/WebKit2Gtk/CMakeLists.txt
-index b0b4739..434e4ca 100644
+index b0b473962..434e4ca25 100644
--- a/Tools/TestWebKitAPI/Tests/WebKit2Gtk/CMakeLists.txt
+++ b/Tools/TestWebKitAPI/Tests/WebKit2Gtk/CMakeLists.txt
@@ -23,7 +23,7 @@ include_directories(
@@ -190,7 +190,7 @@ index b0b4739..434e4ca 100644
${GLIB_INCLUDE_DIRS}
${GSTREAMER_INCLUDE_DIRS}
diff --git a/Tools/WebKitTestRunner/CMakeLists.txt b/Tools/WebKitTestRunner/CMakeLists.txt
-index 6355772..6279658 100644
+index 6355772ce..627965858 100644
--- a/Tools/WebKitTestRunner/CMakeLists.txt
+++ b/Tools/WebKitTestRunner/CMakeLists.txt
@@ -116,7 +116,7 @@ GENERATE_BINDINGS(WebKitTestRunner_SOURCES
@@ -202,6 +202,3 @@ index 6355772..6279658 100644
add_library(TestRunnerInjectedBundle SHARED ${WebKitTestRunnerInjectedBundle_SOURCES})
target_link_libraries(TestRunnerInjectedBundle ${WebKitTestRunner_LIBRARIES})
---
-1.9.1
-