aboutsummaryrefslogtreecommitdiffstats
path: root/recipes-qt/qt5/qtwebview_git.bb
diff options
context:
space:
mode:
authorKhem Raj <raj.khem@gmail.com>2020-02-17 22:34:30 -0800
committerMartin Jansa <Martin.Jansa@gmail.com>2020-02-19 11:16:30 +0100
commitabb423512d10d7554e0d62b3a593ce5e436f2756 (patch)
tree8facb6600513e639307bdc9cecccf77fec46d5d8 /recipes-qt/qt5/qtwebview_git.bb
parentcaf09cd53cc2a4eb10a1d1124dadd2a34fb6b116 (diff)
qtwebview: Skip if meta-python is not present
It needs qtwebengine which needs python2 so skip it when python2 is not present Signed-off-by: Khem Raj <raj.khem@gmail.com>
Diffstat (limited to 'recipes-qt/qt5/qtwebview_git.bb')
-rw-r--r--recipes-qt/qt5/qtwebview_git.bb5
1 files changed, 5 insertions, 0 deletions
diff --git a/recipes-qt/qt5/qtwebview_git.bb b/recipes-qt/qt5/qtwebview_git.bb
index 5d102629..c0ca6118 100644
--- a/recipes-qt/qt5/qtwebview_git.bb
+++ b/recipes-qt/qt5/qtwebview_git.bb
@@ -20,3 +20,8 @@ COMPATIBLE_MACHINE_armv7ve = "(.*)"
COMPATIBLE_MACHINE_aarch64 = "(.*)"
SRCREV = "94c697c37945dedb37a55c1a9669d868f8c97f41"
+
+python() {
+ if 'meta-python2' not in d.getVar('BBFILE_COLLECTIONS').split():
+ raise bb.parse.SkipRecipe('Requires meta-python2 to be present.')
+}