aboutsummaryrefslogtreecommitdiffstats
path: root/recipes-qt
diff options
context:
space:
mode:
authorMikko Gronoff <mikko.gronoff@qt.io>2018-08-29 10:28:39 +0300
committerMikko Gronoff <mikko.gronoff@qt.io>2018-08-29 11:42:09 +0000
commit32dafa2a682d72aeceed22e2dda4bb6d34309b52 (patch)
tree7eae8f23bb3e0c8f1aa48148592220056a6ee250 /recipes-qt
parentb2c4866fe9a145713a5548b13d0f6d85457c6c63 (diff)
qt5: update submodules
Task-number: QTBUG-68980 Change-Id: If9e570a126f67225c76b387c81d582918a9a3914 Reviewed-by: Kari Oikarinen <kari.oikarinen@qt.io>
Diffstat (limited to 'recipes-qt')
-rw-r--r--recipes-qt/qt5/nativesdk-qtbase_git.bb2
-rw-r--r--recipes-qt/qt5/qt3d_git.bb2
-rw-r--r--recipes-qt/qt5/qtbase-native_git.bb2
-rw-r--r--recipes-qt/qt5/qtbase_git.bb2
-rw-r--r--recipes-qt/qt5/qtconnectivity_git.bb2
-rw-r--r--recipes-qt/qt5/qtdeclarative_git.bb2
-rw-r--r--recipes-qt/qt5/qtlocation_git.bb2
-rw-r--r--recipes-qt/qt5/qtmqtt_git.bb2
-rw-r--r--recipes-qt/qt5/qtmultimedia_git.bb2
-rw-r--r--recipes-qt/qt5/qtscript_git.bb2
-rw-r--r--recipes-qt/qt5/qtsensors_git.bb2
-rw-r--r--recipes-qt/qt5/qttools_git.bb2
-rw-r--r--recipes-qt/qt5/qtvirtualkeyboard_git.bb2
-rw-r--r--recipes-qt/qt5/qtwayland_git.bb2
-rw-r--r--recipes-qt/qt5/qtwebchannel_git.bb2
-rw-r--r--recipes-qt/qt5/qtwebengine_git.bb4
-rw-r--r--recipes-qt/qt5/qtwebview_git.bb2
-rw-r--r--recipes-qt/qt5/qtxmlpatterns_git.bb2
18 files changed, 19 insertions, 19 deletions
diff --git a/recipes-qt/qt5/nativesdk-qtbase_git.bb b/recipes-qt/qt5/nativesdk-qtbase_git.bb
index 5b027243..a399019b 100644
--- a/recipes-qt/qt5/nativesdk-qtbase_git.bb
+++ b/recipes-qt/qt5/nativesdk-qtbase_git.bb
@@ -208,4 +208,4 @@ fakeroot do_generate_qt_environment_file() {
do_generate_qt_environment_file[umask] = "022"
addtask generate_qt_environment_file after do_install before do_package
-SRCREV = "8f1851013363ae22d311881abcb1186949068270"
+SRCREV = "5b6eb8e247d246a28bdc8ce533c52d7647a44a90"
diff --git a/recipes-qt/qt5/qt3d_git.bb b/recipes-qt/qt5/qt3d_git.bb
index b67f37ee..d2bbd64d 100644
--- a/recipes-qt/qt5/qt3d_git.bb
+++ b/recipes-qt/qt5/qt3d_git.bb
@@ -36,6 +36,6 @@ do_configure_prepend() {
${S}/src/quick3d/imports/input/importsinput.pro
}
-SRCREV = "d3395bf51cc2c90e29908f96aba47ee15c291f9f"
+SRCREV = "d0692c6944599a5561ea07faaa6bddf98e7e2a6e"
BBCLASSEXTEND += "native nativesdk"
diff --git a/recipes-qt/qt5/qtbase-native_git.bb b/recipes-qt/qt5/qtbase-native_git.bb
index 6afb421b..e49abad3 100644
--- a/recipes-qt/qt5/qtbase-native_git.bb
+++ b/recipes-qt/qt5/qtbase-native_git.bb
@@ -134,4 +134,4 @@ do_install() {
echo 'set(_qt5_corelib_extra_includes "${_qt5Core_install_prefix}/lib${QT_DIR_NAME}/mkspecs/linux-oe-g++")' > ${D}${libdir}/cmake/Qt5Core/Qt5CoreConfigExtrasMkspecDir.cmake
}
-SRCREV = "8f1851013363ae22d311881abcb1186949068270"
+SRCREV = "5b6eb8e247d246a28bdc8ce533c52d7647a44a90"
diff --git a/recipes-qt/qt5/qtbase_git.bb b/recipes-qt/qt5/qtbase_git.bb
index cf03620d..065115b7 100644
--- a/recipes-qt/qt5/qtbase_git.bb
+++ b/recipes-qt/qt5/qtbase_git.bb
@@ -249,4 +249,4 @@ INSANE_SKIP_${PN}-mkspecs += "file-rdeps"
RRECOMMENDS_${PN}-plugins += "${@bb.utils.contains('DISTRO_FEATURES', 'x11', 'libx11-locale', '', d)}"
-SRCREV = "8f1851013363ae22d311881abcb1186949068270"
+SRCREV = "5b6eb8e247d246a28bdc8ce533c52d7647a44a90"
diff --git a/recipes-qt/qt5/qtconnectivity_git.bb b/recipes-qt/qt5/qtconnectivity_git.bb
index 3f61ba40..d7b75a76 100644
--- a/recipes-qt/qt5/qtconnectivity_git.bb
+++ b/recipes-qt/qt5/qtconnectivity_git.bb
@@ -19,4 +19,4 @@ PACKAGECONFIG[bluez] = "-feature-bluez,-no-feature-bluez,${BLUEZ}"
EXTRA_QMAKEVARS_CONFIGURE += "${PACKAGECONFIG_CONFARGS}"
-SRCREV = "01bce9f3329ba617c2bd53601f4a4abbe2cb5d44"
+SRCREV = "0c2b6dc44351352e8a88248b98e1d45c0403e01c"
diff --git a/recipes-qt/qt5/qtdeclarative_git.bb b/recipes-qt/qt5/qtdeclarative_git.bb
index e465d91d..f15a9a9f 100644
--- a/recipes-qt/qt5/qtdeclarative_git.bb
+++ b/recipes-qt/qt5/qtdeclarative_git.bb
@@ -33,6 +33,6 @@ do_install_append_class-nativesdk() {
EXTRA_QMAKEVARS_PRE += "${@bb.utils.contains('PACKAGECONFIG', 'qtxmlpatterns', 'CONFIG+=OE_QTXMLPATTERNS_ENABLED', '', d)}"
-SRCREV = "b50165508996e10a232ee70196a820da06f1af1c"
+SRCREV = "f25824e0b2154129c0c7586e708c87fe24ce63eb"
BBCLASSEXTEND =+ "native nativesdk"
diff --git a/recipes-qt/qt5/qtlocation_git.bb b/recipes-qt/qt5/qtlocation_git.bb
index 2f5a6151..36333e6d 100644
--- a/recipes-qt/qt5/qtlocation_git.bb
+++ b/recipes-qt/qt5/qtlocation_git.bb
@@ -31,7 +31,7 @@ SRC_URI += " \
${QT_GIT}/qtlocation-mapboxgl.git;name=qtlocation-mapboxgl;branch=${QT_MODULE_BRANCH_MAPBOXGL};protocol=${QT_GIT_PROTOCOL};destsuffix=git/src/3rdparty/mapbox-gl-native \
"
-SRCREV_qtlocation = "a8c09973f8cc960b9047157ad7e6834032bea0b7"
+SRCREV_qtlocation = "571126c3d63f899a67b896886aaec8cf4f0acb1c"
SRCREV_qtlocation-mapboxgl = "b59b0450c60b3df9e0852f62f6c8a6024889cd9e"
SRCREV_FORMAT = "qtlocation_qtlocation-mapboxgl"
diff --git a/recipes-qt/qt5/qtmqtt_git.bb b/recipes-qt/qt5/qtmqtt_git.bb
index 083c3e48..bdf1f2e1 100644
--- a/recipes-qt/qt5/qtmqtt_git.bb
+++ b/recipes-qt/qt5/qtmqtt_git.bb
@@ -9,4 +9,4 @@ LIC_FILES_CHKSUM = " \
DEPENDS += "qtbase"
-SRCREV = "c129d6650508063e438e80f4c755159ead413e28"
+SRCREV = "d84eeec72495847661fecc7d4b45ea1b068180b0"
diff --git a/recipes-qt/qt5/qtmultimedia_git.bb b/recipes-qt/qt5/qtmultimedia_git.bb
index 4e14294a..03229f36 100644
--- a/recipes-qt/qt5/qtmultimedia_git.bb
+++ b/recipes-qt/qt5/qtmultimedia_git.bb
@@ -37,4 +37,4 @@ SRC_URI += "\
# http://errors.yoctoproject.org/Errors/Build/44914/
LDFLAGS_append_x86 = "${@bb.utils.contains('DISTRO_FEATURES', 'ld-is-gold', ' -fuse-ld=bfd ', '', d)}"
-SRCREV = "02ac3f58721bb52db612acd3bb2e2c26bfc3e05b"
+SRCREV = "c1ca9510af3c3c4134b717f1863651783e338a9e"
diff --git a/recipes-qt/qt5/qtscript_git.bb b/recipes-qt/qt5/qtscript_git.bb
index 71b714cc..23858d33 100644
--- a/recipes-qt/qt5/qtscript_git.bb
+++ b/recipes-qt/qt5/qtscript_git.bb
@@ -32,4 +32,4 @@ DEPENDS += "qtbase"
# http://errors.yoctoproject.org/Errors/Build/44915/
LDFLAGS_append_x86 = "${@bb.utils.contains('DISTRO_FEATURES', 'ld-is-gold', ' -fuse-ld=bfd ', '', d)}"
-SRCREV = "2e67664efc66e2f96eb8c6859bef6d6a4160bade"
+SRCREV = "b5f10e499754d57bde490f663a1edf63b4e1bcdc"
diff --git a/recipes-qt/qt5/qtsensors_git.bb b/recipes-qt/qt5/qtsensors_git.bb
index a9d8189c..383c9d95 100644
--- a/recipes-qt/qt5/qtsensors_git.bb
+++ b/recipes-qt/qt5/qtsensors_git.bb
@@ -12,4 +12,4 @@ LIC_FILES_CHKSUM = " \
DEPENDS += "qtbase qtdeclarative"
-SRCREV = "a2d3d45f3e9f779a4fc10f8df07b9bd921e755c6"
+SRCREV = "b4634741fd94dac837418fd5e4f6e1c75bb29a22"
diff --git a/recipes-qt/qt5/qttools_git.bb b/recipes-qt/qt5/qttools_git.bb
index ff03fbc1..9b1f58fe 100644
--- a/recipes-qt/qt5/qttools_git.bb
+++ b/recipes-qt/qt5/qttools_git.bb
@@ -32,7 +32,7 @@ EXTRA_QMAKEVARS_PRE += " \
${@bb.utils.contains('PACKAGECONFIG', 'qtwebkit', '', 'CONFIG+=noqtwebkit', d)} \
"
-SRCREV = "6edf63144df8662bb3ff787553b183584a533f56"
+SRCREV = "39b59e8b4bd9083070175f1ea4067e68f507a394"
BBCLASSEXTEND = "native nativesdk"
diff --git a/recipes-qt/qt5/qtvirtualkeyboard_git.bb b/recipes-qt/qt5/qtvirtualkeyboard_git.bb
index 04cb10d5..1ce0a657 100644
--- a/recipes-qt/qt5/qtvirtualkeyboard_git.bb
+++ b/recipes-qt/qt5/qtvirtualkeyboard_git.bb
@@ -49,4 +49,4 @@ FILES_${PN} += "${OE_QMAKE_PATH_DATA}/qtvirtualkeyboard/lipi_toolkit"
DEPENDS += "qtbase qtdeclarative qtmultimedia qtquickcontrols qtsvg qtxmlpatterns qtdeclarative-native"
-SRCREV = "bf39468a6368b055335c6b73da65577ec55731ee"
+SRCREV = "c8f5d466bcda37174a3f3d5acbf4db2eb9c29bb1"
diff --git a/recipes-qt/qt5/qtwayland_git.bb b/recipes-qt/qt5/qtwayland_git.bb
index b9be1dbf..f9bc7772 100644
--- a/recipes-qt/qt5/qtwayland_git.bb
+++ b/recipes-qt/qt5/qtwayland_git.bb
@@ -37,7 +37,7 @@ PACKAGECONFIG[libhybris-egl-server] = "-feature-libhybris-egl-server,-no-feature
EXTRA_QMAKEVARS_CONFIGURE += "${PACKAGECONFIG_CONFARGS}"
-SRCREV = "b5dfc03a13014bf29d23784bc6802bb06e212558"
+SRCREV = "048fa7f52cbfee1351e5c2d6420f438fa733106e"
BBCLASSEXTEND =+ "native nativesdk"
diff --git a/recipes-qt/qt5/qtwebchannel_git.bb b/recipes-qt/qt5/qtwebchannel_git.bb
index 1a7b3723..fe85730d 100644
--- a/recipes-qt/qt5/qtwebchannel_git.bb
+++ b/recipes-qt/qt5/qtwebchannel_git.bb
@@ -12,4 +12,4 @@ LIC_FILES_CHKSUM = " \
DEPENDS += "qtdeclarative qtwebsockets"
-SRCREV = "1906f62469e608f712c1507dabd74638e38d8075"
+SRCREV = "b4277bf9bf30f1fc8cba1d6c7185e991e83e6e18"
diff --git a/recipes-qt/qt5/qtwebengine_git.bb b/recipes-qt/qt5/qtwebengine_git.bb
index 730ac560..044e8b27 100644
--- a/recipes-qt/qt5/qtwebengine_git.bb
+++ b/recipes-qt/qt5/qtwebengine_git.bb
@@ -165,8 +165,8 @@ SRC_URI_append_libc-musl = "\
file://chromium/0015-chromium-musl-tcmalloc-Use-off64_t-insread-of-__off6.patch;patchdir=src/3rdparty \
"
-SRCREV_qtwebengine = "410c22978c2add5f9427af08d97356d6e959e412"
-SRCREV_chromium = "a3d55fb8e46caed89ea49aaa0604e1251ce6ab0d"
+SRCREV_qtwebengine = "82d00f9d68319e5e0d52bd17587e65cce001b999"
+SRCREV_chromium = "7085115f51ce9d02cfff216a3f74b1fb6715f38d"
SRCREV = "${SRCREV_qtwebengine}"
SRCREV_FORMAT = "qtwebengine_chromium"
diff --git a/recipes-qt/qt5/qtwebview_git.bb b/recipes-qt/qt5/qtwebview_git.bb
index b1c59750..fc884911 100644
--- a/recipes-qt/qt5/qtwebview_git.bb
+++ b/recipes-qt/qt5/qtwebview_git.bb
@@ -19,4 +19,4 @@ COMPATIBLE_MACHINE_armv7a = "(.*)"
COMPATIBLE_MACHINE_armv7ve = "(.*)"
COMPATIBLE_MACHINE_aarch64 = "(.*)"
-SRCREV = "c95d904fa11b925a1617e4b5b2a87915079d8642"
+SRCREV = "4c1918c99db5bcb3c95e777df2f6886f46b0336b"
diff --git a/recipes-qt/qt5/qtxmlpatterns_git.bb b/recipes-qt/qt5/qtxmlpatterns_git.bb
index a1bef7a5..7b61d2c2 100644
--- a/recipes-qt/qt5/qtxmlpatterns_git.bb
+++ b/recipes-qt/qt5/qtxmlpatterns_git.bb
@@ -14,7 +14,7 @@ LIC_FILES_CHKSUM = " \
DEPENDS += "qtbase"
-SRCREV = "dbc1311af757c5acdca034d3632dca3bf1f81af5"
+SRCREV = "bb3d518fea63cc834fe2b5654c3ac8bf7d2771f6"
BBCLASSEXTEND =+ "native nativesdk"