aboutsummaryrefslogtreecommitdiffstats
path: root/recipes-qt
diff options
context:
space:
mode:
authorOtavio Salvador <otavio@ossystems.com.br>2012-10-23 15:51:25 -0200
committerOtavio Salvador <otavio@ossystems.com.br>2012-10-23 15:51:25 -0200
commit4927bd8c5675151188efa8b4d36bba9640ee3556 (patch)
treef59248184a24ecc5397038f144c441aab56b69bc /recipes-qt
parentec0ac6e5b1682b7a448eb50666cb8330928c9d74 (diff)
qt5-native: Add initial draft
Signed-off-by: Otavio Salvador <otavio@ossystems.com.br>
Diffstat (limited to 'recipes-qt')
-rw-r--r--recipes-qt/qt5/qt5-native.inc49
-rw-r--r--recipes-qt/qt5/qt5-native_5.0.0.bb6
-rw-r--r--recipes-qt/qt5/qt5.inc8
3 files changed, 63 insertions, 0 deletions
diff --git a/recipes-qt/qt5/qt5-native.inc b/recipes-qt/qt5/qt5-native.inc
new file mode 100644
index 00000000..f46817d3
--- /dev/null
+++ b/recipes-qt/qt5/qt5-native.inc
@@ -0,0 +1,49 @@
+DESCRIPTION = "Native version of Qt/[X11|Mac|Embedded]"
+DEPENDS = "zlib-native dbus-native"
+SECTION = "libs"
+HOMEPAGE = "http://qt-project.org"
+PROVIDES = "qt5-tools-native"
+
+LICENSE = "LGPLv2.1 | GPLv3"
+LIC_FILES_CHKSUM = "file://LICENSE.LGPL;md5=cc5963be04f8b19c3e3c46bc31f0f6e1 \
+ file://LICENSE.GPL;md5=d32239bcb673463ab874e80d47fae504 \
+ file://LGPL_EXCEPTION.txt;md5=411080a56ff917a5a1aa08c98acae354"
+
+INC_PR = "r0"
+
+include qt5.inc
+
+inherit native
+
+QT_MODULE = "qtbase"
+
+EXTRA_OECONF = "-prefix ${prefix} \
+ -L ${STAGING_LIBDIR_NATIVE} \
+ -I ${STAGING_INCDIR_NATIVE} \
+ -system-zlib \
+ -no-libjpeg \
+ -no-libpng \
+ -no-gif \
+ -no-accessibility \
+ -no-cups \
+ -no-nis \
+ -no-gui \
+ -no-qml-debug \
+ -no-sql-mysql \
+ -no-sql-sqlite \
+ -no-opengl \
+ -no-openssl \
+ -verbose -release \
+ -headerdir ${includedir}/qt5 \
+ -no-glib \
+ -no-iconv \
+ -no-fast \
+ -silent \
+ -no-rpath"
+
+do_configure() {
+ # Avoid setting QMAKE_LINK from LD (since we want the linker to be g++)
+ unset LD
+
+ (echo o; echo yes) | ./configure ${EXTRA_OECONF} || die "Configuring qt failed. EXTRA_OECONF was ${EXTRA_OECONF}"
+}
diff --git a/recipes-qt/qt5/qt5-native_5.0.0.bb b/recipes-qt/qt5/qt5-native_5.0.0.bb
new file mode 100644
index 00000000..a3e5e769
--- /dev/null
+++ b/recipes-qt/qt5/qt5-native_5.0.0.bb
@@ -0,0 +1,6 @@
+require qt5-native.inc
+
+PR = "${INC_PR}.0"
+
+SRC_URI[md5sum] = "2e1e5198a3a139099bfefe75ed29e043"
+SRC_URI[sha256sum] = "d1a6b06fb3d44e83bbd5b7fe5bc1177ff437f992efafe0154cf37b18cfa87109"
diff --git a/recipes-qt/qt5/qt5.inc b/recipes-qt/qt5/qt5.inc
new file mode 100644
index 00000000..ff5f2b1c
--- /dev/null
+++ b/recipes-qt/qt5/qt5.inc
@@ -0,0 +1,8 @@
+# Copyright (C) 2012 O.S. Systems Software LTDA.
+
+QT_MODULE ?= "${PN}"
+QT_VERSION ?= "${PV}-beta1"
+
+SRC_URI = "http://releases.qt-project.org/qt5.0/beta1/split_sources/${QT_MODULE}-opensource-src-${QT_VERSION}.tar.xz"
+
+S = "${WORKDIR}/${QT_MODULE}-opensource-src-${QT_VERSION}"