aboutsummaryrefslogtreecommitdiffstats
path: root/recipes-qt
diff options
context:
space:
mode:
authorSamuli Piippo <samuli.piippo@qt.io>2018-03-02 16:00:14 +0200
committerSamuli Piippo <samuli.piippo@qt.io>2018-03-06 07:24:15 +0000
commit4f1e157da16e615a79903abc7363799eac2670c7 (patch)
tree01dc2a0ac42494c1d2bd7aa59711486b1a095a66 /recipes-qt
parentce85883673e134947addf3d6859b2b79815e49cd (diff)
Add recipe for Qt WebGL Streaming Plugin
Stream applications to browsers over the network. Change-Id: I1e5a10e9b48420704e4dab5e6c1589df64236dce Reviewed-by: Mikko Gronoff <mikko.gronoff@qt.io>
Diffstat (limited to 'recipes-qt')
-rw-r--r--recipes-qt/qt5/qtwebglplugin_git.bb21
1 files changed, 21 insertions, 0 deletions
diff --git a/recipes-qt/qt5/qtwebglplugin_git.bb b/recipes-qt/qt5/qtwebglplugin_git.bb
new file mode 100644
index 00000000..d43d7149
--- /dev/null
+++ b/recipes-qt/qt5/qtwebglplugin_git.bb
@@ -0,0 +1,21 @@
+require qt5.inc
+require qt5-git.inc
+
+LICENSE = "GPL-3.0 | The-Qt-Company-Commercial"
+LIC_FILES_CHKSUM = " \
+ file://LICENSE.GPL3;md5=d32239bcb673463ab874e80d47fae504 \
+"
+
+DEPENDS += "qtbase qtwebsockets"
+
+PACKAGECONFIG ?= "qtdeclarative"
+PACKAGECONFIG[qtdeclarative] = ",,qtdeclarative"
+
+do_configure_prepend() {
+ # disable qtdeclarative test if it isn't enabled by PACKAGECONFIG
+ sed -e 's/^\(qtHaveModule(quick)\)/OE_QTDECLARATIVE_ENABLED:\1/' -i ${S}/src/plugins/platforms/webgl/webgl.pro
+}
+
+EXTRA_QMAKEVARS_PRE += "${@bb.utils.contains('PACKAGECONFIG', 'qtdeclarative', 'CONFIG+=OE_QTDECLARATIVE_ENABLED', '', d)}"
+
+SRCREV = "d73338df3809c8551f387c7192725683d52746d8"