aboutsummaryrefslogtreecommitdiffstats
path: root/recipes-qt
diff options
context:
space:
mode:
authorSamuli Piippo <samuli.piippo@qt.io>2017-05-08 13:37:54 +0300
committerSamuli Piippo <samuli.piippo@qt.io>2017-05-08 13:32:17 +0000
commit7c0e98422ea79751889cf36fa62bb2f878401efc (patch)
treef677a7dd3c4c825ba6b4fa6db45eac4b9c8ea2db /recipes-qt
parent3d9c554e66f2e6f6eaf8b94d6b1e2bfb34eeae0a (diff)
qt3d: update tools-only patch to work with latest 5.9.0 revision
Change-Id: I04f7342f7aae654e7d957f834c72b12c14eddf8a Reviewed-by: Mikko Gronoff <mikko.gronoff@qt.io> Reviewed-by: Samuli Piippo <samuli.piippo@qt.io>
Diffstat (limited to 'recipes-qt')
-rw-r--r--recipes-qt/qt5/qt3d/0001-Allow-a-tools-only-build.patch16
-rw-r--r--recipes-qt/qt5/qt3d_git.bb2
2 files changed, 15 insertions, 3 deletions
diff --git a/recipes-qt/qt5/qt3d/0001-Allow-a-tools-only-build.patch b/recipes-qt/qt5/qt3d/0001-Allow-a-tools-only-build.patch
index b19f963e..248fb473 100644
--- a/recipes-qt/qt5/qt3d/0001-Allow-a-tools-only-build.patch
+++ b/recipes-qt/qt5/qt3d/0001-Allow-a-tools-only-build.patch
@@ -1,12 +1,14 @@
-From 64f46f5399627430f9ce1a888fb9212b33977231 Mon Sep 17 00:00:00 2001
+From b3fbc6be8844cf2eb8a47d39b1b7ce8016ce5d52 Mon Sep 17 00:00:00 2001
From: Samuli Piippo <samuli.piippo@theqtcompany.com>
Date: Wed, 10 Feb 2016 09:02:09 +0200
Subject: [PATCH] Allow a tools-only build
+Change-Id: I4de6b96ec51fe297a0eeb757cef56d8fb40bd6f0
---
qt3d.pro | 7 ++++++-
src/3rdparty/assimp/assimp_dependency.pri | 2 +-
- 2 files changed, 7 insertions(+), 2 deletions(-)
+ tools/tools.pro | 2 +-
+ 3 files changed, 8 insertions(+), 3 deletions(-)
diff --git a/qt3d.pro b/qt3d.pro
index 2cc347a..81cdeef 100644
@@ -38,3 +40,13 @@ index 8ba2d9a..e973d93 100644
QMAKE_USE_PRIVATE += assimp
} else {
include(assimp.pri)
+diff --git a/tools/tools.pro b/tools/tools.pro
+index 8e973ae..ad51db5 100644
+--- a/tools/tools.pro
++++ b/tools/tools.pro
+@@ -1,4 +1,4 @@
+ TEMPLATE = subdirs
+ QT_FOR_CONFIG += 3dcore-private
+-!android:qtConfig(assimp):qtConfig(commandlineparser): \
++!android:tools-only|qtConfig(assimp):qtConfig(commandlineparser): \
+ SUBDIRS += qgltf
diff --git a/recipes-qt/qt5/qt3d_git.bb b/recipes-qt/qt5/qt3d_git.bb
index 3bcbf66a..43e86ef9 100644
--- a/recipes-qt/qt5/qt3d_git.bb
+++ b/recipes-qt/qt5/qt3d_git.bb
@@ -34,6 +34,6 @@ do_configure_prepend() {
${S}/src/quick3d/imports/input/importsinput.pro
}
-SRCREV = "a2b7483fa18e109011246fba5e7963338a77af56"
+SRCREV = "bb0f4b48390b5ddc9758f04f6ecd692072fb279f"
BBCLASSEXTEND += "native nativesdk"