aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--recipes-qt/qt5/qt5-creator/0001-Fix-interface-of-propertyNameListForWritableProperti.patch52
-rw-r--r--recipes-qt/qt5/qt5-creator_git.bb1
2 files changed, 53 insertions, 0 deletions
diff --git a/recipes-qt/qt5/qt5-creator/0001-Fix-interface-of-propertyNameListForWritableProperti.patch b/recipes-qt/qt5/qt5-creator/0001-Fix-interface-of-propertyNameListForWritableProperti.patch
new file mode 100644
index 00000000..d1faaab4
--- /dev/null
+++ b/recipes-qt/qt5/qt5-creator/0001-Fix-interface-of-propertyNameListForWritableProperti.patch
@@ -0,0 +1,52 @@
+From da429a57a077183d86fe9a4adcb453c07d11e812 Mon Sep 17 00:00:00 2001
+From: Jani Suonpera <jani.suonpera@qt.io>
+Date: Wed, 15 Sep 2021 13:54:30 +0300
+Subject: [PATCH] Fix interface of propertyNameListForWritablePropertie
+
+There are show compiling error:
+Compiling error:
+|build/tmp/work/armv7vet2hf-neon-poky-linux-gnueabi/qt5-creator/4.15.0+gitAUTOINC+978f6caf1e-r0/git/share/qtcreator/qml/qmlpuppet/qmlprivategate/qmlprivategate_56.cpp: In function 'QmlDesigner::PropertyNameList QmlDesigner::Internal::QmlPrivateGate::propertyNameListForWritableProperties(QObject*, const PropertyName&, QObjectList*)':
+| build/tmp/work/armv7vet2hf-neon-poky-linux-gnueabi/qt5-creator/4.15.0+gitAUTOINC+978f6caf1e-r0/git/share/qtcreator/qml/qmlpuppet/qmlprivategate/qmlprivategate_56.cpp:156:117: error: no matching function for call to 'QQuickDesignerSupportProperties::propertyNameListForWritableProperties(QObject*&, const PropertyName&, QObjectList*&)'
+| 156 | return QQuickDesignerSupportProperties::propertyNameListForWritableProperties(object, baseName, inspectedObjects);
+
+This is cause of interface changes. There are drop out parameters
+baseName and inspectedObjects from
+QQuickDesignerSupportProperties::propertyNameListForWritableProperties.
+---
+ .../qtcreator/qml/qmlpuppet/qmlprivategate/qmlprivategate.h | 4 +---
+ .../qml/qmlpuppet/qmlprivategate/qmlprivategate_56.cpp | 6 ++----
+ 2 files changed, 3 insertions(+), 7 deletions(-)
+
+diff --git a/share/qtcreator/qml/qmlpuppet/qmlprivategate/qmlprivategate.h b/share/qtcreator/qml/qmlpuppet/qmlprivategate/qmlprivategate.h
+index b0b68907ed..e600db3c60 100644
+--- a/share/qtcreator/qml/qmlpuppet/qmlprivategate/qmlprivategate.h
++++ b/share/qtcreator/qml/qmlpuppet/qmlprivategate/qmlprivategate.h
+@@ -68,9 +68,7 @@ public:
+ QObject *createComponent(const QUrl &componentUrl, QQmlContext *context);
+ void tweakObjects(QObject *object);
+ bool isPropertyBlackListed(const QmlDesigner::PropertyName &propertyName);
+- PropertyNameList propertyNameListForWritableProperties(QObject *object,
+- const PropertyName &baseName = PropertyName(),
+- QObjectList *inspectedObjects = nullptr);
++ PropertyNameList propertyNameListForWritableProperties(QObject *object);
+ PropertyNameList allPropertyNames(QObject *object,
+ const PropertyName &baseName = PropertyName(),
+ QObjectList *inspectedObjects = nullptr);
+diff --git a/share/qtcreator/qml/qmlpuppet/qmlprivategate/qmlprivategate_56.cpp b/share/qtcreator/qml/qmlpuppet/qmlprivategate/qmlprivategate_56.cpp
+index d41323e310..52a3f5fb28 100644
+--- a/share/qtcreator/qml/qmlpuppet/qmlprivategate/qmlprivategate_56.cpp
++++ b/share/qtcreator/qml/qmlpuppet/qmlprivategate/qmlprivategate_56.cpp
+@@ -65,11 +65,9 @@ PropertyNameList allPropertyNames(QObject *object,
+ return QQuickDesignerSupportProperties::allPropertyNames(object, baseName, inspectedObjects);
+ }
+
+-PropertyNameList propertyNameListForWritableProperties(QObject *object,
+- const PropertyName &baseName,
+- QObjectList *inspectedObjects)
++PropertyNameList propertyNameListForWritableProperties(QObject *object)
+ {
+- return QQuickDesignerSupportProperties::propertyNameListForWritableProperties(object, baseName, inspectedObjects);
++ return QQuickDesignerSupportProperties::propertyNameListForWritableProperties(object);
+ }
+
+ void tweakObjects(QObject *object)
diff --git a/recipes-qt/qt5/qt5-creator_git.bb b/recipes-qt/qt5/qt5-creator_git.bb
index f8d4aa1d..36d59cae 100644
--- a/recipes-qt/qt5/qt5-creator_git.bb
+++ b/recipes-qt/qt5/qt5-creator_git.bb
@@ -24,6 +24,7 @@ PV = "4.13.1+git${SRCPV}"
SRC_URI = " \
git://code.qt.io/qt-creator/qt-creator.git;branch=4.13 \
file://0001-app-Use-malloc_trim-only-on-glibc.patch \
+ file://0001-Fix-interface-of-propertyNameListForWritableProperti.patch \
"
SRC_URI_append_libc-musl = " file://0001-Link-with-libexecinfo-on-musl.patch"