aboutsummaryrefslogtreecommitdiffstats
path: root/recipes-python/pyqtchart/python3-pyqtchart_5.15.1.bb
diff options
context:
space:
mode:
Diffstat (limited to 'recipes-python/pyqtchart/python3-pyqtchart_5.15.1.bb')
-rw-r--r--recipes-python/pyqtchart/python3-pyqtchart_5.15.1.bb14
1 files changed, 7 insertions, 7 deletions
diff --git a/recipes-python/pyqtchart/python3-pyqtchart_5.15.1.bb b/recipes-python/pyqtchart/python3-pyqtchart_5.15.1.bb
index c6cd2ff6..0bb84fe0 100644
--- a/recipes-python/pyqtchart/python3-pyqtchart_5.15.1.bb
+++ b/recipes-python/pyqtchart/python3-pyqtchart_5.15.1.bb
@@ -2,7 +2,7 @@ SUMMARY = "Python Qt Chart Bindings"
AUTHOR = "Adrian.Fiergolski@fastree3d.com"
HOMEPAGE = "https://www.riverbankcomputing.com/software/pyqtchart"
SECTION = "devel/python"
-LICENSE = "GPLv3"
+LICENSE = "GPL-3.0-only"
LIC_FILES_CHKSUM = "\
file://LICENSE;md5=d32239bcb673463ab874e80d47fae504 \
"
@@ -20,7 +20,7 @@ inherit qmake5
inherit python3native python3-dir
DEPENDS = "qtcharts"
-DEPENDS += "sip3 sip3-native python3 python3-pyqt5"
+DEPENDS += "sip sip-native python3 python3-pyqt5"
export BUILD_SYS
export HOST_SYS
@@ -31,7 +31,7 @@ PARALLEL_MAKEINST = ""
DISABLED_FEATURES = "PyQt_Desktop_OpenGL PyQt_Accessibility PyQt_SessionManager"
-do_configure_prepend() {
+do_configure:prepend() {
cd ${S}
echo "[PyQt 5]" > pyqt.cfg
echo "py_platform = linux" >> pyqt.cfg
@@ -44,7 +44,7 @@ do_configure_prepend() {
echo yes | ${PYTHON} configure.py --verbose --qmake ${STAGING_BINDIR_NATIVE}/${QT_DIR_NAME}/qmake --configuration pyqt.cfg --sysroot ${STAGING_DIR_HOST}
}
-do_configure_append() {
+do_configure:append() {
#Fix installation paths
sed -i -e s:'$(INSTALL_ROOT)'${STAGING_EXECPREFIXDIR}:'$(INSTALL_ROOT)'${D}${exec_prefix}:g ${S}/Makefile
sed -i -e s:'$(INSTALL_ROOT)'${STAGING_EXECPREFIXDIR}:'$(INSTALL_ROOT)'${D}${exec_prefix}:g ${S}/QtChart/Makefile
@@ -63,7 +63,7 @@ do_install() {
}
-FILES_${PN} += "${libdir}/${PYTHON_DIR}/site-packages ${datadir}/"
+FILES:${PN} += "${libdir}/${PYTHON_DIR}/site-packages ${datadir}/"
-RDEPENDS_${PN} = "qtbase qtdeclarative qtquickcontrols2 qtquickcontrols2-mkspecs qtcharts"
-RDEPENDS_${PN} += "python3-core python3-sip3 python3-pyqt5"
+RDEPENDS:${PN} = "qtbase qtdeclarative qtquickcontrols2 qtquickcontrols2-mkspecs qtcharts"
+RDEPENDS:${PN} += "python3-core sip python3-pyqt5"