aboutsummaryrefslogtreecommitdiffstats
path: root/recipes-qt/maliit/maliit-framework-qt5_git.bb
diff options
context:
space:
mode:
Diffstat (limited to 'recipes-qt/maliit/maliit-framework-qt5_git.bb')
-rw-r--r--recipes-qt/maliit/maliit-framework-qt5_git.bb36
1 files changed, 16 insertions, 20 deletions
diff --git a/recipes-qt/maliit/maliit-framework-qt5_git.bb b/recipes-qt/maliit/maliit-framework-qt5_git.bb
index 1f0dc8d6..1df83e7c 100644
--- a/recipes-qt/maliit/maliit-framework-qt5_git.bb
+++ b/recipes-qt/maliit/maliit-framework-qt5_git.bb
@@ -1,12 +1,12 @@
DESCRIPTION = "A virtual keyboard for touch-screen based user interfaces"
HOMEPAGE = "https://wiki.maliit.org/Main_Page"
-LICENSE = "LGPLv2.1"
+LICENSE = "LGPL-2.1-only"
LIC_FILES_CHKSUM = "file://LICENSE.LGPL;md5=5c917f6ce94ceb8d8d5e16e2fca5b9ad"
-inherit qmake5 qmake5_paths
+inherit qmake5 qmake5_paths pkgconfig
-SRC_URI = "git://github.com/maliit/framework.git;branch=master \
+SRC_URI = "git://github.com/maliit/framework.git;branch=master;protocol=https \
file://0001-Fix-MALIIT_INSTALL_PRF-to-allow-the-build-with-opene.patch \
file://maliit-server.desktop \
file://0001-config.pri-Use-O1-optimization-in-DEBUG-flags.patch \
@@ -24,9 +24,9 @@ GTKIMMODULES_PACKAGES = "${PN}-gtk"
DEPENDS = "qtdeclarative"
-RRECOMMENDS_${PN} = "maliit-plugins-qt5"
+RRECOMMENDS:${PN} = "maliit-plugins-qt5"
-FILES_${PN} += "\
+FILES:${PN} += "\
${libdir}/*.so* \
${bindir} \
${datadir}/applications/maliit-server.desktop \
@@ -34,11 +34,11 @@ FILES_${PN} += "\
${OE_QMAKE_PATH_PLUGINS}/platforminputcontexts \
"
-FILES_${PN}-dbg += "\
+FILES:${PN}-dbg += "\
${libdir}/maliit-framework-tests \
"
-FILES_${PN}-dev += "\
+FILES:${PN}-dev += "\
${includedir}/maliit \
${libdir}/pkgconfig \
${OE_QMAKE_PATH_QT_ARCHDATA}/mkspecs \
@@ -61,12 +61,12 @@ EXTRA_QMAKEVARS_PRE = "\
CONFIG+=qt5-inputcontext \
"
-# tests fail to build with clang
-EXTRA_QMAKEVARS_PRE_append_toolchain-clang = " CONFIG+=notests"
+# tests fail to build with gcc12/clang
+EXTRA_QMAKEVARS_PRE:append = " CONFIG+=notests"
EXTRA_OEMAKE += "INSTALL_ROOT=${D}"
-do_install_append() {
+do_install:append() {
#Fix absolute paths
sed -i -e "s|/usr|${STAGING_DIR_TARGET}${prefix}|" ${D}/${OE_QMAKE_PATH_QT_ARCHDATA}/mkspecs/features/maliit-framework.prf
sed -i -e "s|/usr|${STAGING_DIR_TARGET}${prefix}|" ${D}/${OE_QMAKE_PATH_QT_ARCHDATA}/mkspecs/features/maliit-plugins.prf
@@ -75,26 +75,22 @@ do_install_append() {
install -m 644 ${WORKDIR}/maliit-server.desktop ${D}${datadir}/applications
}
-pkg_postinst_${PN} () {
+pkg_postinst_ontarget:${PN} () {
#!/bin/sh
# should run online
-if [ "x$D" != "x" ]; then
- exit 1
-fi
echo "export QT_IM_MODULE=Maliit" >> /etc/xprofile
ln -s /usr/share/applications/maliit-server.desktop /etc/xdg/autostart/maliit-server.desktop
}
-pkg_postrm_${PN} () {
+pkg_postrm:${PN} () {
#!/bin/sh
# should run online
if [ "x$D" = "x" ]; then
- exit 1
-fi
-if [ -e "/etc/xprofile" ]; then
- sed -i -e "g|export QT_IM_MODULE=Maliit|d" /etc/xprofile
+ if [ -e "/etc/xprofile" ]; then
+ sed -i -e "g|export QT_IM_MODULE=Maliit|d" /etc/xprofile
+ fi
+ rm -f /etc/xdg/autostart/maliit-server.desktop
fi
-rm -f /etc/xdg/autostart/maliit-server.desktop
}
S = "${WORKDIR}/git"