aboutsummaryrefslogtreecommitdiffstats
path: root/recipes-qt/maliit
diff options
context:
space:
mode:
Diffstat (limited to 'recipes-qt/maliit')
-rw-r--r--recipes-qt/maliit/maliit-framework-qt5_git.bb6
-rw-r--r--recipes-qt/maliit/maliit-plugins-qt5_git.bb6
2 files changed, 6 insertions, 6 deletions
diff --git a/recipes-qt/maliit/maliit-framework-qt5_git.bb b/recipes-qt/maliit/maliit-framework-qt5_git.bb
index ebad8ccd..1df83e7c 100644
--- a/recipes-qt/maliit/maliit-framework-qt5_git.bb
+++ b/recipes-qt/maliit/maliit-framework-qt5_git.bb
@@ -1,7 +1,7 @@
DESCRIPTION = "A virtual keyboard for touch-screen based user interfaces"
HOMEPAGE = "https://wiki.maliit.org/Main_Page"
-LICENSE = "LGPLv2.1"
+LICENSE = "LGPL-2.1-only"
LIC_FILES_CHKSUM = "file://LICENSE.LGPL;md5=5c917f6ce94ceb8d8d5e16e2fca5b9ad"
inherit qmake5 qmake5_paths pkgconfig
@@ -61,8 +61,8 @@ EXTRA_QMAKEVARS_PRE = "\
CONFIG+=qt5-inputcontext \
"
-# tests fail to build with clang
-EXTRA_QMAKEVARS_PRE:append:toolchain-clang = " CONFIG+=notests"
+# tests fail to build with gcc12/clang
+EXTRA_QMAKEVARS_PRE:append = " CONFIG+=notests"
EXTRA_OEMAKE += "INSTALL_ROOT=${D}"
diff --git a/recipes-qt/maliit/maliit-plugins-qt5_git.bb b/recipes-qt/maliit/maliit-plugins-qt5_git.bb
index eb878199..d0576415 100644
--- a/recipes-qt/maliit/maliit-plugins-qt5_git.bb
+++ b/recipes-qt/maliit/maliit-plugins-qt5_git.bb
@@ -1,7 +1,7 @@
DESCRIPTION = "Plugins for a virtual keyboard for touch-screen based user interfaces"
HOMEPAGE = "https://wiki.maliit.org/Main_Page"
-LICENSE = "BSD"
+LICENSE = "BSD-3-Clause"
LIC_FILES_CHKSUM = "file://LICENSE;md5=f29b21caa8e460097bfad9c026a33621"
inherit qmake5
@@ -27,8 +27,8 @@ EXTRA_QMAKEVARS_PRE = "\
CONFIG+=nodoc \
"
-# tests fail to build with clang
-EXTRA_QMAKEVARS_PRE:append:toolchain-clang = " CONFIG+=notests"
+# tests fail to build with gcc12/clang
+EXTRA_QMAKEVARS_PRE:append = " CONFIG+=notests"
FILES:${PN} += "\
${libdir}/maliit \