aboutsummaryrefslogtreecommitdiffstats
path: root/recipes-qt/qt5/qt3d_git.bb
diff options
context:
space:
mode:
Diffstat (limited to 'recipes-qt/qt5/qt3d_git.bb')
-rw-r--r--recipes-qt/qt5/qt3d_git.bb29
1 files changed, 20 insertions, 9 deletions
diff --git a/recipes-qt/qt5/qt3d_git.bb b/recipes-qt/qt5/qt3d_git.bb
index d23a2d36..df338b69 100644
--- a/recipes-qt/qt5/qt3d_git.bb
+++ b/recipes-qt/qt5/qt3d_git.bb
@@ -1,7 +1,7 @@
require qt5.inc
-require qt5-git.inc
+require qt5-lts.inc
-LICENSE = "LGPL-3.0 | GPL-2.0 | The-Qt-Company-Commercial"
+LICENSE = "LGPL-3.0-only | GPL-2.0-only | The-Qt-Company-Commercial"
LIC_FILES_CHKSUM = " \
file://LICENSE.LGPLv3;md5=8211fde12cc8a4e2477602f5953f5b71 \
file://LICENSE.GPLv3;md5=88e2b9117e6be406b5ed6ee4ca99a705 \
@@ -9,17 +9,25 @@ LIC_FILES_CHKSUM = " \
"
DEPENDS += "qtbase"
-DEPENDS_class-target += "qtdeclarative qt3d-native"
+DEPENDS:class-target += "qtdeclarative qt3d-native"
-# Patches from https://github.com/meta-qt5/qt3d/commits/b5.12
-# 5.12.meta-qt5.2
+# Patches from https://github.com/meta-qt5/qt3d/commits/b5.15
+# 5.15.meta-qt5.2
SRC_URI += " \
file://0001-Allow-a-tools-only-build.patch \
"
+# For assimp submodule
+SRC_URI += " \
+ git://code.qt.io/qt/qtquick3d-assimp.git;name=assimp;branch=qt6_assimp;protocol=https;destsuffix=git/src/3rdparty/assimp/src \
+"
+
+SRC_URI:append:riscv64 = " file://0001-renderers-opengl-Link-in-libatomic-on-riscv.patch"
+SRC_URI:append:riscv32 = " file://0001-renderers-opengl-Link-in-libatomic-on-riscv.patch"
+
PACKAGECONFIG ??= ""
-PACKAGECONFIG_class-native ??= "tools-only"
-PACKAGECONFIG_class-nativesdk ??= "tools-only"
+PACKAGECONFIG:class-native ??= "tools-only"
+PACKAGECONFIG:class-nativesdk ??= "tools-only"
PACKAGECONFIG[tools-only] = ""
PACKAGECONFIG[system-assimp] = "-feature-system-assimp,-no-feature-system-assimp,assimp"
PACKAGECONFIG[qtgamepad] = ",,qtgamepad"
@@ -29,13 +37,16 @@ EXTRA_QMAKEVARS_CONFIGURE += "${PACKAGECONFIG_CONFARGS}"
EXTRA_QMAKEVARS_PRE += "${@bb.utils.contains('PACKAGECONFIG', 'tools-only', 'CONFIG+=tools-only QMAKE_USE_PRIVATE+=zlib', '', d)}"
EXTRA_QMAKEVARS_PRE += "${@bb.utils.contains('PACKAGECONFIG', 'qtgamepad', 'CONFIG+=OE_QTGAMEPAD_ENABLED', '', d)}"
-do_configure_prepend() {
+do_configure:prepend() {
# disable qtgamepad test if it isn't enabled by PACKAGECONFIG
sed -e 's/^\(qtHaveModule(gamepad)\)/OE_QTGAMEPAD_ENABLED:\1/' -i \
${S}/src/input/frontend/frontend.pri \
${S}/src/quick3d/imports/input/importsinput.pro
}
-SRCREV = "d2c52680884095238ec3859fabaad03157af3985"
+SRCREV_qt3d = "dac2afc9c6cffd42e49030dcafffc1e0a05873b9"
+SRCREV_assimp = "8f0c6b04b2257a520aaab38421b2e090204b69df"
+
+SRCREV_FORMAT = "qt3d_assimp"
BBCLASSEXTEND += "native nativesdk"