aboutsummaryrefslogtreecommitdiffstats
path: root/recipes-qt/qt5/qtbase-native_git.bb
diff options
context:
space:
mode:
Diffstat (limited to 'recipes-qt/qt5/qtbase-native_git.bb')
-rw-r--r--recipes-qt/qt5/qtbase-native_git.bb19
1 files changed, 12 insertions, 7 deletions
diff --git a/recipes-qt/qt5/qtbase-native_git.bb b/recipes-qt/qt5/qtbase-native_git.bb
index e4667dd1..b0435ba9 100644
--- a/recipes-qt/qt5/qtbase-native_git.bb
+++ b/recipes-qt/qt5/qtbase-native_git.bb
@@ -20,20 +20,25 @@ require qt5-native.inc
require qt5-git.inc
# common for qtbase-native, qtbase-nativesdk and qtbase
+# Patches from https://github.com/meta-qt5/qtbase/commits/b5.9-shared
+# 5.9.meta-qt5-shared.2
SRC_URI += "\
file://0001-Add-linux-oe-g-platform.patch \
file://0002-cmake-Use-OE_QMAKE_PATH_EXTERNAL_HOST_BINS.patch \
- file://0002-qlibraryinfo-allow-to-set-qt.conf-from-the-outside-u.patch \
- file://0005-configure-bump-path-length-from-256-to-512-character.patch \
- file://0009-Disable-all-unknown-features-instead-of-erroring-out.patch \
- file://0010-Pretend-Qt5-wasn-t-found-if-OE_QMAKE_PATH_EXTERNAL_H.patch \
+ file://0003-qlibraryinfo-allow-to-set-qt.conf-from-the-outside-u.patch \
+ file://0004-configure-bump-path-length-from-256-to-512-character.patch \
+ file://0005-Disable-all-unknown-features-instead-of-erroring-out.patch \
+ file://0006-Pretend-Qt5-wasn-t-found-if-OE_QMAKE_PATH_EXTERNAL_H.patch \
+ file://0007-Delete-qlonglong-and-qulonglong.patch \
+ file://0008-Replace-pthread_yield-with-sched_yield.patch \
"
# common for qtbase-native and nativesdk-qtbase
+# Patches from https://github.com/meta-qt5/qtbase/commits/b5.9-native
+# 5.9.meta-qt5-native.2
SRC_URI += " \
- file://0011-Always-build-uic.patch \
- file://0012-qdbuscpp2xml.pro-do-not-build-with-bootstrapped-depe.patch \
file://0001-Disable-unnamed-tmp-files.patch \
+ file://0009-Always-build-uic.patch \
"
CLEANBROKEN = "1"
@@ -80,7 +85,7 @@ PACKAGECONFIG_CONFARGS = " \
# for qtbase configuration we need default settings
# since we cannot set empty set filename to a not existent file
-export OE_QMAKE_QTCONF_PATH = "foodummy"
+deltask generate_qt_config_file
do_configure_prepend() {
# Avoid qmake error "Cannot read [...]/usr/lib/qt5/mkspecs/oe-device-extra.pri: No such file or directory"