aboutsummaryrefslogtreecommitdiffstats
path: root/recipes-qt/qt5/qtdeclarative_git.bb
diff options
context:
space:
mode:
Diffstat (limited to 'recipes-qt/qt5/qtdeclarative_git.bb')
-rw-r--r--recipes-qt/qt5/qtdeclarative_git.bb39
1 files changed, 32 insertions, 7 deletions
diff --git a/recipes-qt/qt5/qtdeclarative_git.bb b/recipes-qt/qt5/qtdeclarative_git.bb
index 7b9f70ca..5ade81be 100644
--- a/recipes-qt/qt5/qtdeclarative_git.bb
+++ b/recipes-qt/qt5/qtdeclarative_git.bb
@@ -1,9 +1,9 @@
require qt5.inc
-require qt5-git.inc
+require qt5-lts.inc
require qt5-ptest.inc
HOMEPAGE = "http://www.qt.io"
-LICENSE = "GFDL-1.3 & BSD & ( GPL-3.0 & The-Qt-Company-GPL-Exception-1.0 | The-Qt-Company-Commercial ) & ( GPL-2.0+ | LGPL-3.0 | The-Qt-Company-Commercial )"
+LICENSE = "GFDL-1.3 & BSD-3-Clause & ( GPL-3.0-only & The-Qt-Company-GPL-Exception-1.0 | The-Qt-Company-Commercial ) & ( GPL-2.0-or-later | LGPL-3.0-only | The-Qt-Company-Commercial )"
LIC_FILES_CHKSUM = " \
file://LICENSE.LGPL3;md5=e6a600fd5e1d9cbde2d983680233ad02 \
file://LICENSE.GPL2;md5=b234ee4d69f5fce4486a80fdaf4a4263 \
@@ -12,22 +12,47 @@ LIC_FILES_CHKSUM = " \
file://LICENSE.FDL;md5=6d9f2a9af4c8b8c3c769f6cc1b6aaf7e \
"
-DEPENDS += "qtbase"
-
-SRC_URI += "\
+# Patches from https://github.com/meta-qt5/qtdeclarative/commits/b5.15
+# 5.15.meta-qt5.1
+SRC_URI += " \
file://0001-Use-OE_QMAKE_PATH_EXTERNAL_HOST_BINS-to-locate-qmlca.patch \
"
+LDFLAGS:append:riscv64 = " -pthread"
+
+DEPENDS += "qtbase qtdeclarative-native"
+
PACKAGECONFIG ??= "qml-debug qml-network ${@bb.utils.contains('DISTRO_FEATURES', 'qt5-static', 'static', '', d)}"
PACKAGECONFIG[qml-debug] = "-qml-debug,-no-qml-debug"
PACKAGECONFIG[qml-network] = "-qml-network, -no-qml-network"
PACKAGECONFIG[static] = ",,qtdeclarative-native"
-do_install_append_class-nativesdk() {
+EXTRA_QMAKEVARS_CONFIGURE += "${PACKAGECONFIG_CONFARGS}"
+
+do_install_ptest() {
+ mkdir -p ${D}${PTEST_PATH}
+ for var in `find ${B}/tests/auto/ -name tst_*`; do
+ case=$(basename ${var})
+ if [ -z `echo ${case} | grep '\.'` ]; then
+ dname=$(dirname ${var})
+ pdir=$(basename ${dname})
+ echo ${pdir}/${case} >> ${D}${PTEST_PATH}/tst_list
+
+ mkdir ${D}${PTEST_PATH}/${pdir}
+ install -m 0744 ${var} ${D}${PTEST_PATH}/${pdir}
+ data_dir=${S}/${dname##${B}}/data
+ if [ -d ${data_dir} ]; then
+ cp -r ${data_dir} ${D}${PTEST_PATH}/${pdir}
+ fi
+ fi
+ done
+}
+
+do_install:append:class-nativesdk() {
# qml files not needed in nativesdk
rm -rf ${D}${OE_QMAKE_PATH_QML}
}
-SRCREV = "a02b5d48cf63228ed8faf6abf4724df2c4500269"
+SRCREV = "73eeb35f09fd1ea846bb0f5ce507316f587fda9f"
BBCLASSEXTEND =+ "native nativesdk"