aboutsummaryrefslogtreecommitdiffstats
path: root/recipes-qt/qt5/qtmultimedia_git.bb
diff options
context:
space:
mode:
Diffstat (limited to 'recipes-qt/qt5/qtmultimedia_git.bb')
-rw-r--r--recipes-qt/qt5/qtmultimedia_git.bb12
1 files changed, 7 insertions, 5 deletions
diff --git a/recipes-qt/qt5/qtmultimedia_git.bb b/recipes-qt/qt5/qtmultimedia_git.bb
index 5be578ea..8d90bd9b 100644
--- a/recipes-qt/qt5/qtmultimedia_git.bb
+++ b/recipes-qt/qt5/qtmultimedia_git.bb
@@ -1,7 +1,7 @@
require qt5.inc
require qt5-lts.inc
-LICENSE = "GFDL-1.3 & BSD & ( GPL-3.0 & The-Qt-Company-GPL-Exception-1.0 | The-Qt-Company-Commercial ) & ( GPL-2.0+ | LGPL-3.0 | The-Qt-Company-Commercial )"
+LICENSE = "GFDL-1.3 & BSD-3-Clause & ( GPL-3.0-only & The-Qt-Company-GPL-Exception-1.0 | The-Qt-Company-Commercial ) & ( GPL-2.0-or-later | LGPL-3.0-only | The-Qt-Company-Commercial )"
LIC_FILES_CHKSUM = " \
file://LICENSE.LGPL3;md5=e6a600fd5e1d9cbde2d983680233ad02 \
file://LICENSE.GPL2;md5=b234ee4d69f5fce4486a80fdaf4a4263 \
@@ -12,6 +12,8 @@ LIC_FILES_CHKSUM = " \
DEPENDS += "qtdeclarative"
+inherit pkgconfig
+
PACKAGECONFIG ??= "gstreamer \
${@bb.utils.contains('DISTRO_FEATURES', 'alsa', 'alsa', '', d)} \
${@bb.utils.contains('DISTRO_FEATURES', 'pulseaudio', 'pulseaudio', '', d)}"
@@ -36,12 +38,12 @@ SRC_URI += "\
# The same issue as in qtbase:
# http://errors.yoctoproject.org/Errors/Build/44914/
-LDFLAGS_append_x86 = "${@bb.utils.contains('DISTRO_FEATURES', 'ld-is-gold', ' -fuse-ld=bfd ', '', d)}"
+LDFLAGS:append:x86 = "${@bb.utils.contains('DISTRO_FEATURES', 'ld-is-gold', ' -fuse-ld=bfd ', '', d)}"
-SRCREV = "1994b277bfb5420afbbe814e9cb2ab47e1c45b78"
+SRCREV = "b46203a7c4e4889c76f59e4a72da68a069a8f9c4"
# Temporary work around for Qt5MultimediaConfig.cmake referencing non-existent videoeglvideonode directory
-do_install_append() {
+do_install:append() {
install -d ${D}${OE_QMAKE_PATH_PLUGINS}/videoeglvideonode
}
-FILES_${PN} += "${OE_QMAKE_PATH_PLUGINS}/videoeglvideonode"
+FILES:${PN} += "${OE_QMAKE_PATH_PLUGINS}/videoeglvideonode"