aboutsummaryrefslogtreecommitdiffstats
path: root/recipes-qt/qt5/qtremoteobjects_git.bb
diff options
context:
space:
mode:
Diffstat (limited to 'recipes-qt/qt5/qtremoteobjects_git.bb')
-rw-r--r--recipes-qt/qt5/qtremoteobjects_git.bb16
1 files changed, 8 insertions, 8 deletions
diff --git a/recipes-qt/qt5/qtremoteobjects_git.bb b/recipes-qt/qt5/qtremoteobjects_git.bb
index 8d22d0b5..3dd17b2d 100644
--- a/recipes-qt/qt5/qtremoteobjects_git.bb
+++ b/recipes-qt/qt5/qtremoteobjects_git.bb
@@ -1,4 +1,4 @@
-LICENSE = "BSD & ( GPL-3.0 & The-Qt-Company-GPL-Exception-1.0 ) & ( GPL-2.0+ | LGPL-3.0 ) | The-Qt-Company-Commercial"
+LICENSE = "BSD-3-Clause & ( GPL-3.0-only & The-Qt-Company-GPL-Exception-1.0 ) & ( GPL-2.0-or-later | LGPL-3.0-only ) | The-Qt-Company-Commercial"
LIC_FILES_CHKSUM = " \
file://LICENSE.GPL2;md5=b234ee4d69f5fce4486a80fdaf4a4263 \
file://LICENSE.GPL3;md5=d32239bcb673463ab874e80d47fae504 \
@@ -7,24 +7,24 @@ LIC_FILES_CHKSUM = " \
"
require qt5.inc
-require qt5-git.inc
+require qt5-lts.inc
DEPENDS += "qtbase qtdeclarative qtremoteobjects-native"
-# Patches from https://github.com/meta-qt5/qtremoteobjects/commits/b5.12
-# 5.12.meta-qt5.2
+# Patches from https://github.com/meta-qt5/qtremoteobjects/commits/b5.15
+# 5.15.meta-qt5.1
SRC_URI += " \
file://0001-Allow-a-tools-only-build.patch \
- file://0001-cmake-Use-OE_QMAKE_PATH_EXTERNAL_HOST_BINS.patch \
+ file://0002-cmake-Use-OE_QMAKE_PATH_EXTERNAL_HOST_BINS.patch \
"
PACKAGECONFIG ??= ""
-PACKAGECONFIG_class-native ??= "tools-only"
-PACKAGECONFIG_class-nativesdk ??= "tools-only"
+PACKAGECONFIG:class-native ??= "tools-only"
+PACKAGECONFIG:class-nativesdk ??= "tools-only"
PACKAGECONFIG[tools-only] = "CONFIG+=tools-only"
EXTRA_QMAKEVARS_PRE += "${PACKAGECONFIG_CONFARGS}"
-SRCREV = "35516bfec49c5da9b0e6bcd0731bb5d5b7983944"
+SRCREV = "e006bf7ec70e4e1617810667f992aa3f9b01cd0f"
BBCLASSEXTEND += "native nativesdk"