aboutsummaryrefslogtreecommitdiffstats
path: root/recipes-qt/qt5/qttools_git.bb
diff options
context:
space:
mode:
Diffstat (limited to 'recipes-qt/qt5/qttools_git.bb')
-rw-r--r--recipes-qt/qt5/qttools_git.bb16
1 files changed, 11 insertions, 5 deletions
diff --git a/recipes-qt/qt5/qttools_git.bb b/recipes-qt/qt5/qttools_git.bb
index 6252ae4e..16ccb78e 100644
--- a/recipes-qt/qt5/qttools_git.bb
+++ b/recipes-qt/qt5/qttools_git.bb
@@ -11,13 +11,13 @@ LIC_FILES_CHKSUM = " \
file://LICENSE.FDL;md5=6d9f2a9af4c8b8c3c769f6cc1b6aaf7e \
"
-DEPENDS += "qtbase qtdeclarative qtxmlpatterns chrpath-replacement-native"
-EXTRANATIVEPATH += "chrpath-native"
+DEPENDS += "qtbase qtdeclarative qtxmlpatterns"
# Patches from https://github.com/meta-qt5/qttools/commits/b5.13
# 5.13.meta-qt5.1
SRC_URI += " \
file://0001-add-noqtwebkit-configuration.patch \
file://0002-linguist-tools-cmake-allow-overriding-the-location-f.patch \
+ file://0003-src.pro-Add-option-noqdoc-to-disable-qdoc-builds.patch \
"
FILES_${PN}-tools += "${datadir}${QT_DIR_NAME}/phrasebooks"
@@ -29,10 +29,19 @@ PACKAGECONFIG_append_toolchain-clang = " clang"
PACKAGECONFIG[qtwebkit] = ",,qtwebkit"
PACKAGECONFIG[clang] = ",,clang"
+COMPATIBLE_HOST_toolchain-clang_riscv32 = "null"
+COMPATIBLE_HOST_toolchain-clang_riscv64 = "null"
+
export YOCTO_ALTERNATE_EXE_PATH = "${STAGING_BINDIR}/llvm-config"
+TOOLSTOBUILD += "linguist/lconvert linguist/lrelease linguist/lupdate pixeltool qtdiag qtpaths qtplugininfo"
+TOOLSTOBUILD += "${@bb.utils.contains('PACKAGECONFIG', 'clang', 'qdoc', '', d)}"
+TOOLSFORTARGET = "pixeltool qtdiag qtpaths qtplugininfo"
+TOOLSFORHOST = "linguist ${@bb.utils.contains('PACKAGECONFIG', 'clang', 'qdoc', '', d)}"
+
EXTRA_QMAKEVARS_PRE += " \
${@bb.utils.contains('PACKAGECONFIG', 'qtwebkit', '', 'CONFIG+=noqtwebkit', d)} \
+ ${@bb.utils.contains('PACKAGECONFIG', 'clang', 'CONFIG+=disable_external_rpath', 'CONFIG+=noqdoc', d)} \
"
EXTRA_QMAKEVARS_PRE_append_class-native = " CONFIG+=config_clang_done CONFIG-=config_clang"
EXTRA_QMAKEVARS_PRE_append_class-nativesdk = " CONFIG+=config_clang_done CONFIG-=config_clang"
@@ -44,6 +53,3 @@ SRCREV = "4dcc7a3d10a223ddd111eaaac6665609add7c46f"
BBCLASSEXTEND = "native nativesdk"
-do_install_append_toolchain-clang() {
- chrpath --delete ${D}${bindir}/qdoc
-}