aboutsummaryrefslogtreecommitdiffstats
path: root/recipes-qt/qt5/qtwebkit_git.bb
diff options
context:
space:
mode:
Diffstat (limited to 'recipes-qt/qt5/qtwebkit_git.bb')
-rw-r--r--recipes-qt/qt5/qtwebkit_git.bb23
1 files changed, 15 insertions, 8 deletions
diff --git a/recipes-qt/qt5/qtwebkit_git.bb b/recipes-qt/qt5/qtwebkit_git.bb
index a10346f4..fc9ca922 100644
--- a/recipes-qt/qt5/qtwebkit_git.bb
+++ b/recipes-qt/qt5/qtwebkit_git.bb
@@ -16,12 +16,16 @@ SRC_URI += "\
file://0002-Fix-build-with-non-glibc-libc-on-musl.patch \
file://0003-Fix-build-bug-for-armv32-BE.patch \
file://0004-PlatformQt.cmake-Do-not-generate-hardcoded-include-p.patch \
- file://0005-Riscv-Add-support-for-riscv.patch \
- file://0006-Fix-build-with-bison37.patch \
- file://0007-Disable-code-related-to-HTTP-2-when-Qt-is-configured.patch \
- file://0008-Fix-compilation-with-Python-3.9-avoid-passing-encodi.patch \
+ file://0005-Fix-build-with-bison37.patch \
+ file://0006-Disable-code-related-to-HTTP-2-when-Qt-is-configured.patch \
+ file://0007-Fix-compilation-with-Python-3.9-avoid-passing-encodi.patch \
+ file://0008-Fix-build-with-icu-68.patch \
+ file://0009-Riscv-Add-support-for-riscv.patch \
"
+SRC_URI_append_riscv32 = " file://0010-webdriver-libatomic.patch "
+SRC_URI_append_riscv64 = " file://0010-webdriver-libatomic.patch "
+
inherit cmake_qt5 perlnative
inherit python3native
@@ -58,14 +62,17 @@ EXTRA_OECMAKE += " \
EXTRA_OECMAKE_append_toolchain-clang = " -DCMAKE_CXX_IMPLICIT_INCLUDE_DIRECTORIES:PATH='${STAGING_INCDIR}'"
# JIT not supported on MIPS/PPC/RISCV
-EXTRA_OECMAKE_append_mipsarch = " -DENABLE_JIT=OFF -DENABLE_C_LOOP=ON "
-EXTRA_OECMAKE_append_powerpc = " -DENABLE_JIT=OFF -DENABLE_C_LOOP=ON "
-EXTRA_OECMAKE_append_riscv64 = " -DENABLE_JIT=OFF -DENABLE_C_LOOP=ON "
+EXTRA_OECMAKE_append_mipsarch = " -DENABLE_JIT=OFF -DUSE_SYSTEM_MALLOC=ON -DENABLE_C_LOOP=ON "
+EXTRA_OECMAKE_append_powerpc = " -DENABLE_JIT=OFF -DUSE_SYSTEM_MALLOC=ON -DENABLE_C_LOOP=ON "
+EXTRA_OECMAKE_append_powerpc64le = " -DENABLE_JIT=OFF -DUSE_SYSTEM_MALLOC=ON -DENABLE_C_LOOP=ON "
+EXTRA_OECMAKE_append_riscv64 = " -DENABLE_JIT=OFF -DUSE_SYSTEM_MALLOC=ON -DENABLE_C_LOOP=ON "
# Disable gold on mips64/clang
# mips64-yoe-linux-musl-ld.gold: internal error in get_got_page_offset, at ../../gold/mips.cc:6260
# mips-yoe-linux-musl-ld.gold: error: Can't find matching LO16 reloc
-EXTRA_OECMAKE_append_toolchain-clang_mipsarch = " -DUSE_LD_GOLD=OFF "
+EXTRA_OECMAKE_append_mipsarch = " -DUSE_LD_GOLD=OFF "
+EXTRA_OECMAKE_append_powerpc = " -DUSE_LD_GOLD=OFF "
+EXTRA_OECMAKE_append_riscv64 = " -DUSE_LD_GOLD=OFF "
PACKAGECONFIG ??= "qtlocation qtmultimedia qtsensors qtwebchannel \
${@bb.utils.filter('DISTRO_FEATURES', 'x11', d)} \