aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorSamuli Piippo <samuli.piippo@qt.io>2021-02-09 10:54:14 +0200
committerMikko Gronoff <mikko.gronoff@qt.io>2021-02-15 15:31:41 +0200
commit2faae9d515d77323ba2bcbf52075d37839b9aba2 (patch)
tree1e4d2ca8a686acfc0cd87c00a78df122acd4e5a0
parente4624bdb8ea440eeaded2ae9999d6ce3fa6aec7c (diff)
qt6: update submodulesv6.1.0-alpha
Update to the 6.1 Alpha. Task-number: QTBUG-90009 Change-Id: Ia7aac87d92197a7981f32ae7758cddfdc4c5d7a2 Reviewed-by: Mikko Gronoff <mikko.gronoff@qt.io>
-rw-r--r--recipes-qt/qt6/qt3d_git.bb6
-rw-r--r--recipes-qt/qt6/qt5compat_git.bb2
-rw-r--r--recipes-qt/qt6/qt6-git.inc2
-rw-r--r--recipes-qt/qt6/qtbase/0002-qlibraryinfo-allow-to-set-qt.conf-from-the-outside-u.patch12
-rw-r--r--recipes-qt/qt6/qtbase_git.bb2
-rw-r--r--recipes-qt/qt6/qtcharts_git.bb2
-rw-r--r--recipes-qt/qt6/qtcoap_git.bb2
-rw-r--r--recipes-qt/qt6/qtdeclarative_git.bb2
-rw-r--r--recipes-qt/qt6/qtdeviceutilities_git.bb2
-rw-r--r--recipes-qt/qt6/qtgraphicaleffects_git.bb2
-rw-r--r--recipes-qt/qt6/qtimageformats_git.bb2
-rw-r--r--recipes-qt/qt6/qtmqtt_git.bb2
-rw-r--r--recipes-qt/qt6/qtnetworkauth_git.bb2
-rw-r--r--recipes-qt/qt6/qtopcua_git.bb2
-rw-r--r--recipes-qt/qt6/qtquick3d_git.bb4
-rw-r--r--recipes-qt/qt6/qtquickcontrols2_git.bb2
-rw-r--r--recipes-qt/qt6/qtquicktimeline_git.bb2
-rw-r--r--recipes-qt/qt6/qtserialbus_git.bb6
-rw-r--r--recipes-qt/qt6/qtserialport_git.bb6
-rw-r--r--recipes-qt/qt6/qtshadertools_git.bb2
-rw-r--r--recipes-qt/qt6/qtspeech_git.bb3
-rw-r--r--recipes-qt/qt6/qtsvg_git.bb2
-rw-r--r--recipes-qt/qt6/qttools_git.bb2
-rw-r--r--recipes-qt/qt6/qttranslations_git.bb2
-rw-r--r--recipes-qt/qt6/qtvirtualkeyboard_git.bb2
-rw-r--r--recipes-qt/qt6/qtwayland_git.bb2
-rw-r--r--recipes-qt/qt6/qtwebsockets_git.bb4
27 files changed, 46 insertions, 35 deletions
diff --git a/recipes-qt/qt6/qt3d_git.bb b/recipes-qt/qt6/qt3d_git.bb
index d9619fc..c95b0cd 100644
--- a/recipes-qt/qt6/qt3d_git.bb
+++ b/recipes-qt/qt6/qt3d_git.bb
@@ -14,7 +14,7 @@ include recipes-qt/qt6/qt6-git.inc
include recipes-qt/qt6/qt6.inc
SRC_URI += " \
- ${QT_GIT}/${QT_GIT_PROJECT}/qtquick3d-assimp.git;name=assimp;branch=upstream/assimp_5.0_release;protocol=${QT_GIT_PROTOCOL};destsuffix=git/src/3rdparty/assimp/src \
+ ${QT_GIT}/${QT_GIT_PROJECT}/qtquick3d-assimp.git;name=assimp;branch=qt6_assimp;protocol=${QT_GIT_PROTOCOL};destsuffix=git/src/3rdparty/assimp/src \
"
DEPENDS = "qtbase qtdeclarative qtshadertools qtshadertools-native"
@@ -25,5 +25,5 @@ PACKAGECONFIG[system-assimp] = "-DFEATURE_system_assimp=ON,-DQT_FEATURE_system_a
PACKAGECONFIG[qtgamepad] = ",,qtgamepad"
SRCREV_FORMAT = "qt3d_assimp"
-SRCREV_qt3d = "cf7127a7897b072af16a78139afc6059e9e7c9a5"
-SRCREV_assimp = "8f0c6b04b2257a520aaab38421b2e090204b69df"
+SRCREV_qt3d = "9eab5800f53c50fe332967d811fce4bf8b97e933"
+SRCREV_assimp = "d71020db155e9b2d4dba5562c980c016cde77f4c"
diff --git a/recipes-qt/qt6/qt5compat_git.bb b/recipes-qt/qt6/qt5compat_git.bb
index 1c6a6eb..91fddc4 100644
--- a/recipes-qt/qt6/qt5compat_git.bb
+++ b/recipes-qt/qt6/qt5compat_git.bb
@@ -17,4 +17,4 @@ DEPENDS += "qtbase"
PACKAGECONFIG[iconv] = "-DFEATURE_iconv=ON,-DFEATURE_iconv=OFF,virtual/libiconv"
-SRCREV = "e8b4c8c245765827377cf634a081cabc544770c3"
+SRCREV = "8228a999c79c244eb361bd1259bede49f394b853"
diff --git a/recipes-qt/qt6/qt6-git.inc b/recipes-qt/qt6/qt6-git.inc
index e8ae7e7..fec0650 100644
--- a/recipes-qt/qt6/qt6-git.inc
+++ b/recipes-qt/qt6/qt6-git.inc
@@ -2,7 +2,7 @@ DESCRIPTION ?= "Qt is a cross-platform application development framework for des
HOMEPAGE ?= "https://www.qt.io"
QT_MODULE ?= "${BPN}"
-QT_MODULE_BRANCH ?= "dev"
+QT_MODULE_BRANCH ?= "6.1"
QT_MODULE_BRANCH_PARAM ?= "branch=${QT_MODULE_BRANCH}"
SRC_URI = "${QT_GIT}/${QT_GIT_PROJECT}/${QT_MODULE}.git;name=${QT_MODULE};${QT_MODULE_BRANCH_PARAM};protocol=${QT_GIT_PROTOCOL}"
diff --git a/recipes-qt/qt6/qtbase/0002-qlibraryinfo-allow-to-set-qt.conf-from-the-outside-u.patch b/recipes-qt/qt6/qtbase/0002-qlibraryinfo-allow-to-set-qt.conf-from-the-outside-u.patch
index da36a76..9e2cb07 100644
--- a/recipes-qt/qt6/qtbase/0002-qlibraryinfo-allow-to-set-qt.conf-from-the-outside-u.patch
+++ b/recipes-qt/qt6/qtbase/0002-qlibraryinfo-allow-to-set-qt.conf-from-the-outside-u.patch
@@ -1,8 +1,8 @@
-From fd50da53d4de86fe3a9e3eca24a7ae3e5c0f53fa Mon Sep 17 00:00:00 2001
+From dbbb5f6695c4fb8e01842ddb0b0690f60b62e061 Mon Sep 17 00:00:00 2001
From: Holger Freyther <zecke@selfish.org>
Date: Wed, 26 Sep 2012 17:22:30 +0200
-Subject: [PATCH 2/3] qlibraryinfo: allow to set qt.conf from the outside using
- the environment
+Subject: [PATCH] qlibraryinfo: allow to set qt.conf from the outside using the
+ environment
Allow to set a qt.conf from the outside using the environment. This allows
to inject new prefixes and other paths into qmake. This is needed when using
@@ -20,10 +20,10 @@ Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com>
1 file changed, 4 insertions(+), 1 deletion(-)
diff --git a/src/corelib/global/qlibraryinfo.cpp b/src/corelib/global/qlibraryinfo.cpp
-index c8c7c0bf9b..90e81d0990 100644
+index a86436f4c8..c5856f6750 100644
--- a/src/corelib/global/qlibraryinfo.cpp
+++ b/src/corelib/global/qlibraryinfo.cpp
-@@ -183,7 +183,10 @@ void QLibrarySettings::load()
+@@ -181,7 +181,10 @@ void QLibrarySettings::load()
QSettings *QLibraryInfoPrivate::findConfiguration()
{
#ifdef QT_BUILD_QMAKE
@@ -32,6 +32,6 @@ index c8c7c0bf9b..90e81d0990 100644
+ QString qtconfig = QFile::decodeName(config);
+ if(qtconfig.isEmpty() || !QFile::exists(qtconfig))
+ qtconfig = qmake_libraryInfoFile();
- if (QFile::exists(qtconfig))
+ if (!qtconfig.isEmpty())
return new QSettings(qtconfig, QSettings::IniFormat);
#else
diff --git a/recipes-qt/qt6/qtbase_git.bb b/recipes-qt/qt6/qtbase_git.bb
index 5ac6088..094a0b0 100644
--- a/recipes-qt/qt6/qtbase_git.bb
+++ b/recipes-qt/qt6/qtbase_git.bb
@@ -149,4 +149,4 @@ FILES_${PN}-tools += "\
BBCLASSEXTEND =+ "native nativesdk"
-SRCREV = "c2657f9762e01abd65ac991ba31e3ca085d9540c"
+SRCREV = "2c55e121c22601d365aa353cfa39ee856770855c"
diff --git a/recipes-qt/qt6/qtcharts_git.bb b/recipes-qt/qt6/qtcharts_git.bb
index d26cc86..22fa3bf 100644
--- a/recipes-qt/qt6/qtcharts_git.bb
+++ b/recipes-qt/qt6/qtcharts_git.bb
@@ -10,4 +10,4 @@ include recipes-qt/qt6/qt6.inc
DEPENDS += "qtbase qtdeclarative"
-SRCREV = "6e9df608606fc67480e2e7c0aa473b13389db2a4"
+SRCREV = "5a51145d190291ed9bc605d85379d9642d6214ac"
diff --git a/recipes-qt/qt6/qtcoap_git.bb b/recipes-qt/qt6/qtcoap_git.bb
index 6425e87..644abdd 100644
--- a/recipes-qt/qt6/qtcoap_git.bb
+++ b/recipes-qt/qt6/qtcoap_git.bb
@@ -12,4 +12,4 @@ DEPENDS += "qtbase"
PACKAGECONFIG[examples] = "-DQT_BUILD_EXAMPLES=ON,-DQT_BUILD_EXAMPLES=OFF,qtdeclarative"
-SRCREV = "7c1d0c871e89f2faad14fc5883b024dd532d3e9c"
+SRCREV = "b29fa915b16fd3602bdf89cf52a2aa7c336ac19d"
diff --git a/recipes-qt/qt6/qtdeclarative_git.bb b/recipes-qt/qt6/qtdeclarative_git.bb
index 9790124..9bf22f7 100644
--- a/recipes-qt/qt6/qtdeclarative_git.bb
+++ b/recipes-qt/qt6/qtdeclarative_git.bb
@@ -16,4 +16,4 @@ DEPENDS += "qtbase qtdeclarative-native"
BBCLASSEXTEND =+ "native nativesdk"
-SRCREV = "c2c180e4ee58f8cfc104207b3b56e83ddcb7e79a"
+SRCREV = "e7695ce2ca2e8aa29c8b689f4cdb97e8b8fa43ef"
diff --git a/recipes-qt/qt6/qtdeviceutilities_git.bb b/recipes-qt/qt6/qtdeviceutilities_git.bb
index 78525b9..97177c4 100644
--- a/recipes-qt/qt6/qtdeviceutilities_git.bb
+++ b/recipes-qt/qt6/qtdeviceutilities_git.bb
@@ -5,6 +5,8 @@ inherit qt6-cmake
include recipes-qt/qt6/qt6.inc
include recipes-qt/qt6/qt6-git.inc
+QT_MODULE_BRANCH = "dev"
+
DEPENDS = "qtbase qtdeclarative qtdeclarative-native qtvirtualkeyboard"
RDEPENDS_${PN} = "connman"
diff --git a/recipes-qt/qt6/qtgraphicaleffects_git.bb b/recipes-qt/qt6/qtgraphicaleffects_git.bb
index 2e5cfc1..a023e39 100644
--- a/recipes-qt/qt6/qtgraphicaleffects_git.bb
+++ b/recipes-qt/qt6/qtgraphicaleffects_git.bb
@@ -10,6 +10,8 @@ inherit qt6-cmake
include recipes-qt/qt6/qt6-git.inc
include recipes-qt/qt6/qt6.inc
+QT_MODULE_BRANCH = "dev"
+
DEPENDS += "qtbase qtdeclarative"
SRCREV = "2910bb5d11da4261a88bd57c7251d86c51bb57d3"
diff --git a/recipes-qt/qt6/qtimageformats_git.bb b/recipes-qt/qt6/qtimageformats_git.bb
index ce7b07f..a72a742 100644
--- a/recipes-qt/qt6/qtimageformats_git.bb
+++ b/recipes-qt/qt6/qtimageformats_git.bb
@@ -24,4 +24,4 @@ PACKAGECONFIG[mng] = "-DFEATURE_mng=ON,-DFEATURE_mng=OFF,libmng"
PACKAGECONFIG[tiff] = "-DFEATURE_tiff=ON,-DFEATURE_libtiff=OFF,tiff"
PACKAGECONFIG[webp] = "-DFEATURE_webp=ON,-DFEATURE_webp=OFF,libwebp"
-SRCREV = "6dc07aa351c5da856f992862f7260096e7ce35bb"
+SRCREV = "1533e2b1a90425d1469fb450160bb852f7145db9"
diff --git a/recipes-qt/qt6/qtmqtt_git.bb b/recipes-qt/qt6/qtmqtt_git.bb
index 015ef06..8854df2 100644
--- a/recipes-qt/qt6/qtmqtt_git.bb
+++ b/recipes-qt/qt6/qtmqtt_git.bb
@@ -13,4 +13,4 @@ DEPENDS += "qtbase"
PACKAGECONFIG[examples] = "-DQT_BUILD_EXAMPLES=ON,-DQT_BUILD_EXAMPLES=OFF,qtdeclarative qtwebsockets"
-SRCREV = "cfd837ee491f82cffb5c137a35dec958dd25fd15"
+SRCREV = "f12a79d635d776107fc86ebda516af69c9374545"
diff --git a/recipes-qt/qt6/qtnetworkauth_git.bb b/recipes-qt/qt6/qtnetworkauth_git.bb
index 009cd39..e960ab6 100644
--- a/recipes-qt/qt6/qtnetworkauth_git.bb
+++ b/recipes-qt/qt6/qtnetworkauth_git.bb
@@ -11,4 +11,4 @@ include recipes-qt/qt6/qt6.inc
DEPENDS += "qtbase"
-SRCREV = "efdcb01ad03bc43de2eb8f6611d9b6b777108441"
+SRCREV = "63949973b71194bc47141f1b67dc8b616160a697"
diff --git a/recipes-qt/qt6/qtopcua_git.bb b/recipes-qt/qt6/qtopcua_git.bb
index 265924a..0dae513 100644
--- a/recipes-qt/qt6/qtopcua_git.bb
+++ b/recipes-qt/qt6/qtopcua_git.bb
@@ -21,4 +21,4 @@ SECURITY_STRINGFORMAT = ""
DEPENDS += "qtbase"
-SRCREV = "e0df4cf65e25519a69d1a98b389abf7bda2380bb"
+SRCREV = "4a54de0d44addf9a26b9cd7bce1e4131c60ee539"
diff --git a/recipes-qt/qt6/qtquick3d_git.bb b/recipes-qt/qt6/qtquick3d_git.bb
index eb4ce3b..5ea9bfa 100644
--- a/recipes-qt/qt6/qtquick3d_git.bb
+++ b/recipes-qt/qt6/qtquick3d_git.bb
@@ -9,7 +9,7 @@ include recipes-qt/qt6/qt6-git.inc
include recipes-qt/qt6/qt6.inc
SRC_URI += " \
- ${QT_GIT}/${QT_GIT_PROJECT}/qtquick3d-assimp.git;name=assimp;branch=upstream/master;protocol=${QT_GIT_PROTOCOL};destsuffix=git/src/3rdparty/assimp/src \
+ ${QT_GIT}/${QT_GIT_PROJECT}/qtquick3d-assimp.git;name=assimp;branch=qt6.1_assimp;protocol=${QT_GIT_PROTOCOL};destsuffix=git/src/3rdparty/assimp/src \
file://0001-CMake-allow-tools-build-without-opengl.patch \
"
@@ -25,5 +25,5 @@ FILES_${PN}-qmlplugins += " \
"
SRCREV_FORMAT = "qtquick3d_assimp"
-SRCREV_qtquick3d = "2e9f76543951ca2039f66573697aaf94a8023fd6"
+SRCREV_qtquick3d = "363640c657fbd2559c1995b3d1c08fe65e59f61e"
SRCREV_assimp = "b3e1ee3ca0d825d384044867fc30cd0bc8417be6"
diff --git a/recipes-qt/qt6/qtquickcontrols2_git.bb b/recipes-qt/qt6/qtquickcontrols2_git.bb
index 4b977b5..00db7fe 100644
--- a/recipes-qt/qt6/qtquickcontrols2_git.bb
+++ b/recipes-qt/qt6/qtquickcontrols2_git.bb
@@ -12,4 +12,4 @@ include recipes-qt/qt6/qt6.inc
DEPENDS = "qtbase qtdeclarative"
-SRCREV = "83f49d3f4c0041bf2c74ff1ff2eb03c5d37aa1f4"
+SRCREV = "ab49d333726ab4649a93f08216b9a34873f3fe57"
diff --git a/recipes-qt/qt6/qtquicktimeline_git.bb b/recipes-qt/qt6/qtquicktimeline_git.bb
index f3fb141..aa3f87c 100644
--- a/recipes-qt/qt6/qtquicktimeline_git.bb
+++ b/recipes-qt/qt6/qtquicktimeline_git.bb
@@ -11,4 +11,4 @@ include recipes-qt/qt6/qt6.inc
DEPENDS = "qtbase qtdeclarative"
-SRCREV = "2a85480c4cec9e9beb0120c02da8c7faa1fae838"
+SRCREV = "867cbb07f37f90a07adbca57591897036be82118"
diff --git a/recipes-qt/qt6/qtserialbus_git.bb b/recipes-qt/qt6/qtserialbus_git.bb
index 6f630fb..bbd2da5 100644
--- a/recipes-qt/qt6/qtserialbus_git.bb
+++ b/recipes-qt/qt6/qtserialbus_git.bb
@@ -6,13 +6,15 @@ LIC_FILES_CHKSUM = " \
file://LICENSE.LGPLv3;md5=e0459b45c5c4840b353141a8bbed91f0 \
"
-inherit qt6-qmake
+inherit qt6-cmake
include recipes-qt/qt6/qt6-git.inc
include recipes-qt/qt6/qt6.inc
+QT_MODULE_BRANCH = "dev"
+
DEPENDS += "qtbase qtserialport qtserialbus-native"
BBCLASSEXTEND =+ "native nativesdk"
-SRCREV = "867b4d428f78fffe7fefeffaa2f819c9f345da26"
+SRCREV = "227060f8c17aaf90fe542ad6079a6badaf410a0d"
diff --git a/recipes-qt/qt6/qtserialport_git.bb b/recipes-qt/qt6/qtserialport_git.bb
index b684582..95260ab 100644
--- a/recipes-qt/qt6/qtserialport_git.bb
+++ b/recipes-qt/qt6/qtserialport_git.bb
@@ -7,13 +7,15 @@ LIC_FILES_CHKSUM = " \
file://LICENSE.LGPL3;md5=e6a600fd5e1d9cbde2d983680233ad02 \
"
-inherit qt6-qmake
+inherit qt6-cmake
include recipes-qt/qt6/qt6-git.inc
include recipes-qt/qt6/qt6.inc
+QT_MODULE_BRANCH = "dev"
+
DEPENDS += "qtbase"
BBCLASSEXTEND =+ "native nativesdk"
-SRCREV = "5433343796549dc3393b341a2f65b398f8f4134d"
+SRCREV = "1aaaa4997f0deb69af76793620443218ab0459f3"
diff --git a/recipes-qt/qt6/qtshadertools_git.bb b/recipes-qt/qt6/qtshadertools_git.bb
index db45f0d..7441365 100644
--- a/recipes-qt/qt6/qtshadertools_git.bb
+++ b/recipes-qt/qt6/qtshadertools_git.bb
@@ -12,4 +12,4 @@ DEPENDS = "qtbase qtshadertools-native"
BBCLASSEXTEND =+ "native nativesdk"
-SRCREV = "984df1fa87adcef3e05730e3ec4c4bf56b4ea0d4"
+SRCREV = "9994ae7c0e5c0d724e1167e28d144039a31fe813"
diff --git a/recipes-qt/qt6/qtspeech_git.bb b/recipes-qt/qt6/qtspeech_git.bb
index 6f2af98..3a67398 100644
--- a/recipes-qt/qt6/qtspeech_git.bb
+++ b/recipes-qt/qt6/qtspeech_git.bb
@@ -7,10 +7,11 @@ LIC_FILES_CHKSUM = " \
inherit qt6-qmake
-
include recipes-qt/qt6/qt6-git.inc
include recipes-qt/qt6/qt6.inc
+QT_MODULE_BRANCH = "dev"
+
DEPENDS += "qtbase"
SRCREV = "cda67019fff449d5793f9d5116e6226247ce7a7c"
diff --git a/recipes-qt/qt6/qtsvg_git.bb b/recipes-qt/qt6/qtsvg_git.bb
index f56e060..4a69d40 100644
--- a/recipes-qt/qt6/qtsvg_git.bb
+++ b/recipes-qt/qt6/qtsvg_git.bb
@@ -13,4 +13,4 @@ include recipes-qt/qt6/qt6.inc
DEPENDS += "qtbase"
-SRCREV = "ff0bd2573e32730782d689870ed1cc9379a3e9fb"
+SRCREV = "b80bab342072c3199e3e25187ce337e67543ffa3"
diff --git a/recipes-qt/qt6/qttools_git.bb b/recipes-qt/qt6/qttools_git.bb
index f641e43..6dedb71 100644
--- a/recipes-qt/qt6/qttools_git.bb
+++ b/recipes-qt/qt6/qttools_git.bb
@@ -18,4 +18,4 @@ FILES_${PN}-tools += "${QT6_INSTALL_DATADIR}/phrasebooks"
BBCLASSEXTEND =+ "native nativesdk"
-SRCREV = "2393e68dd5b2566a16cd8296fe0493c77eae22cb"
+SRCREV = "e33fd6658e140b68774c9d1c7fa25572e7da7386"
diff --git a/recipes-qt/qt6/qttranslations_git.bb b/recipes-qt/qt6/qttranslations_git.bb
index 5aa4e7b..5d07be5 100644
--- a/recipes-qt/qt6/qttranslations_git.bb
+++ b/recipes-qt/qt6/qttranslations_git.bb
@@ -18,4 +18,4 @@ python populate_packages_prepend () {
'Qt translations for %s', extra_depends='')
}
-SRCREV = "ca19f7c57cc84f699976958770524063dfaf33e5"
+SRCREV = "99a03ea4a06f6cbe91c08cbb7da4c82f4522b4c6"
diff --git a/recipes-qt/qt6/qtvirtualkeyboard_git.bb b/recipes-qt/qt6/qtvirtualkeyboard_git.bb
index 84e0e15..4bd32e4 100644
--- a/recipes-qt/qt6/qtvirtualkeyboard_git.bb
+++ b/recipes-qt/qt6/qtvirtualkeyboard_git.bb
@@ -116,4 +116,4 @@ FILES_${PN}-dictionaries = "${QT6_INSTALL_DATADIR}/qtvirtualkeyboard/*/*.dat"
DEPENDS += "qtbase qtdeclarative qtsvg qtdeclarative-native"
-SRCREV = "90d64dea7d0370abcb5b787bcc77dc4770f491ed"
+SRCREV = "98d04c0e58393d4a2d215b91e783997e68c57519"
diff --git a/recipes-qt/qt6/qtwayland_git.bb b/recipes-qt/qt6/qtwayland_git.bb
index 91580b2..5e904a2 100644
--- a/recipes-qt/qt6/qtwayland_git.bb
+++ b/recipes-qt/qt6/qtwayland_git.bb
@@ -37,4 +37,4 @@ DEPENDS += "qtbase qtdeclarative qtwayland-native wayland wayland-native"
BBCLASSEXTEND =+ "native nativesdk"
-SRCREV = "e8e112e50bd27472a2cf3f65c10555f966a78454"
+SRCREV = "64e51ef43fea77a7c7a525e212f172d46f530764"
diff --git a/recipes-qt/qt6/qtwebsockets_git.bb b/recipes-qt/qt6/qtwebsockets_git.bb
index c63f258..b404e22 100644
--- a/recipes-qt/qt6/qtwebsockets_git.bb
+++ b/recipes-qt/qt6/qtwebsockets_git.bb
@@ -11,6 +11,8 @@ inherit qt6-cmake
include recipes-qt/qt6/qt6-git.inc
include recipes-qt/qt6/qt6.inc
+QT_MODULE_BRANCH = "dev"
+
DEPENDS += "qtbase qtdeclarative"
-SRCREV = "fa6c7e50321e7be048297e5d0ce8503647a9488e"
+SRCREV = "69b87fc663f86b8cdeddd954a8a8449f783598b5"