aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorSamuli Piippo <samuli.piippo@qt.io>2023-12-04 10:05:36 +0000
committerSamuli Piippo <samuli.piippo@qt.io>2023-12-04 17:35:22 +0000
commit7b5020d1a1dcf2fd34f4a4ad07d0807311e03477 (patch)
treee578dfdaa1eb1149c834fe1ded85da0251bc604e
parente3e5eaa498e54420668f50c0ef75f3c1011be67d (diff)
qtinterfaceframework: remove simulation and reference api
The simulation and reference api implementations were removed from qtinterfaceframework module. Change-Id: Iff7bcd4591d0e8955d2a96aa8fe31f2af103a0cb Reviewed-by: Dominik Holland <dominik.holland@qt.io>
-rw-r--r--recipes-qt/qt6/qtinterfaceframework.inc35
-rw-r--r--recipes-qt/qt6/qtinterfaceframework/if-services.target3
-rw-r--r--recipes-qt/qt6/qtinterfaceframework/ifmedia-simulation-server.service13
-rw-r--r--recipes-qt/qt6/qtinterfaceframework/ifvehiclefunctions-simulation-server.service13
-rw-r--r--recipes-qt/qt6/qtinterfaceframework/simulation-server.conf8
-rw-r--r--recipes-qt/qt6/qtinterfaceframework_git.bb46
6 files changed, 3 insertions, 115 deletions
diff --git a/recipes-qt/qt6/qtinterfaceframework.inc b/recipes-qt/qt6/qtinterfaceframework.inc
deleted file mode 100644
index aee07f6..0000000
--- a/recipes-qt/qt6/qtinterfaceframework.inc
+++ /dev/null
@@ -1,35 +0,0 @@
-inherit systemd
-
-SRC_URI += " \
- file://ifmedia-simulation-server.service \
- file://ifvehiclefunctions-simulation-server.service \
- file://if-services.target \
- file://simulation-server.conf \
-"
-
-do_install:append:class-target() {
- install -m 0755 -d ${D}${systemd_unitdir}/system
- install -m 0644 ${WORKDIR}/ifmedia-simulation-server.service ${D}${systemd_unitdir}/system/
- install -m 0644 ${WORKDIR}/ifvehiclefunctions-simulation-server.service ${D}${systemd_unitdir}/system/
- install -m 0644 ${WORKDIR}/if-services.target ${D}${systemd_unitdir}/system/
-
- install -m 0755 -d ${D}${sysconfdir}
- install -m 0755 ${WORKDIR}/simulation-server.conf ${D}${sysconfdir}/
-}
-
-SYSTEMD_PACKAGES = "${PN}-simulation"
-SYSTEMD_SERVICE:${PN}-simulation = " \
- ifmedia-simulation-server.service \
- ifvehiclefunctions-simulation-server.service \
- if-services.target \
- "
-
-PACKAGE_BEFORE_PN =+ "${PN}-simulation"
-FILES:${PN}-simulation = " \
- ${QT6_INSTALL_BINDIR}/ifmedia-simulation-server \
- ${QT6_INSTALL_BINDIR}/ifvehiclefunctions-simulation-server \
- ${QT6_INSTALL_PLUGINSDIR}/interfaceframework/ \
- ${systemd_unitdir}/system \
- ${sysconfdir}/simulation-server.conf \
- "
-RRECOMMENDS:${PN} += "${PN}-simulation"
diff --git a/recipes-qt/qt6/qtinterfaceframework/if-services.target b/recipes-qt/qt6/qtinterfaceframework/if-services.target
deleted file mode 100644
index 24d990e..0000000
--- a/recipes-qt/qt6/qtinterfaceframework/if-services.target
+++ /dev/null
@@ -1,3 +0,0 @@
-[Unit]
-Description=Qt Interface Framework services
-After=systemd-user-sessions.service
diff --git a/recipes-qt/qt6/qtinterfaceframework/ifmedia-simulation-server.service b/recipes-qt/qt6/qtinterfaceframework/ifmedia-simulation-server.service
deleted file mode 100644
index 2ecba90..0000000
--- a/recipes-qt/qt6/qtinterfaceframework/ifmedia-simulation-server.service
+++ /dev/null
@@ -1,13 +0,0 @@
-[Unit]
-Description=ifmedia-simulation-server
-PartOf=if-services.target
-Before=if-services.target
-
-[Service]
-User=root
-ExecStart=/usr/bin/ifmedia-simulation-server
-Restart=on-failure
-Environment=SERVER_CONF_PATH=/etc/simulation-server.conf
-
-[Install]
-WantedBy=if-services.target
diff --git a/recipes-qt/qt6/qtinterfaceframework/ifvehiclefunctions-simulation-server.service b/recipes-qt/qt6/qtinterfaceframework/ifvehiclefunctions-simulation-server.service
deleted file mode 100644
index 0929118..0000000
--- a/recipes-qt/qt6/qtinterfaceframework/ifvehiclefunctions-simulation-server.service
+++ /dev/null
@@ -1,13 +0,0 @@
-[Unit]
-Description=ifvehiclefunctions-simulation-server
-PartOf=if-services.target
-Before=if-services.target
-
-[Service]
-User=root
-ExecStart=/usr/bin/ifvehiclefunctions-simulation-server
-Restart=on-failure
-Environment=SERVER_CONF_PATH=/etc/simulation-server.conf
-
-[Install]
-WantedBy=if-services.target
diff --git a/recipes-qt/qt6/qtinterfaceframework/simulation-server.conf b/recipes-qt/qt6/qtinterfaceframework/simulation-server.conf
deleted file mode 100644
index 6b0a7af..0000000
--- a/recipes-qt/qt6/qtinterfaceframework/simulation-server.conf
+++ /dev/null
@@ -1,8 +0,0 @@
-[remotesettings]
-Registry=tcp://0.0.0.0:9999
-
-[drivedata]
-Registry=tcp://0.0.0.0:9998
-
-[qtifmedia]
-Registry=tcp://0.0.0.0:9997
diff --git a/recipes-qt/qt6/qtinterfaceframework_git.bb b/recipes-qt/qt6/qtinterfaceframework_git.bb
index f13d5b2..dcb4038 100644
--- a/recipes-qt/qt6/qtinterfaceframework_git.bb
+++ b/recipes-qt/qt6/qtinterfaceframework_git.bb
@@ -13,58 +13,18 @@ inherit qt6-cmake
include recipes-qt/qt6/qt6-git.inc
include recipes-qt/qt6/qt6.inc
-# Default build and package these
-REFERENCE_API ?= "1"
-SIMULATION_SUPPORT ?= "1"
-include ${@bb.utils.contains('SIMULATION_SUPPORT', '1', 'qtinterfaceframework.inc', '', d)}
-
FILES:${PN}-dev += " \
${QT6_INSTALL_DATADIR}/ifcodegen-templates \
"
-PACKAGE_BEFORE_PN =+ "${PN}-refapi-media"
-FILES:${PN}-refapi-media = "\
- ${QT6_INSTALL_LIBDIR}/libQt6IfMedia.so.* \
- ${QT6_INSTALL_LIBDIR}/qml/QtInterfaceFramework/Media \
- "
-
-PACKAGE_BEFORE_PN =+ "${PN}-refapi-vehiclefuntions"
-FILES:${PN}-refapi-vehiclefuntions = "\
- ${QT6_INSTALL_LIBDIR}/libQt6IfVehicleFunctions.so.* \
- ${QT6_INSTALL_LIBDIR}/qml/QtInterfaceFramework/VehicleFunctions \
- "
-
DEPENDS += "qtbase qtdeclarative qtdeclarative-native qtinterfaceframework-native"
-PRIVATE_LIBS:${PN}-examples = "libInstrumentCluster.so"
-
-PACKAGECONFIG ?= "ifcodegen remoteobjects interfaceframework \
- ${PACKAGECONFIG_REFERENCE_API} \
- ${PACKAGECONFIG_SIMULATION} \
- "
+PACKAGECONFIG ?= "ifcodegen remoteobjects"
+PACKAGECONFIG:append:class-native = " host-tools-only"
+PACKAGECONFIG:append:class-nativesdk = " host-tools-only"
-PACKAGECONFIG[taglib] = "-DFEATURE_taglib=ON,-DFEATURE_taglib=OFF,taglib"
PACKAGECONFIG[host-tools-only] = "-DFEATURE_host_tools_only=ON,-DFEATURE_host_tools_only=OFF"
PACKAGECONFIG[ifcodegen] = "-DFEATURE_ifcodegen=ON,-DFEATURE_ifcodegen=OFF,python3-qface,python3-qface"
PACKAGECONFIG[remoteobjects] = "-DFEATURE_remoteobjects=ON,-DFEATURE_remoteobjects=OFF,qtremoteobjects qtremoteobjects-native"
-#interfaceframework only
-PACKAGECONFIG[interfaceframework] = "-DFEATURE_interfaceframework=ON,-DFEATURE_interfaceframework=OFF"
-
-# reference API's
-PACKAGECONFIG[ifmedia] = "-DFEATURE_ifmedia=ON,-DFEATURE_ifmedia=OFF,qtmultimedia"
-PACKAGECONFIG[ifvehiclefunctions] = "-DFEATURE_ifvehiclefunctions=ON,-DFEATURE_ifvehiclefunctions=OFF"
-
-PACKAGECONFIG_REFERENCE_API ?= "${@bb.utils.contains('REFERENCE_API', '1', 'ifvehiclefunctions ifmedia taglib', '', d)}"
-
-# simulation support
-PACKAGECONFIG[no-media-simulation] = "-DFEATURE_media_qtro_backend=OFF -DFEATURE_media_qtro_simulation_server=OFF -DFEATURE_media_simulation_backend=OFF -DFEATURE_tuner_simulation_backend=OFF"
-PACKAGECONFIG[no-vehiclefuntions-simulation] = "-DFEATURE_vehiclefunctions_qtro_backend=OFF -DFEATURE_vehiclefunctions_qtro_simulation_server=OFF -DFEATURE_vehiclefunctions_simulation_backend=OFF"
-
-PACKAGECONFIG_SIMULATION ?= "${@bb.utils.contains('SIMULATION_SUPPORT', '1', '', 'no-media-simulation no-vehiclefuntions-simulation', d)}"
-
-PACKAGECONFIG:class-native ??= "interfaceframework ifcodegen host-tools-only remoteobjects"
-PACKAGECONFIG:class-nativesdk ??= "${PACKAGECONFIG:class-native}"
-
BBCLASSEXTEND = "native nativesdk"
-