aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorSamuli Piippo <samuli.piippo@qt.io>2024-01-26 08:38:30 +0000
committerSamuli Piippo <samuli.piippo@qt.io>2024-01-31 09:59:45 +0000
commit8d3758ce9eeafa3756301409b090c8deb363fa1f (patch)
tree6c6f592e73d754f3886b09748a9ff00f4dde2ea0
parent564f560b5086b2035325b6f1ffbdc27be8395127 (diff)
packagegroup: fix warning caused by inherit_defer
Yocto scarthgap is now using inherit_defer which causes allarch to be inherited last, when nativesdk wants to always be the last one. Workaround this by setting PACKAGE_ARCH to empty, which causes the allarch inherit to be skipped. PACKAGE_ARCH will still end up being the same value, as packagegroup will set it correctly. Fixes QA Issue: nativesdk-packagegroup-qt6-toolchain-host: native/nativesdk class is not inherited last, this can result in unexpected behaviour. Pick-to: 6.7 6.6 6.5 Change-Id: I0457a62333d88b14c3330e3349f585dc6c3eec35 Reviewed-by: Mikko Gronoff <mikko.gronoff@qt.io>
-rw-r--r--recipes-qt/packagegroups/nativesdk-packagegroup-qt6-toolchain-host.bb3
1 files changed, 3 insertions, 0 deletions
diff --git a/recipes-qt/packagegroups/nativesdk-packagegroup-qt6-toolchain-host.bb b/recipes-qt/packagegroups/nativesdk-packagegroup-qt6-toolchain-host.bb
index e40a263..dddb142 100644
--- a/recipes-qt/packagegroups/nativesdk-packagegroup-qt6-toolchain-host.bb
+++ b/recipes-qt/packagegroups/nativesdk-packagegroup-qt6-toolchain-host.bb
@@ -1,6 +1,9 @@
DESCRIPTION = "Qt6 development host packages"
LICENSE = "MIT"
+# avoid warning with inherit_defer allarch
+PACKAGE_ARCH = ""
+
inherit packagegroup nativesdk
PACKAGEGROUP_DISABLE_COMPLEMENTARY = "1"