aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorMikko Gronoff <mikko.gronoff@qt.io>2020-10-26 14:49:37 +0200
committerMikko Gronoff <mikko.gronoff@qt.io>2020-10-30 08:59:31 +0200
commit9d8e570f041d08c551adf8e6de98c5ba9317b1b7 (patch)
tree7dc3d0342a1ed320a38d5eff23c94f8cd2b794cd
parentea5a87ff4df25917101549f0027db34da66476fc (diff)
qt6: update submodulesv6.0.0-beta2
Update submodules to beta2 revisions. Task-number: QTBUG-86349 Change-Id: Iddd5da3a62bd397b9b2941b8fd89e71e15a0a6a7 Reviewed-by: Samuli Piippo <samuli.piippo@qt.io>
-rw-r--r--recipes-qt/qt6/qt3d/0001-Fix-compilation-with-latest-QMutexLocker-changed.patch22
-rw-r--r--recipes-qt/qt6/qt3d_git.bb3
-rw-r--r--recipes-qt/qt6/qt5compat_git.bb2
-rw-r--r--recipes-qt/qt6/qtbase_git.bb5
-rw-r--r--recipes-qt/qt6/qtdeclarative_git.bb2
-rw-r--r--recipes-qt/qt6/qtquick3d_git.bb2
-rw-r--r--recipes-qt/qt6/qtquickcontrols2_git.bb2
-rw-r--r--recipes-qt/qt6/qtquicktimeline_git.bb2
-rw-r--r--recipes-qt/qt6/qtshadertools_git.bb2
-rw-r--r--recipes-qt/qt6/qtsvg_git.bb2
-rw-r--r--recipes-qt/qt6/qttools_git.bb2
-rw-r--r--recipes-qt/qt6/qttranslations_git.bb2
-rw-r--r--recipes-qt/qt6/qtwayland_git.bb2
13 files changed, 38 insertions, 12 deletions
diff --git a/recipes-qt/qt6/qt3d/0001-Fix-compilation-with-latest-QMutexLocker-changed.patch b/recipes-qt/qt6/qt3d/0001-Fix-compilation-with-latest-QMutexLocker-changed.patch
new file mode 100644
index 0000000..03785dc
--- /dev/null
+++ b/recipes-qt/qt6/qt3d/0001-Fix-compilation-with-latest-QMutexLocker-changed.patch
@@ -0,0 +1,22 @@
+From 1c7c8ce10b76afa98f46e98523c0cb91211dba85 Mon Sep 17 00:00:00 2001
+From: Mikko Gronoff <mikko.gronoff@qt.io>
+Date: Wed, 28 Oct 2020 12:21:27 +0200
+Subject: [PATCH] Fix compilation with latest QMutexLocker changed
+
+---
+ src/core/resources/qresourcemanager_p.h | 2 +-
+ 1 file changed, 1 insertion(+), 1 deletion(-)
+
+diff --git a/src/core/resources/qresourcemanager_p.h b/src/core/resources/qresourcemanager_p.h
+index 82e8ad17f..954f7b5e4 100644
+--- a/src/core/resources/qresourcemanager_p.h
++++ b/src/core/resources/qresourcemanager_p.h
+@@ -165,7 +165,7 @@ public :
+ }
+
+ private:
+- QMutexLocker m_locker;
++ QMutexLocker<QMutex> m_locker;
+ };
+
+ private:
diff --git a/recipes-qt/qt6/qt3d_git.bb b/recipes-qt/qt6/qt3d_git.bb
index 27bc27b..0ac0826 100644
--- a/recipes-qt/qt6/qt3d_git.bb
+++ b/recipes-qt/qt6/qt3d_git.bb
@@ -15,6 +15,7 @@ include recipes-qt/qt6/qt6.inc
SRC_URI += " \
git://github.com/assimp/assimp.git;name=assimp;branch=assimp_5.0_release;protocol=https;destsuffix=git/src/3rdparty/assimp/src \
+ file://0001-Fix-compilation-with-latest-QMutexLocker-changed.patch \
"
DEPENDS = "qtbase qtdeclarative qtshadertools-native"
@@ -25,5 +26,5 @@ PACKAGECONFIG[system-assimp] = "-DFEATURE_system_assimp=ON,-DQT_FEATURE_system_a
PACKAGECONFIG[qtgamepad] = ",,qtgamepad"
SRCREV_FORMAT = "qt3d_assimp"
-SRCREV_qt3d = "92a8d07e339fa19b7c9344dc8279aeaf7256a06c"
+SRCREV_qt3d = "f852aa731e3fdc79a4045425bc424fbbd3a4e50a"
SRCREV_assimp = "8f0c6b04b2257a520aaab38421b2e090204b69df"
diff --git a/recipes-qt/qt6/qt5compat_git.bb b/recipes-qt/qt6/qt5compat_git.bb
index d97e556..5e5b294 100644
--- a/recipes-qt/qt6/qt5compat_git.bb
+++ b/recipes-qt/qt6/qt5compat_git.bb
@@ -15,4 +15,4 @@ include recipes-qt/qt6/qt6-git.inc
DEPENDS += "qtbase"
-SRCREV = "1da66bfbab19d912fb2bd6b48d6c569444cc9215"
+SRCREV = "a892088d556b99fbcf1ceb00753f72d18fb00a71"
diff --git a/recipes-qt/qt6/qtbase_git.bb b/recipes-qt/qt6/qtbase_git.bb
index eb31cf8..b239436 100644
--- a/recipes-qt/qt6/qtbase_git.bb
+++ b/recipes-qt/qt6/qtbase_git.bb
@@ -115,6 +115,9 @@ EXTRA_OECMAKE_append_class-target = "\
-DQT_QPA_DEFAULT_PLATFORM=${QT_QPA_DEFAULT_PLATFORM} \
"
+# mkspecs have mac specific scripts that depend on perl and bash
+SKIP_FILEDEPS_${PN}-dev = "1"
+
SYSROOT_DIRS += "${QT6_INSTALL_MKSPECSDIR}"
do_install_append() {
@@ -136,4 +139,4 @@ FILES_${PN}-tools += "\
BBCLASSEXTEND =+ "native nativesdk"
-SRCREV = "86d2f7f365c35f9833f3cf5c5731a8c258ad8ec4"
+SRCREV = "b6cd3bca280bd81e932ff51a3ec2b9fc70231646"
diff --git a/recipes-qt/qt6/qtdeclarative_git.bb b/recipes-qt/qt6/qtdeclarative_git.bb
index fdc8911..44c7f05 100644
--- a/recipes-qt/qt6/qtdeclarative_git.bb
+++ b/recipes-qt/qt6/qtdeclarative_git.bb
@@ -16,4 +16,4 @@ DEPENDS += "qtbase qtdeclarative-native"
BBCLASSEXTEND =+ "native nativesdk"
-SRCREV = "22e0701ee8baaf20a996abc3773e391687cbad70"
+SRCREV = "d22ea28589767189cb0e38fc68bf5d7f308d0417"
diff --git a/recipes-qt/qt6/qtquick3d_git.bb b/recipes-qt/qt6/qtquick3d_git.bb
index 52f1985..c1c69d7 100644
--- a/recipes-qt/qt6/qtquick3d_git.bb
+++ b/recipes-qt/qt6/qtquick3d_git.bb
@@ -25,5 +25,5 @@ _FILES_${PN}-qmlplugins += " \
"
SRCREV_FORMAT = "qtquick3d_assimp"
-SRCREV_qtquick3d = "772fd7f3eb2a51f796ec000536765b1de748bbc1"
+SRCREV_qtquick3d = "8841bcc50dfd2d50accc9e793bbdb6e3d23ea508"
SRCREV_assimp = "8f0c6b04b2257a520aaab38421b2e090204b69df"
diff --git a/recipes-qt/qt6/qtquickcontrols2_git.bb b/recipes-qt/qt6/qtquickcontrols2_git.bb
index aa79e24..edb437c 100644
--- a/recipes-qt/qt6/qtquickcontrols2_git.bb
+++ b/recipes-qt/qt6/qtquickcontrols2_git.bb
@@ -12,4 +12,4 @@ include recipes-qt/qt6/qt6.inc
DEPENDS = "qtbase qtdeclarative"
-SRCREV = "54bf57ec19162c5a9b8a880e3da60d8781f4c908"
+SRCREV = "7f72d97132f33ea5fd8f81945fecde9c8a268186"
diff --git a/recipes-qt/qt6/qtquicktimeline_git.bb b/recipes-qt/qt6/qtquicktimeline_git.bb
index 47b0874..95d5ff6 100644
--- a/recipes-qt/qt6/qtquicktimeline_git.bb
+++ b/recipes-qt/qt6/qtquicktimeline_git.bb
@@ -11,4 +11,4 @@ include recipes-qt/qt6/qt6.inc
DEPENDS = "qtbase qtdeclarative"
-SRCREV = "d55ca0253496ce75c3a46d0c9e7e10e0bbfdd1fd"
+SRCREV = "66471edfa249d77ff47dd1e38cad9a0ec1850531"
diff --git a/recipes-qt/qt6/qtshadertools_git.bb b/recipes-qt/qt6/qtshadertools_git.bb
index c3c7fd5..fd90e1f 100644
--- a/recipes-qt/qt6/qtshadertools_git.bb
+++ b/recipes-qt/qt6/qtshadertools_git.bb
@@ -12,4 +12,4 @@ DEPENDS = "qtbase qtshadertools-native"
BBCLASSEXTEND =+ "native nativesdk"
-SRCREV = "c096e4223b721ca8903511221b7250659c31f335"
+SRCREV = "013571627787b7c8b57644f3e41f83d142d03bab"
diff --git a/recipes-qt/qt6/qtsvg_git.bb b/recipes-qt/qt6/qtsvg_git.bb
index 3baaafa..7a19cd5 100644
--- a/recipes-qt/qt6/qtsvg_git.bb
+++ b/recipes-qt/qt6/qtsvg_git.bb
@@ -13,4 +13,4 @@ include recipes-qt/qt6/qt6.inc
DEPENDS += "qtbase"
-SRCREV = "be823374e9c4a90c4d8c93b23f684c36427cae4d"
+SRCREV = "5f45ccdf8bc09786766e8bd2f4b8c73dd7401812"
diff --git a/recipes-qt/qt6/qttools_git.bb b/recipes-qt/qt6/qttools_git.bb
index 94d834f..8da9bbc 100644
--- a/recipes-qt/qt6/qttools_git.bb
+++ b/recipes-qt/qt6/qttools_git.bb
@@ -16,4 +16,4 @@ DEPENDS += "qtbase qtdeclarative qttools-native"
BBCLASSEXTEND =+ "native nativesdk"
-SRCREV = "9e0ce81d7abb7ff1aca379b79c9729bf5cb6fbe6"
+SRCREV = "0867b74d0381c9b5b0cbff6cc5d24a4d6b9e8ad9"
diff --git a/recipes-qt/qt6/qttranslations_git.bb b/recipes-qt/qt6/qttranslations_git.bb
index 44d0ddf..e078f0d 100644
--- a/recipes-qt/qt6/qttranslations_git.bb
+++ b/recipes-qt/qt6/qttranslations_git.bb
@@ -18,4 +18,4 @@ python populate_packages_prepend () {
'Qt translations for %s', extra_depends='')
}
-SRCREV = "8c38aedb29aef78116c3b6e1a54851ef20688076"
+SRCREV = "d0097f07a3b247f1825b52aead61f0f5d51e4ff7"
diff --git a/recipes-qt/qt6/qtwayland_git.bb b/recipes-qt/qt6/qtwayland_git.bb
index dbdb714..b3cce0a 100644
--- a/recipes-qt/qt6/qtwayland_git.bb
+++ b/recipes-qt/qt6/qtwayland_git.bb
@@ -37,4 +37,4 @@ DEPENDS += "qtbase qtdeclarative qtwayland-native wayland wayland-native"
BBCLASSEXTEND =+ "native nativesdk"
-SRCREV = "84b330284ac8f98ed0f20bacae42b031990dabb9"
+SRCREV = "77b494d39a72e588dde9711d7ab2f7b43b1dc630"